or Connect
AVS › AVS Forum › Video Components › Home Theater Computers › ASRock H77M-ITX + Intel i3-3220T bitstreaming problem
New Posts  All Forums:Forum Nav:

ASRock H77M-ITX + Intel i3-3220T bitstreaming problem

post #1 of 5
Thread Starter 
I cannot seem to get bistreaming working on my new HTPC. I had it working fine on my old ATI 5760.

I'm running Windows 7 32bit.

I'm running the following:

Intel HD Graphics date 10/17/2012 version 9.17.10.2875
Realtek High Definition Audio 10/18/2011 version 6.0.1.6482 - Realtek Semiconductor Corp. - location 0
High Definition Audio Device 11/19/2010 version 6.1.7601.17514 - Microsoft - location 3

Under playback devices I've noticed some odd behavior
Sometimes it shows RX-V867 as audio device
Sometimes it shows SV470M (Vizio TV)

I've followed Assassin's MPC-HC guide, and also have tried TMT5. I seem to only get core DTS tracks when playing DTS-HD MA (Pirate Radio Bluray) or the DTS-HD MA test audio file I've found here on the forums.

If I use the Dolby TrueHD test file, sound comes through as PCM. I've tried just about every setting on the RX-V867 to set it in "Straight" mode to accept bitstreaming with no luck. I had this same issue while trying to configure an Nvidia GT430 and gave up and went with the ATI.

I'm not sure why I have a High Definition Audio Device and Realtek Audio Device. Also, why does my TV show up as the audio device? This functionality was different when using the ATI card.

Does anyone have any ideas? If there is any more additional info needed to help figure this out, let me know and I'll post it.

Screenshot one was taken before loading the Realtek drivers from the ASRock site. That is why the audio device list looks different. The one with SV470M is the current state.


post #2 of 5
Thread Starter 
Is there nobody with an ASRock + Intel HD Graphics that can help out?

Also, I put my ATI 5670 (sorry, listed 5760 in original post) and configured bistreaming just fine, so my AVR is not the problem. I've seen some posts that mention "Intel High Definition Audio" should be listed in playback devices, but mine does not. Is there something funky with ASRock that causes the functionality above? --- Either AVR or TV showing up as the playback device.
post #3 of 5
I have AsRock plus i5 in my HTPC but about to board a plane.

I'll help you out when I land at my layover.
post #4 of 5
Thread Starter 
Found the problem!

After loading the Realtek drivers, I forced the driver update of the "High Definition Audio Device" to the folder d:\asrock\VGA_Win8_Win7(v15.28.6.2857)\VGA(v15.28.6.2857)\DisplayAudio

Now it shows "Intel(R) Display Audio" and has the bitstreaming options!




One more question.. why would HDCP be not supported?


For some reason after all of my fiddling, my recorded videos in Win 7 Media Center got all choppy. I am not sure what went wrong. I have an Acronis drive image from 2 days ago that I'm going to restore then try to just update the Intel driver to see if that works.
post #5 of 5
Good news !!!

I just landed and waiting for next flight.

Happy to hear.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Home Theater Computers
AVS › AVS Forum › Video Components › Home Theater Computers › ASRock H77M-ITX + Intel i3-3220T bitstreaming problem