post #1 of 1
Thread Starter 
Gonna need some Linux brains on this one. I'm out of ideas. Going to be long, but I've done a lot of troubleshooting to come to the conclusion I've come to.

I run several MythTV frontends tied to one backend. The backend is built on ArchLinux, the Frontends are a mishmosh of Mint, Kubuntu, Xubuntu.

So, I'm trying to reconfigure the entire setup, build a new frontend/backend machine, ditch the ArchLinux (due to complexity). I built up a test machine with Xubuntu and MythTV on top of that (essentially homebrew Mythbuntu) as a frontend. Worked as I intented. So, I started on building up the backend/frontend combo.

This machine exists for two reasons. MythTV and VirtualBox to run Netflix (via Windows). So, I need both applications. I just build a menu button on the main menu of MythTV to open the VirtualBox.

Anyway, build it up, with Xubuntu and MythTV. I also swap out video cards for a silent (fanless) card. Get everything loaded, and go to play a video, which works fine, but when I exit the video, the system freezes. Just locks up and I need to do a hard reset of the system. I reload the OS and all the software, and again, system freezes up when I exit.

Irritated, I try Mythbuntu. Mythbuntu works great. No freezing on exit, but I have no audio in VirtualBox. This is where I learn that Xubuntu is using PulseAudio while Mythbuntu is using ALSA. Great, I keep a shell .asoundrc file around for just this situation that sets up dmix. I throw the .asoundrc file onto the system, and voila, I have audio in VirtualBox. Go to MythTV, play a video, I have audio there. Perfect!!! Now on to more configuring, except that when I exit the video, the system locks up.

So, I'm pretty confident the lock up is due to the dmix. Pulse does it by default, and ALSA has to be configured to do it.

The only thing different between a system that works and the new system is the video card. So, I put the video card from the working system into the machine, and I get the same issue.

The time between building the test machine and the new machine is about 2 weeks. Both machines used Xubuntu 12.10. Mythbuntu is 12.04.1.

No errors in the error log. Just a pure system freeze up.

Dmix is essential because, while I use all the internal players within MythTV for videos, I still need Netflix. I even tried the new Netflix-Desktop app that was released, and while it works, without dmix, there's no audio. So dmix is essential.

I'm getting no feedback on the Ubuntu forums. Google yields nothing. MythTV forums yield nothing. I have two weeks to get it figured out while I'm out of town on business. If nothing by then, I start the ArchLinux process, which is long and painful, but in the end always works.