or Connect
AVS › AVS Forum › Audio › Subwoofers, Bass, and Transducers › Klipsch RW-12d on sale for $299 at Newegg.com again today!
New Posts  All Forums:Forum Nav:

Klipsch RW-12d on sale for $299 at Newegg.com again today! - Page 74

post #2191 of 2776
Quote:
Originally Posted by lovinthehd View Post

I'd seen 699, 799 and 999....1499? I always thought msrp of 799 sounded about right....

$699-799 is close enough until someone who paid retail chimes in, if they do.
post #2192 of 2776
Quote:
Originally Posted by SanchoPanza View Post

$699-799 is close enough until someone who paid retail chimes in, if they do.
No one who paid retail is going to chime in. Everybody will laugh and make fun of them.
post #2193 of 2776
Hence the "if they do". Will need to find old thread IF available.
post #2194 of 2776
Quote:
Originally Posted by SanchoPanza View Post

$699-799 is close enough until someone who paid retail chimes in, if they do.

This Sound and Vision review from 2007 lists $699: http://www.soundandvisionmag.com/article/shootout-five-mid-price-subwoofers?page=0,3
post #2195 of 2776
Thank you
post #2196 of 2776
I just ordered one from Newegg for $279. It is showing available at $349 with a $70 coupon code good through 6/17/2013.

Newegg has sent me the tracking info too!

Paul
Edited by pwhittle - 6/14/13 at 10:35am
post #2197 of 2776
gonna need @ least 1 more, but my room is rather large
post #2198 of 2776
Mine arrived today (ordered Wednesday), going to try and take some sound measurements.



Good thing the subs were double-packed since there was damage to the outer box, nicely done by Newegg.
post #2199 of 2776
Find mine good for music can pick out the Bass (fiddle) in Jazz, for instance, but little notice in Movies, even less in tv.

Sure content drives this.
post #2200 of 2776
I love my dual RW-12Ds. I should of gone dual sooner. Sorry for the dirty carpet lol


Edited by GusGus748s - 6/16/13 at 11:38am
post #2201 of 2776
Does newegg usually run the $70 off coupon? I will be out of the country untill the 28th so i can not pick it up when it will be delivered but i don't want to miss this good deal.
post #2202 of 2776
Quote:
Originally Posted by austin8868 View Post

Does newegg usually run the $70 off coupon? I will be out of the country untill the 28th so i can not pick it up when it will be delivered but i don't want to miss this good deal.

Could you have them deliver to your workplace? or ship it to a neighbor or someone you trust...

I'm sure they will run out of them at some point, would be a shame to miss...
post #2203 of 2776
Quote:
Originally Posted by GusGus748s View Post

I love my dual RW-12Ds. I should of gone dual sooner. Sorry for the dirty carpet lol

Nice setup, I'm hoping your next purchase would be a carpet cleaner... smile.gif
post #2204 of 2776
Stuck on the beach, no Klipsch
post #2205 of 2776
Do any of you take sound measurements? Can the Audyssey mic be used? Can someone help me out with this? REW with Audyssey mic
Edited by shpitz - 6/19/13 at 8:19am
post #2206 of 2776
Quote:
Originally Posted by shpitz View Post

Nice setup, I'm hoping your next purchase would be a carpet cleaner... smile.gif

With two kids, two dogs and a cat... It's pretty difficult to keep anything clean lol.
post #2207 of 2776
Quote:
Originally Posted by BeeMan458 View Post

I've taken the time to add foam sheeting and poly-fil to each of our three Klipsch subwoofers and based on measurements, I can say unequivocally, money and time well spent. 

I guess, as with most things, YMMV. 

I used these:

http://www.walmart.com/ip/Morning-Glory-Foam-Seat-Cushions-4-Pack-16-L-x-16-W-x-1-H/19397511

and it looked like this:

 

 

 

Unsmoothed results from about 4 feet in front of the sub:

 

 

 

The bottom (green) line is with the port stuffed with a hand towel, in case anyone was curious about how closing the port might affect things. biggrin.gif

 

BTW, the driver weighs about 12.5 pounds, so, if you do want or need to get in there, be prepared to catch it when you take the last screw out. wink.gif

 

And please don't ask how my REW calibration gets me 120dB. confused.gif

 

Michael

post #2208 of 2776
Graphs can be confusing. Is it safe to say the foam made virtually no difference?
post #2209 of 2776
Quote:
Originally Posted by shpitz View Post

Does any of you take sound measurements? Can the Audyssey mic be used? Can someone help me out with this? REW with Audyssey mic

The Audyssey mic is calibrated to work with Audyssey. Unless you can find calibration corrections for it's measurements, I doubt it can be used with REW.
post #2210 of 2776
Quote:
Originally Posted by cel4145 View Post

The Audyssey mic is calibrated to work with Audyssey. Unless you can find calibration corrections for it's measurements, I doubt it can be used with REW.

Yeah, I figured that much so took the plunge and bought the miniDSP UMIK-1, should be on the way from HK smile.gif
post #2211 of 2776
Quote:
Originally Posted by Bond 007 View Post

Graphs can be confusing. Is it safe to say the foam made virtually no difference?

In my case, that is correct. BeeMan's results, obviously, are different. I was very careful not to move the sub or the mic during the procedure, but who knows? He may have used something different that worked better.

I guess what I used is better as seat cushions. 


Edited by LastButNotLeast - 6/19/13 at 10:52am
post #2212 of 2776
Quote:
Originally Posted by LastButNotLeast View Post

...BeeMan's results, obviously, are different.

Oh sure, let's go there. tongue.gif
post #2213 of 2776
I dont know if I'm doing something wrong with these RW-12d's, but I've got MultEQ XT to come back with 00.0db on the sub channel (which is what you want correct?) & honestly they don't even sound loud to me. Even when I raise the level a little they don't sound loud at all. Not much louder than the e55's below 80hz honestly. They're on for sure. Crossover has been played with around 70-80hz. I mean I know I've only had them on and playing around for an hour or so, but I can barely feel them! I had to put the level ON THE RW-12d at -23db to get MultEQ XT to come back at 0db. When I put them at 0db and -10db (might have been -11db) MulEQ XT came back with the sub channel at -12db.

I have them set on DEPTH & crossover at 80hz (on the sub; I guess i could experiment with raising it to 120hz or whatever on the sub...but I don't think that's what's wrong). I played the Iron Man 2 scene where he's jumping out of the plane at the beginning and I feel a tiny bit of bass, but honestly it's nothing. I sounds like what a little 10" or 8" could do.

Uh ...oh.

Can anyone HELP??! redface.gif
post #2214 of 2776
Quote:
Originally Posted by ousooner2 View Post

I dont know if I'm doing something wrong with these RW-12d's, but I've got MultEQ XT to come back with 00.0db on the sub channel (which is what you want correct?) & honestly they don't even sound loud to me. Even when I raise the level a little they don't sound loud at all. Not much louder than the e55's below 80hz honestly. They're on for sure. Crossover has been played with around 70-80hz. I mean I know I've only had them on and playing around for an hour or so, but I can barely feel them! I had to put the level ON THE RW-12d at -23db to get MultEQ XT to come back at 0db. When I put them at 0db and -10db (might have been -11db) MulEQ XT came back with the sub channel at -12db.

I have them set on DEPTH & crossover at 80hz (on the sub; I guess i could experiment with raising it to 120hz or whatever on the sub...but I don't think that's what's wrong). I played the Iron Man 2 scene where he's jumping out of the plane at the beginning and I feel a tiny bit of bass, but honestly it's nothing. I sounds like what a little 10" or 8" could do.

Uh ...oh.

Can anyone HELP??! redface.gif

What receiver do you have?
post #2215 of 2776
Quote:
Originally Posted by ousooner2 View Post

I dont know if I'm doing something wrong with these RW-12d's, but I've got MultEQ XT to come back with 00.0db on the sub channel (which is what you want correct?) & honestly they don't even sound loud to me. Even when I raise the level a little they don't sound loud at all. Not much louder than the e55's below 80hz honestly. They're on for sure. Crossover has been played with around 70-80hz. I mean I know I've only had them on and playing around for an hour or so, but I can barely feel them! I had to put the level ON THE RW-12d at -23db to get MultEQ XT to come back at 0db. When I put them at 0db and -10db (might have been -11db) MulEQ XT came back with the sub channel at -12db.

I have them set on DEPTH & crossover at 80hz (on the sub; I guess i could experiment with raising it to 120hz or whatever on the sub...but I don't think that's what's wrong). I played the Iron Man 2 scene where he's jumping out of the plane at the beginning and I feel a tiny bit of bass, but honestly it's nothing. I sounds like what a little 10" or 8" could do.

Uh ...oh.

Can anyone HELP??! redface.gif
Not sure about audyssey but my yamaha avr with ypao tends to set the subwoofer(s) low. I would set the gain so audyssey is pulling -5, then add 5db back in.
That should get you close to your likings. Most folks tend to like bass 5-10db hot. I actually set my subs so ypao trims -10db and add 5db back so the avr shows -5db. This way if I am playing some source content thats lacking bass I have another 5db of adjustment. I do not like to go past zero on the sub trim as it can clip the signal and cause a loss of headroom at high volume.
post #2216 of 2776
Quote:
Originally Posted by ousooner2 View Post

I dont know if I'm doing something wrong with these RW-12d's, but I've got MultEQ XT to come back with 00.0db on the sub channel (which is what you want correct?) & honestly they don't even sound loud to me. Even when I raise the level a little they don't sound loud at all. Not much louder than the e55's below 80hz honestly. They're on for sure. Crossover has been played with around 70-80hz. I mean I know I've only had them on and playing around for an hour or so, but I can barely feel them! I had to put the level ON THE RW-12d at -23db to get MultEQ XT to come back at 0db. When I put them at 0db and -10db (might have been -11db) MulEQ XT came back with the sub channel at -12db.

I have them set on DEPTH & crossover at 80hz (on the sub; I guess i could experiment with raising it to 120hz or whatever on the sub...but I don't think that's what's wrong). I played the Iron Man 2 scene where he's jumping out of the plane at the beginning and I feel a tiny bit of bass, but honestly it's nothing. I sounds like what a little 10" or 8" could do.

Uh ...oh.

Can anyone HELP??! redface.gif
Try to get a new MIC, i just got the Onkyo 818 with XT-32, and everytime inran it it set my subs to 68db according to the Ratshack SPL meter, and i do mean everytime, now i just got a new mic, and it sets the bass to 75db everytime, it seems crazy that the other mic was bad, but that is mu suggestion for you, hope it helps;)
post #2217 of 2776
Quote:
Originally Posted by basshead81 View Post

Not sure about audyssey but my yamaha avr with ypao tends to set the subwoofer(s) low. I would set the gain so audyssey is pulling -5, then add 5db back in.
That should get you close to your likings. Most folks tend to like bass 5-10db hot. I actually set my subs so ypao trims -10db and add 5db back so the avr shows -5db. This way if I am playing some source content thats lacking bass I have another 5db of adjustment. I do not like to go past zero on the sub trim as it can clip the signal and cause a loss of headroom at high volume.
Just a thought. The 773 only displays to -10. Make sure youre not really below that and dont know it. You could be at -18 even though the 773 is displaying -10.
post #2218 of 2776
Quote:
Originally Posted by Bond 007 View Post

Just a thought. The 773 only displays to -10. Make sure youre not really below that and dont know it. You could be at -18 even though the 773 is displaying -10.

If its actually lower than -10 it wil throw a error code. wink.gif

I also have a mic, spl meter, and measuring gear...so its a safe bet I know where its actually at aside from what yapo shows. smile.gif
post #2219 of 2776
Quote:
Originally Posted by basshead81 View Post

If its actually lower than -10 it wil throw a error code. wink.gif

I also have a mic, spl meter, and measuring gear...so its a safe bet I know where its actually at aside from what yapo shows. smile.gif
Cool. My 671 and 675 will not do that.
post #2220 of 2776
Quote:
Originally Posted by Bond 007 View Post

Cool. My 671 and 675 will not do that.


Really? It must be another feature added in the multi point measure ypao software. it actually has a few error codes...i believe it can detect speakers being out of phase and the other I forget.
New Posts  All Forums:Forum Nav:
  Return Home
AVS › AVS Forum › Audio › Subwoofers, Bass, and Transducers › Klipsch RW-12d on sale for $299 at Newegg.com again today!