or Connect
AVS › AVS Forum › Audio › Subwoofers, Bass, and Transducers › XLR Splitter Issues
New Posts  All Forums:Forum Nav:

XLR Splitter Issues

post #1 of 2
Thread Starter 
Thank you everyone who helped me in my thread a few weeks ago. I decided to cut my budget and bought a pair of Epik Legends when they were on sale. Now I've run into an issue getting them hooked up.

At the moment, I am running the subwoofer output from my receiver into a Behringer FBQ2496. The output of the FBQ is split using an XLR splitter (http://www.amazon.com/gp/product/B000068O59/ref=oh_details_o01_s00_i00) into the inputs for the two subs. Unfortunately, this results in the input signal to the sub being incredibly weak. I can turn off the mains and get decent measurements, but even with the mains set 20dB below the subwoofer on the receiver and the subs' volume controls turned all the way up, the subs are too weak.

Unhooking one of the subs from the splitter results in dramatically increased volume from the sub left attached. This appears to be related to the additional wire coming off the splitter, though, as the unused sub must be unhooked at the splitter not the subwoofer itself. I have never observed this behavior with a splitter before, although I have only used RCA splitters before. Is this a quirk of the balanced cables?

My first thought would be to put the splitter in between the receiver and the FBQ, using a channel per sub, but unfortunately only one of the channels on my FBQ is functional. Does anyone have any other suggestions?


Edit:
Well, switched over to RCA sooner and used an RCA splitter I forgot I owned which solves the volume issue. I suppose the issue is with the splitter I own.
Edited by intangiblefatman - 12/2/12 at 6:53pm
post #2 of 2
Quote:
Originally Posted by intangiblefatman View Post

This appears to be related to the additional wire coming off the splitter, though, as the unused sub must be unhooked at the splitter not the subwoofer itself.
Probably a short in that cable.
New Posts  All Forums:Forum Nav:
  Return Home
AVS › AVS Forum › Audio › Subwoofers, Bass, and Transducers › XLR Splitter Issues