or Connect
AVS › AVS Forum › Audio › Receivers, Amps, and Processors › Sony STR DH820 Issues
New Posts  All Forums:Forum Nav:

Sony STR DH820 Issues

post #1 of 8
Thread Starter 
Hello. I bought a Sony STR DH820 AVR 2 months ago. I had it hooked up to a Monitor Audio 2.0 speaker system. I was primarily using it as a music system and was able to play my music collection on my ipod/ipad via usb.

Recently I hooked it up to a 37 inch LG 37LS5600 LED TV. I connected this to the AVR using a Cambridge Audio HDMI cable. Once I did this, few issues cropped up.

1) The USB functionality seems to have stopped. I have tried connecting an ipod and an HTC smartphone to play music. The display on the AVR indicates USB but after that nothing happens. My ipod flashes the message 'OK to disconnect'.

2) I am unable to output TV audio via the speakers. I tried using an optical cable and was able to output the TV audio. Doesn't seem to be working on HDMI.

3) I am unable to view the receiver GUI on the TV. I suspect it is linked to the above issue. Even though GUI mode is turned on, I am not able to view any of the options on the TV.

Would the experts have any idea on what could be wrong? Thanks in advance for your help!
post #2 of 8
sony recommends their own HDMI 1.4a cable, but there maybe others out there that work.
post #3 of 8
Is the HDMI cable a hi-speed (category 1) or standard speed (category 2) cable? Is it particularly long? They're not really a version of HDMI such as 1.4 (but sometimes the hi speed cables are marketed that way). http://www.hdmi.org/learningcenter/kb.aspx#49

Are you trying to get audio via ARC (Audio Return Channel) feature of HDMI? Your tv and avr need to support that feature (I didn't check the specs on your eqpt)

Your tv has a selection setting most likely (I didn't look at the manual) for either tv speakers or external speakers; maybe connecting changed that but look in the manual.

I always have several HDMI cables around and have discovered bad ones by swapping in/out with others.
post #4 of 8
just went to that web site, it must be out of date as it does not have the 1.4a HDMI cable listed in the FAQ.
going back to read what else they have.....
just found
I see a new spec for 3D is 1.4a and a newer version coming out for 1.4b that will probably be 4K TV sets
but does not say it.....
post #5 of 8
also my Sony receiver uses 1.4a in it's specs......
post #6 of 8
You can only view the Setup menus of the receiver by using a component-video connection from the receiver to the TV. That is the way they designed it.

Forget about using HDMI from the receiver to the TV; remove that cable and just use component-video/analog audio connections from receiver to TV (THE COMPONENT VIDEO-MONITOR OUT AND AUDIO OUT JACKS).

The digital cable will route the TV audio to the receiver.

The HDMI functionality of this receiver is very limited, and as a result is a pain in the butt.
Edited by commsysman - 1/16/13 at 9:36am
post #7 of 8
http://www.hdmi.org/consumer/finding_right_cable.aspx
try this, are you using the standard HDMI with ethernet or the new one. I have just received the 830
similar to the 820 and have yet to connect it up. but I have read just about every thread on 700-730 as
well as the 800 to 830 AVR to this point.
I too have a dozen HDMI cables now.

edit also the 1.4a is compatible with the 4K sets at this time.
post #8 of 8
I have this receiver and all connections are HMDI and the setup menu shows up fine.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Receivers, Amps, and Processors
AVS › AVS Forum › Audio › Receivers, Amps, and Processors › Sony STR DH820 Issues