post #1 of 1
Thread Starter 
I'm encountering a strange issue on my system: I use WMC7 + Media Browser for playback, with the latest LAV Filters installed.

I use my Harmony remote to control playback, and if I attempt to fast-forward/Skip during playback of a VC-1 encoded MKV file, playback freezes and I have to Force Quit the app.

However, if the MKV is encoded with AVC, I can fast-forward/Skip just fine.

Running two sample MKVs through GraphStudio, I can see that:

* AVC MKVs are using "Microsoft DTV-DVD Video Decoder"
* VC-1 MKVs are using "WMVideo Decoder DMO" (highlighted in green in GraphStudio, which I read just indicates that it's a DirectX object)

I've tried adjusting LAV Video's settings:

* Under the Formats, I've tried unchecking "Use Microsoft WMV9 DMO decoder for WMV3 and VC-1" but it didn't make a difference, I still get the freeze.

* Under Video Settings, I've tried enabling Hardware Acceleration (using DXVA2 (native) since I'm running an ATI card) and have checked "VC-1" under "Codecs for HW". No difference, still get the freeze.

Any suggestions to fix this?

-R