or Connect
AVS › AVS Forum › Audio › DIY Speakers and Subs › Gone off the deep end - LMS content :)
New Posts  All Forums:Forum Nav:

Gone off the deep end - LMS content :)

post #1 of 14
Thread Starter 
In Jan this year, I managed to fry one of my Maelstrom X 18s and after consulting this forum, it was replaced with one LMS Ultra 18. Right after I replaced one driver, the people of this forum suggested that I should have identical drivers eek.gif In the interest of controlling my spending, I ran one LMS and one Mal-X for this year. As time went on, it got more obvious that the Mal-X isn't playing well nor keeping up with the LMS. Thankfully, the voice coil of the second Mal-x failed as well, so I went ahead and got a second LMS Ultra 5400.

After many hours of back breaking work today, both subs are installed! I took this opportunity to upgrade to a nut and bolt fastener setup. I've only had a few minutes to demo the new setup, and it's literally blowing me away biggrin.gif
post #2 of 14
More pics! Looks like a great setup and I really like the light colored wood.
post #3 of 14
I concur.
post #4 of 14
Really nice build. Did you do all your speakers? Build threads?
post #5 of 14
Thread Starter 
Quote:
Originally Posted by laeriq View Post

More pics! Looks like a great setup and I really like the light colored wood.

Quote:
Originally Posted by bass addict View Post

I concur.

I'll grab the good camera and get a few more shots tomorrow.

Quote:
Originally Posted by pgwalsh View Post

Really nice build. Did you do all your speakers? Build threads?

Thanks for the complement! I only built my subwoofers smile.gif The speakers are Paradigm studios. Maybe one day I'll build a speaker setup with Scan Speak drivers. tongue.gif

Here is the "build" thread that these speakers started their life as.

http://www.avsforum.com/t/1125158/my-dual-poor-mans-f113-build

I originally built these box for two JL 13W7s drivers. One of the drivers failed due to thermal issues. These enclosures were then modified for a pair of Maelstorm X 18s, and modified again for these LMS Ultra 5400s.

Out of all the drivers I've had, the LMS drivers are the best by far in terms of response and clarity smile.gif Some on this forum say the drivers have alignment issues with the basket and magnet. Mine were perfect cool.gif
post #6 of 14
I'm seeing curved cabinets. Build pics?
post #7 of 14
Thread Starter 
Quote:
Originally Posted by nograveconcern View Post

I'm seeing curved cabinets. Build pics?

My build process is poorly documented. I wish I had taken more pictures through it smile.gif

http://www.avsforum.com/t/1125158/my-dual-poor-mans-f113-build
post #8 of 14
"My build process is poorly documented."

yeah, but you did a great job with them. :-)
post #9 of 14
Your CE4000 fried the dual Mal's?
How close to clipping are you?
I hope your LMS's survive.
post #10 of 14
Thread Starter 
Quote:
Originally Posted by LTD02 View Post

"My build process is poorly documented."
yeah, but you did a great job with them. :-)

Thanks smile.gif These boxes have been through three sets of drivers now lol.
Quote:
Originally Posted by BassThatHz View Post

Your CE4000 fried the dual Mal's?
How close to clipping are you?
I hope your LMS's survive.

The amps weren't clipping very often. After all, each driver has a dedicated CE4000 which are not light weights smile.gif The Mal-x broke due to a manufacturing defect in my opinion. When I cut of one the drivers open last year, the voice coil were not burnt what so ever. The expert opinion is the magnet pole might've shifted for some reason. I've had one LMS for almost a year, and so far so good biggrin.gif
Quote:
Originally Posted by laeriq View Post

More pics! Looks like a great setup and I really like the light colored wood.

I'll snap a few more pictures tonight with the good camera. I've been forgetful throughout the holiday smile.gif
post #11 of 14
Beautiful system, and great looking room! The only thing that bugs me is the light colored speakers, floors, and walls. Why not go dark?
post #12 of 14
Thread Starter 
Quote:
Originally Posted by jdoostil View Post

Beautiful system, and great looking room! The only thing that bugs me is the light colored speakers, floors, and walls. Why not go dark?

Thanks for the complement!

I had the speakers before I built the room and subs, so my hands were tied smile.gif
post #13 of 14
Thread Starter 
A few more pictures. It was difficult to get a good shot with the screen in the way.


post #14 of 14
Quote:
Originally Posted by macming View Post

A few more pictures. It was difficult to get a good shot with the screen in the way.

Gorgeous!

Mind me asking where you live?
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: DIY Speakers and Subs
AVS › AVS Forum › Audio › DIY Speakers and Subs › Gone off the deep end - LMS content :)