or Connect
AVS › AVS Forum › Display Devices › Direct View (single tube) CRT Displays › Toshiba CW34X92 Speaker Problems
New Posts  All Forums:Forum Nav:

Toshiba CW34X92 Speaker Problems

post #1 of 4
Thread Starter 
First...I can't believe we still have this thing rolleyes.gif It's a beast. But it's in a downstairs room that doesn't get much use, and it looks good enough for that. Anyway, it's having an audio problem that I can't seem to figure out. Recently, it's been having an issue that on all inputs with the speakers. First, there is no sound without turning SBS on. None at all. Then, with it on, there is absolutely nothing but low frequency sound coming through. In fact, it directly correlates to the level of SBS; if SBS is on but set below, say, 20% on the scale, there is still no sound. You need to have it on and turned up past half way to hear anything, although all you hear is extremely low frequency, no midrange or treble at all. This happened out of the blue, and it looks like my last option is to take it to a repair guy. Any last minute advice before we haul this 200 lb beast in there? Any is appreciated!
post #2 of 4
If it were me and I couldn't fix it myself I'd just take the audio to some other pre-amp/amp. At the low end even a pair of amplified computer speakers. If the speakers are really good on the set you could even go as far as wiring back into them.

I'm assuming this is an early model widescreen HD CRT with no built-in DTV tuner. They're just not worth hauling and spending money on when you could find a newer version with HD tuner for $50-100 on Craigslist.
post #3 of 4
Thread Starter 
Well we (maybe stupidly) hauled it to the repair guy, waiting on an answer now. But yeah I think going external would be better anyway. The built-ins aren't bad but even a base-line 5.1 setup would be nice. Will probably end up doing that. I think this thing is from about 2000...so it's earlier on for HDTVs although for CRT direct-view it's about as good as it got back in the day. Actually still looks very good.
post #4 of 4
Yeah I have a similar era and version Panasonic (CT-34WX50). Great pic but no DTV tuner and only goes up to component video. Great sound, has 5 speakers with some kind of sound waveguide structure and a nice surround emulator. I lucked out and found a $20 Motorola HD tuner (buggy software but reception and PQ are good). These CRTs were great at displaying SD content, I've read on these forums that the flat panels are not so good at that performance. I got this TV free via a friend who works at a Kenwood car audio distributor, they lightly used it for shows until shipping these monsters didn't make sense anymore (Kenwood didn't want it back).
New Posts  All Forums:Forum Nav:
  Return Home
AVS › AVS Forum › Display Devices › Direct View (single tube) CRT Displays › Toshiba CW34X92 Speaker Problems