or Connect
AVS › AVS Forum › Display Devices › Rear Projection Units › Toshiba DLP 62HM196 Lamp issue (please help!)
New Posts  All Forums:Forum Nav:

Toshiba DLP 62HM196 Lamp issue (please help!)

post #1 of 6
Thread Starter 
I bought this DLP TV in January 2007 and the lamp finally blew last month (i determined it was the lamp by interpreting the yellow light blinking code as described in the owner's manual when i lost my picture. Also, upon removal, the lamp bulb was filled with shattered glass ). Replaced it with legit Toshiba lamp I bought online and replaced installed it as per the instructions (was careful not to touch any glass, tightened the screws, etc.) BUT now when i turn on the TV it often takes a few minutes for picture to appear. Specifically:

When i turn on the TV, the sound comes on immediately, as does the blue light, but picture does not come on, the screen remains blank and yellow light blinks many times. TV then "clicks" and sound goes off, but then it clicks again and sound comes back, but no picture and yellow light blinks. After 3-4 iterations of this clicking on and off with sound coming back immediately but no picture, the TV picture DOES come on, but this has me worried that it won't be long before it just doesn't come on at all! Note that this happens MOST of the time i turn on the TV. About once every 3-4 times, the sound and picture come on immediately, like they should.

Any ideas? Thanks!
Edited by stephenj - 12/25/12 at 8:27am
post #2 of 6
Bad ballast. I have read this happening many times.
post #3 of 6
Thread Starter 
So what is my solution? Can I buy a ballast and replace myself or is this a job for a pro?
post #4 of 6
I had a 65hm167 model that did exactly the same thing whenever I used a lamp that was not an official Toshiba lamp. Unless it comes in a box with Toshiba printed on it, along with a Toshiba 6 month warranty card, it is not an official Toshiba branded lamp and will likely cause you problems.

In my model, the lamp ballast was part of the light engine assembly - which is the most expensive part of the set. I'm not sure about your particular model, but Toshiba apparently started putting as many components as possible in one assembly to reduce manufacturing costs.

Do check your lamp to make sure it is OEM. Not compatible, etc. Vendors use lots of weasel words to make it sound like you're getting the real thing, when you're getting a cheap knock off.

After numerous lamp replacements from vendors, I eventually started buying them directly from Toshiba's web site. Never had a problem after that - fired up 1st time every time until the lamp died. Price was the highest out there, but I saved me hours of aggravation and frustration.
post #5 of 6
Quote:
So what is my solution? Can I buy a ballast and replace myself or is this a job for a pro?
To answer your questions;
Yes,
maybe if you know what you are doing,
if you don't then yes.
post #6 of 6
I have a similar problem but I get no sound nor a blue light for the TV turning on. Just the blinking lights with a new bulb installed.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Rear Projection Units
AVS › AVS Forum › Display Devices › Rear Projection Units › Toshiba DLP 62HM196 Lamp issue (please help!)