or Connect
AVS › AVS Forum › Display Devices › Rear Projection Units › Help with Samsung HL67a750?
New Posts  All Forums:Forum Nav:

Help with Samsung HL67a750?

post #1 of 2
Thread Starter 
Hi everyone, I've read the forums forever but never posted. I hope this is in the right spot. I have a Samsung HL67a750 which is going on 4 years now. Thanks to the threads here, I managed to replace my DMD chip today without problem and get rid of my starfield, so thank you all for that!

I have another problem with this set, and I'm not sure this is all related to one thing or not. I have a DirecTV HR-34 connected through a Logitech Revue, connected to HDMI 2, an Xbox 360 on HDMI 1, and a Blu-Ray player on HDMI 3. I use a Logitech Harmony 880 remote with everything. For a while now, I've had an issue when turning on the TV, where I have two options to get a picture to stay on the screen: Reboot the Revue box or change inputs (HDMI 2 -> HDMI 1 -> HDMI2, possibly twice). Once that I manage to get a picture, it stayed on. I also have had an issue where if I turned the TV off, and back on within ~10 minutes, the screen never lights up, I get a blinking green light for a short time, the TV will click and cycle 3 times, and I get the 3 flashing lights. the LED Phlats themselves are all working fine, and if I wait a few minutes I can hit power and the TV will come on normally.

I've also realized recently that the geometry on the TV is a little off. the bottom of the TV bows down very slightly right in the middle, the sides are fine, but the top edge has some serious skew, about 1/2" difference between the left and right (the right corner sits lower than the left). In looking around on how to fix this, I ended up in the service menu, and thought I was just looking around. I must have made some changes I wasn't aware of, because now the TV is acting even worse. When I turn it on, I get the "HDMI 2" up in the corner, I get a picture for a second or two, and then it goes black, and won't show anything on the screen, although the backlighting stays on. if I try to change inputs, it acts like it is doing something, but I see nothing. A couple of times it came up up and showed something that disappeared quickly, it looked like it said "Cable" with a channel of 3, then "Digital - Air" and 3-0, flipped between thr two for a second then the screen went blank, backlight on again, and same issue where I can't seem to do anything. In both situations, I can turn the TV off and back on, get the three light issue, wait, hit to turn it on, and it will come on fine. If I turn it on to the Service menu, it comes on without issue, I can see the source image behind the menus. There has to be something I changed that I didn't realize that can fix this, but I am completely lost as to what. I did a factory reset to try to fix it, that did nothing for me.

If I can provide any additional info to help diagnose/fix this issue, I would be more than happy to. I appreciate any help I can get in resolving this issue, you all are the brightest minds in Home theater!

Thanks,
Mike
post #2 of 2
Thread Starter 
Does anyone have any suggestions, or am I looking at having to buy new parts/new TV?
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Rear Projection Units
AVS › AVS Forum › Display Devices › Rear Projection Units › Help with Samsung HL67a750?