or Connect
AVS › AVS Forum › Audio › DIY Speakers and Subs › Blown Kenwood SW36HT subwoofer
New Posts  All Forums:Forum Nav:

Blown Kenwood SW36HT subwoofer

post #1 of 7
Thread Starter 
A friend asked me to look into a replacement woofer for this low fi sub. He's not into audio, just wants his sub working again.

Any ideas on a replacement 8" woofer for this 100watt piece? Perhaps an improved woofer?
post #2 of 7
Kenwood SW36HT woofer PART NUMBER: T10-0848-05 and seems to be a discontinued item. I was unable to find any ts information to even begin to suggest an alternative driver.

I would recommend contacting Kenwood directly.
post #3 of 7
A few questions and a suitable replacement should be easy to find.

#1 Can you measure the internal dimensions of the enclosure?
#2 Can you measure the port diameter and length?
#3 Can you measure the cutout for the woofer on the box, don't want to get one that does not fit.

With those we can determine the enclosure volume and tuning frequency which should help in determining a good replacement.

Right now looking at some pictures I am guessing it is about 1.2cuft net and port is maybe 3” in diameter and about 10” or so long with would put tuning in the mid thirties. But I would like you to double check those estimates when you get the chance.
post #4 of 7
Thread Starter 
Quote:
Originally Posted by mtg90 View Post

A few questions and a suitable replacement should be easy to find.

#1 Can you measure the internal dimensions of the enclosure?
#2 Can you measure the port diameter and length?
#3 Can you measure the cutout for the woofer on the box, don't want to get one that does not fit.

With those we can determine the enclosure volume and tuning frequency which should help in determining a good replacement.

Right now looking at some pictures I am guessing it is about 1.2cuft net and port is maybe 3” in diameter and about 10” or so long with would put tuning in the mid thirties. But I would like you to double check those estimates when you get the chance.

I think we'd be pretty safe going by your estimates. There is no port on it that I can see. The whole front face is covered by unserviceable black fabric. I will see if he will allow me to tear it off for a look and report back
post #5 of 7
http://www.crutchfield.com/S-qKswE1V1q7D/p_113HTB505/Kenwood-HTB-505.html#

Subwoofer:
8" cone
100-watt built-in amplifier
bass-reflex design
11-13/16"W x 13-3/16"H x 19-1/4"D

It is definitely ported. I have been looking around to see if I can find what it is tuned to.
post #6 of 7
Thread Starter 
I won't have a chance to disect this thing until this weekend. Seeing the Crutchfield specs, it says the "system freq response is 40-40000hz"? Could that mean that the sub goes to 40?


I was considering this driver. I know its a lot better quality than the Kenwood piece


http://www.parts-express.com/pe/showdetl.cfm?partnumber=295-484
post #7 of 7
I don't see any reason why that driver would not work. As long as the built in amp is stable at 4ohm.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: DIY Speakers and Subs
AVS › AVS Forum › Audio › DIY Speakers and Subs › Blown Kenwood SW36HT subwoofer