or Connect
AVS › AVS Forum › Blu-ray & HD DVD › Blu-ray Players › Oppo 105 HDMI "INPUT" frustration
New Posts  All Forums:Forum Nav:

Oppo 105 HDMI "INPUT" frustration  

post #1 of 2
Thread Starter 
I'm attempting to use the 105 in a home theater sans processor. So far so good with exception to the HDMI inputs from my cable TV tuner. After selecting the appropriate HDMI input, the audio and video start normally but are quickly interrupted by a full screen, green screen. Contacted Oppo customer service and they recommended that even though my 105 is brand new, to upgrade the firmware. Completed this task but did not solve the problem. Contacted my dealer and they were confident it is a bad HDMI cable. Tried three different cables to no avail. Using both HDMI results in the same problem. My guess is that the HDMI output from my cable box is the culprit; just not compatible. Any similar experience? Will try Oppo customer service again tomorrow. Thank you in advance for any guidance offered!
post #2 of 2
Quote:
Originally Posted by drmarg58 View Post

I'm attempting to use the 105 in a home theater sans processor. So far so good with exception to the HDMI inputs from my cable TV tuner. After selecting the appropriate HDMI input, the audio and video start normally but are quickly interrupted by a full screen, green screen. Contacted Oppo customer service and they recommended that even though my 105 is brand new, to upgrade the firmware. Completed this task but did not solve the problem. Contacted my dealer and they were confident it is a bad HDMI cable. Tried three different cables to no avail. Using both HDMI results in the same problem. My guess is that the HDMI output from my cable box is the culprit; just not compatible. Any similar experience? Will try Oppo customer service again tomorrow. Thank you in advance for any guidance offered!

Welcome to AVSForum.

Please post your question in the BDP-105 Owners thread: http://www.avsforum.com/t/1439524/official-oppo-bdp-105-owners-thread

-Bill
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Blu-ray Players
This thread is locked  
AVS › AVS Forum › Blu-ray & HD DVD › Blu-ray Players › Oppo 105 HDMI "INPUT" frustration