or Connect
AVS › AVS Forum › Home Entertainment & Theater Builder › General Home Theater & Media/Game Rooms › No display signal on screen but sound coming through home theatre system
New Posts  All Forums:Forum Nav:

No display signal on screen but sound coming through home theatre system

post #1 of 6
Thread Starter 
Hi,
I have Dennon 3311C1 receiver and epson 8700ub projector since 2 years. Today after watching divisional playoffs . i moved my receiver to connect new roku i bought but suddenly I could not get picture on my 120 inch screen from my cable on blue ray or any source. The display on screen says

"No display signal " but sound coming through home theatre system but with out picture. Can someone help me what is the cause of it and how to resolve it.
Thanks
Smith
post #2 of 6
First off put things back the way you originally had them to verify you still get video. More then likely a loose connection. If you are using HDMI it could be that the cable does not carry enough bandwidth, as I had an HDMI to DVI adaptor connected to a DVI to HDMI adaptor and it would not carry signal. Is the Roku like a media box? You may also want to check that your receiver is not in pure audio mode or direct audio mode as that kills the video feed.
post #3 of 6
Thread Starter 
Yes I put things back the way you originally had them but still I am getting same error. Do you know how to check receiver is not in pure audio mode or direct audio mode
post #4 of 6
Usually there is a button that says pure audio. Usually changing it to one of your other scene modes on the receiver will usually work. ie Stadium or concert, something along those lines, even pressing the pure audio button might resolve it.

Might even try the manual...
http://www.manualowl.com/m/Denon/AVR-3311CI/Manual/169907?page=78
post #5 of 6
Thread Starter 
Did that without any luck
post #6 of 6
The thing to try is to start by plugging in the projector directly into a source device. Make sure that it works. Then add the receiver in the middle. Check each component you add and when the picture no longer works, then there is your issue.
New Posts  All Forums:Forum Nav:
  Return Home
AVS › AVS Forum › Home Entertainment & Theater Builder › General Home Theater & Media/Game Rooms › No display signal on screen but sound coming through home theatre system