or Connect
AVS › AVS Forum › Audio › Receivers, Amps, and Processors › Onkyo 515 new user
New Posts  All Forums:Forum Nav:

Onkyo 515 new user

post #1 of 3
Thread Starter 
Good morning. I bought a NR515 and hooked it up yesterday. Couple questions/problems with it. First, when I switch to my Blu Ray I get the sound almost immendiately but the picture takes up to 5 minutes to appear. Is this normal? Also, when I push the Listening Mode button I get "not available" alot. Sometimes I can cycle thru the modes but mostly I get that error. Any suggestions? Thanks all.
post #2 of 3
Do the firmware upgrade on this device. Use an USB Pen Drive; not bigger than 4Gb; preferable 2Gbps and format it as Fat32. Download the files from Onkyo website and extract i all on the root of the pen drive. .Leave the extracted files as is. I believe it creates 3 files and a folder which contains inside another 4 files. Waiting about 5 minutes to get video is a NO-NO. Something should be wrong. Meanwhile try another HDMI input from the receiver. But I believe the FW Upgrade fix most issues related with HDMI handshaking.....

And do not swap HDMI connections if any of the devices are ON (Bluray player, TV, Receiver). It can possibly damage any of the hdmi boards
post #3 of 3
Thread Starter 
Thanks for your response. I did do the firmware upgrade as soon as I got the receiver. I think I might have found the problem. I thought that I had turned on the RIHD but it was off when I checked. When I tturned it on the Listening Mode started working. The Blu Ray switching seems to be a little faster. Still a couple minutes but alot faster than it was. Thanks again.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Receivers, Amps, and Processors
AVS › AVS Forum › Audio › Receivers, Amps, and Processors › Onkyo 515 new user