or Connect
AVS › AVS Forum › Display Devices › LCD Flat Panel Displays › Sony KDL-60NX720 HDMI display problem
New Posts  All Forums:Forum Nav:

Sony KDL-60NX720 HDMI display problem

post #1 of 2
Thread Starter 
I have a Sony 60NX720 on a wall with an hdmi cable running under the house to a Pioneer SC 65 receiver which has been working fine generally. On occasion I needed to pull the receiver out which caused the hdmi cable to come loose such that gray static would display on the screen until it was reseated properly. However as of yesterday I am getting a message on the TV screen, "No signal. Check the external input or select another input". The TV is set to hdmi 1. I thought maybe the receiver hdmi out connector had gone bad but when I connected the hdmi cable directly to a blu ray player, I get the same message. I checked that the hdmi cable is properly seated in the hdmi 1 port on the TV. I do not have another screen with hdmi to test out.

Does anyone have any idea what the problem could be? The only things I could think of are:

1. The TV hdmi port is broken
2. The hdmi cable was chewed by rats. I did have rat problems under the house about 1 year ago but nothing since then.

Any ideas? Thanks.
post #2 of 2
Thread Starter 
So today I bought a small tv just to test the hdmi cable and sure enough, I have confirmed the hdmi cable doesn't work going from the closet to the room next door, I think 35 feet. I definitely removed the cable from the receiver numerous times but how can that damage the cable? I can see how it might damage the receiver but not the cable. Nothing looks bent. Is there anything I can do to fix the end of the cable to get it working? If not I'm ordering a blue jeans hdmi cable to replace.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: LCD Flat Panel Displays
AVS › AVS Forum › Display Devices › LCD Flat Panel Displays › Sony KDL-60NX720 HDMI display problem