or Connect
AVS › AVS Forum › Video Components › Home Theater Computers › Xbmc 24hz picture moved to the left and not centered
New Posts  All Forums:Forum Nav:

Xbmc 24hz picture moved to the left and not centered

post #1 of 22
Thread Starter 
Hi, i just made a htpc xbmc build, and well i luckily found the way to get rid of the overscan thing on my hdtv that made the picture be around black bars... now i have a problem with xbmc, when i enable the adjust display to video refresh rate on xbmc, every time the movie starts and adjust to 24hz the picture is aligned to the left.. so theres some video chopped and a black space to the right so is not centered, i just got tired of spending like 2 hours on catalyst moving every setting and i cannot resolve this thing... however.. right now i have disabled the adjust refresh rate to match video and the video plays normal but is stuck at 60hz so i see some stuttering or whatever you call it so im bothered with it.. it just doesnt look to good and is distracting.. oh and i forgot when i have the refresh rate to match video it does switch to 24hz i check my tv and it says its on 24hz but like i said the picture is moved to the left...

i tried the catalyst to manually switch to 1080p24hz and it looks fine in windows.. but soon as i open xbmc goes back to 60hz.. and if i play a video and i have the adjust refresh rate to match video it does switch but yep to the left so is unwatchable..

specs

windows server 2008 r2
amd catalyst new version
amd radeon HD 7770
phenom x4 965
msi am3 motherboard
8gb of ram
LG 55LM8600 (tv is set up for just scan- putting it to 16:9 does the same thing)


please help guys.. i need to fix this thing

confused.gif
post #2 of 22
Whow - I could have sworn I saw the exact same post over at xbmc smile.gif

I know you said you had found a way to get rid of overscan. If you are going to use 'adjust refresh rate to match playback' you have to set overscan for each refresh rate you are likely to use - 24, 50 etc. If you've already done this - I'm stuck - haven't seen that issue reported.
post #3 of 22
Did you try setting your refresh rate to 23 Hz rather than 24 Hz in Catalyst and changing it that way?

Also, did you verify that the content is in fact 24 Hz? I think you press 'O' during playback in XBMC to bring up the codec info.
Edited by lockdown571 - 1/28/13 at 7:20am
post #4 of 22
What are your video settings? http://wiki.xbmc.org/index.php?title=Video_playback

Specifically, do you have "Crop black bars" enabled or a custom "View Mode"
post #5 of 22
Thread Starter 
on my hdtv settings on catalyst i only see 1080p24hz 30hz and 60hz theres also 1080i it says add and apply format which on 30hz theres no way to apply it... this thing is so confusing lol made me want to slap my face for not getting nvidia lol

i have everything disabled on xbmc except the dxva and dxva2 settings so is stuck at 60hz and i have normal view.. if that helps
post #6 of 22
I use intel integrated, but I've changed refresh rates in their system-wide graphics tool and never experienced this

I've also used the refresh rate sync feature in xbmc without experiencing this

If you're not adjusting any scaling or zoom settings, I'm out of ideas for now

I only shared my experiences to clarify I've not seen any "left-shift" in my own usage. I'm sure there's a lot of AMD XBMC users that will hopefully chime in
post #7 of 22
I have used this "feature" in XBMC with multiple AMD gpu's(5570,4870,5870) without issues. I believe I used it on my Llano laptop also. I would try using the fullscreen window feature of xbmc.
post #8 of 22
Thread Starter 
I did try the use fullscreen rather than true i checked on ans off stillthe same i already tried alot of combinations..

Somehow i think the problem is with compatibility of my hdtv maybe is a new tv and the catalyst doesnt have my type of tv on its recognized hdtv list?
post #9 of 22
Quote:
Originally Posted by zpeedy88 View Post

I did try the use fullscreen rather than true i checked on ans off stillthe same i already tried alot of combinations..

Somehow i think the problem is with compatibility of my hdtv maybe is a new tv and the catalyst doesnt have my type of tv on its recognized hdtv list?

I think you need to set the desktop to 23.976hz through catalyst and adjust from there, don't remember how to do this. To me 60hz plays back better than 23.976. Can't say why but it seems better.
post #10 of 22
Hmm, try adding the 23 Hz option as described here.

This is one of the many reasons I hate ATI cards. The overscan situation is obnoxious.
post #11 of 22
Thread Starter 
Any chance to set upthat refresh rate true catalyst??? I do see 1080p24hz standard and optimal and i do hit apply but when opening xbmc goes back to 60hz
post #12 of 22
Quote:
Originally Posted by zpeedy88 View Post

Any chance to set upthat refresh rate true catalyst??? I do see 1080p24hz standard and optimal and i do hit apply but when opening xbmc goes back to 60hz

Sorry, I'm not understanding. Can you rephrase/elaborate?
post #13 of 22
Quote:
Originally Posted by lockdown571 View Post

Hmm, try adding the 23 Hz option as described here.

This is one of the many reasons I hate ATI cards. The overscan situation is obnoxious.

From the thread that lockdown linked to:

In order to see the 23hz option you need to add it to the list of refresh rates by using the 'force' button'. Click the force button in CCC in the menu where you change display size and refresh rate, in there is a 23hz option, hit the checkbox to make it appear.


Set the desktop to 23hz as shown above and report back with findings.
post #14 of 22
Thread Starter 
Alright buds.. let me go take a hot shower and ill be doing my thing.. reporting back in a few.. ill try to screenshot some stuff
post #15 of 22
Thread Starter 







when i put the adjust refresh rate check how my screen look




some of the settings i have


post #16 of 22
The player can have video calibrations saved for each title independently (I think, same with audio, all part of XBMC database)

Click the video options in the OSD and try changing from "normal" to "original size"

I've always left at normal and never seen this, but it's worth a shot
post #17 of 22
Thread Starter 
yeah i tried the video calibration it just doesnt work.. i believe im making a mistake i think the video is 23hz or 23.97 or something like that.. i go to catalyst and i try to chose the 23hz option and goes back to 24hz.. it wont let me select 23hz
post #18 of 22
Thread Starter 
I DEMAND THE HIGHEST OF THE HIGH FIVES!!!!!!!!!!!!!!!!




I did fixed it alil by reinstalling catalyst and restoring everything to default and just disabled scaling and did the xbmc calibration adn my tv to just scan.. god damn it took almost a week to resolve this problem..
post #19 of 22
^ Lol

Baptism by fire
post #20 of 22
Thread Starter 
now some 23hz content plays really ******.. i have a dedicated htpc enable full screen rather than true screen?
post #21 of 22
As a quick test, try disabling Windows Aero.
post #22 of 22
Thread Starter 
i have windows 2008 server is the classic theme it doesnt have aero..

man some movies are unwatchable even tho i did made the sync refresh rate to work..

anyways on 1080p i want to apply 23hz but it wont let me.. it goes back to 24hz... also with 29hz goes back to 30hz
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Home Theater Computers
AVS › AVS Forum › Video Components › Home Theater Computers › Xbmc 24hz picture moved to the left and not centered