or Connect
AVS › AVS Forum › Display Devices › LCD Flat Panel Displays › Major problem with the 40L5200U
New Posts  All Forums:Forum Nav:

Major problem with the 40L5200U

post #1 of 2
Thread Starter 
Just got this tv 3 days ago,saw it in Best Buy and bought it. Terrible TV! The sound is horrible,the remote is...garbage,absolutely horrid and even worse there is MAJOR lag when I play Battlefield 3 on my PS3 on the tv. I even switched "game mode" on and aiming is nearly impossible,it's like being drunk and on a sheet of ice the way your characters movements are delayed or overly dramatic. Fine tune aiming is impossible! I originally hooked it up with an HDMI cable and experienced all of these problems,read about game mode and tried it,no avail,still horrible lag. Then went out and bought component cables and hooked it up,tv doesn't recognize the component hook up even though it's plugged in,showed picture in black and white at 420i,I then changed the settings on the PS3 to component.....screen goes black,no signal detected. Absolutely horrible,HORRIBLE,TERRIBLE TV! Stay away from this set if you're a gamer.
post #2 of 2
As far as the component problem, you need to reset the ps3's video settings from hdmi to component, and the correct resolution. As far as the other problem, since you just got it, take it back and get a different model before your 30 days are up.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: LCD Flat Panel Displays
AVS › AVS Forum › Display Devices › LCD Flat Panel Displays › Major problem with the 40L5200U