or Connect
AVS › AVS Forum › Blu-ray & HD DVD › Blu-ray Players › Oppo 103 stop working after 3 weeks
New Posts  All Forums:Forum Nav:

Oppo 103 stop working after 3 weeks

post #1 of 6
Thread Starter 
I got it 3 weeks ago and it was working great. Today I tried to watch a movie and the player stop working. What I can see is only one screen with white OPPO on the top and a blue Bluray on the bottom and that is it. I can't go to setup screen or any thing alse even the home screen. If we know a combination of button on the remote might help or anything else.

Please help me out and thanks for your inputs.
post #2 of 6
First, please post in the Oppo 103 thread. Second, have you called Oppo Customer Service?
post #3 of 6
I had mine for a week and sent it back today.
far too much hype for the price.
And judging by all the issues being reported - this machine is better left alone for now.
It's a shame.
I really wanted to be blown away by it.
I picked up a Pioneer 150 today for $125 and yeah the build quality is not that great- but it works and honestly looks just as good as the 103.
Actually- it looks better- because it doesn't have an issue with sharp setting.

I think when you spend more on a machine a placebo effect occurs and you believe (or want to believe) the experience is better than it really is.

Good luck.
post #4 of 6
I like mine, No issues. And who is placebo? Is he that opera singer? Placebo Domingo?
post #5 of 6
Quote:
Originally Posted by zombie1210 View Post

I like mine, No issues. And who is placebo? Is he that opera singer? Placebo Domingo?

More or less:
It's when you think something is better based on the power of suggestion.
post #6 of 6
Quote:
Originally Posted by bokes View Post

More or less:
It's when you think something is better based on the power of suggestion.

sorry to hear about your problem. too bad you didnt check with oppo. I think they would have helped you with the sitatuion..
unlike other companies that dont respond. good luck with the other player.

Jacob
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Blu-ray Players
AVS › AVS Forum › Blu-ray & HD DVD › Blu-ray Players › Oppo 103 stop working after 3 weeks