post #1 of 1
Thread Starter 
Hi Guys,

I've been trying to hook up my devices for some time but to no avail.

What I have:

- A home cinema DVD player (quite old but still working fine) - JVC TH A35R
- LG BD670: 3D Capable Blu-ray Discâ„¢ Player
- XBox 360 Slim
- HD TV box - ZHD200 - Satellite Receiver with optical output
- 3 way Optical Switch + 3x Digital Audio Toslink Cables -
http://www.ebay.co.uk/itm/380308480611?ssPageName=STRK:MEWNX:IT&_trksid=p3984.m1497.l2648
- another Optical cable

What is the issue....

I hooked up the HD TV box, LG BD670, the Xbox's digital outputs to the switch and on the other end to the home cinema digital input.

The result...
*Xbox is working fine only on Stereo mode... when select DD 5.1 from the console setting - no sound.
My question here is... why there is no sound when DD5.1 is selected..
And.. if it is because of the Home Cinema... is there any way to be updated or so...

*The BD670 works ok with most of the mkv files (movies) when selected digital output -> DTS option in the BD settings but with lag (lips sync issue... voice comes bit earlier than the picture). The options in the BD settings for Audio/Digital Output are: PCM Stereo (which works fine but still stereo not 5.1), DTS Re-Encode and Primary Pass-Thru (no idea of what those two options are) but as I said with them selected most of the 5.1 mkv movies run well but with lag. Those which are DTS are ok but with lag, the others DD - no sound.
How can i fix this lag and why some mkv with DD audio do not play on DTS mode selected but only on PCM stereo?

*The HD TV box... works well when strait connected to the Hi Fi but when hooked up to the switch ... no sound... no idea... when I touch both optical cables to each other sound is coming out... when connected strait to the hi fi... no problem... but when connected to the switch... nothing coming out... I tried to change the plugs... no any difference... plugs where the xbox and the BD works the HD TV box doesnt. .. Any ideas on that? When I plug the cable coming out from the HD TV box in the switch i can see the red light coming out from the other end of the switch .... so i think there is a signal going into the switch... any ideas?

* The switch came with three cables with kind of copper heads but I have another at home with is with kind of plastic or similar material head with does not work with the switch... again.. no idea...

Thanks guys and hope you can help me to hook up everything and make it works...

Let me know if you need any other info so you can picture it well