or Connect
AVS › AVS Forum › Audio › Receivers, Amps, and Processors › AVR-3310CI suddenly has no LCD display
New Posts  All Forums:Forum Nav:

AVR-3310CI suddenly has no LCD display

post #1 of 9
Thread Starter 
Hi guys,

Been lurking here for a while, but decided to join to get some expert advice!

Has anybody else had the issue of the LCD display on their Denon AVR3310CI go blank? My Audio and Video still work.

Thanks,

Marc
Edited by 335xi - 2/27/13 at 5:09pm
post #2 of 9
This is normal if you are using PURE DIRECT mode.
post #3 of 9
Thread Starter 
Quote:
Originally Posted by jdsmoothie View Post

This is normal if you are using PURE DIRECT mode.

How do I get out of pure direct mode?
post #4 of 9
Press the "STD" button on the back of the remote. If it's not in PURE DIRECT mode, then reset the microprocessor (p. 103 OM).
post #5 of 9
Thread Starter 
Quote:
Originally Posted by jdsmoothie View Post

Press the "STD" button on the back of the remote. If it's not in PURE DIRECT mode, then reset the microprocessor (p. 103 OM).

I don't have the OEM remote any more. Am I in trouble? Thanks!
post #6 of 9
Open the flip down door on the front of the receiver and push the STD button (top left)

post #7 of 9
Thread Starter 
Thanks guys. I tried both with no luck. When I turn my unit on, the standby LED flashes green for a few seconds. Is this normal?
post #8 of 9
Thread Starter 
When I do the microprocessor reset, the Display still stays black. No light at all.
post #9 of 9
Try unplugging the AVR for a few minutes and then power on doing the reset again. If still no LCD display lights, then you'll likely need to get it repaired, although you should still be able to control it using the Web Control feature (p. 82 OM) and a laptop.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Receivers, Amps, and Processors
AVS › AVS Forum › Audio › Receivers, Amps, and Processors › AVR-3310CI suddenly has no LCD display