or Connect
AVS › AVS Forum › A/V Control & Automation › Home Automation › What am I missing here Samsung serial control
New Posts  All Forums:Forum Nav:

What am I missing here Samsung serial control

post #1 of 3
Thread Starter 
All I'm trying to do here is turn on/off a Samsung UN60ES7500 via the EX-link port from a X-gen (cnmsx-pro) com port. I constructed a cable following the CNSP-568 cable diagram. the tip is RX, the ring is TX and the sleeve is ground. Double checked with a multimeter. I seem to recall that the Crestron com ports are not standard and I think this wiring diagram and the module I pulled the protocol from is for a 2 and 3 series processor. I am sending from "COM C" for ON \x08\x22\x00\x00\x00\x02 and get no results. Is the com port pin-out the same for a x-gen pro and a pro2? Or am I sending the wrong protocol? The com port is set up correctly 9600 baud, parity none, data bits 8 and stop bits 1. Thanks,

Chip
post #2 of 3
I've never done it, but you might consider connecting to the display from a PC first, using hyperterminal or Hercules, for troubleshooting.

Try searching for Samsung 232 control at RC.

Do you need a carriage return?
post #3 of 3
Thread Starter 
It's fixed. I was missing the last byte from both strings \0d6 for on and \0d5 for off.
So how was this working in a supposed working module without it??
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Home Automation
AVS › AVS Forum › A/V Control & Automation › Home Automation › What am I missing here Samsung serial control