or Connect
AVS › AVS Forum › Display Devices › LCD Flat Panel Displays › Please Help Me!!! Sony BRAVIA KDL55EX620 (EDITED....found problem but need solution)
New Posts  All Forums:Forum Nav:

Please Help Me!!! Sony BRAVIA KDL55EX620 (EDITED....found problem but need solution)

post #1 of 9
Thread Starter 
Hi guys, I have a problem with my Sony 55EX620. I have had it a little over a year now. These yellow lines/streaks keep showing up in the picture. I notice it when watching satellite and when I am on my computer (through hdmi)


Here are some pics I took while watching a show

Please let me know what the problem is




(edit)

So I now know the problem but need you help with a solution. In the winter time, I have one of those radiant heaters going day and night. I unplugged it when spring time came, and after 5 days or so my picture retuned to normal. I was so happy. Then as my basement became damp, I plugged in my dehumidifier. A few days later, the yellow lines returned.

So I have come to the conclusion to many things are plugged in and I am not getting enough voltage and my tv is suffering. Is there something I can buy that will keep my voltage at a normal level and not drop off when I have the heater/dehumidifier plugged in??

I can always add another breaker and only run my tv on that but if there is a product that can boost my power, i would rather try that

Any help would be appreciated
Edited by Spartiatis - 9/9/13 at 12:02pm
post #2 of 9
Quote:
Originally Posted by Spartiatis View Post

Hi guys, I have a problem with my Sony 55EX620. I have had it a little over a year now. These yellow lines/streaks keep showing up in the picture. I notice it when watching satellite and when I am on my computer (through hdmi)


Here are some pics I took while watching a show

Please let me know what the problem is

Good morning Spartiatis!

Sorry to see that you're having difficulty with your Television. The issue that is displaying on your screen doesn't look like something that we're aware of. You may need to have your unit evaluated by an authorized Sony servicer. If you would like further details on how to schedule for the evaluation, please follow this link: https://eservice.sony.com. You will need your model number, purchase date, and your zip code. After the evaluation is complete, please have the servicer send us your evaluation documents back to Sony. We will review and determine how to proceed. Thank you! =)

-Amanda Maffei

Sony Support USA
post #3 of 9
Thread Starter 
Thank you for your reply. But I am in Canada. I will try it out through the Canadian site. Thanks again
post #4 of 9
Thread Starter 
Bump
post #5 of 9
Thread Starter 
Bump
post #6 of 9
After doing some quick research it seems to be 1 or 2 things. To me it looks like the issue may lie in the layers of the screen, specifically the two polarized layers within the screen itself. These two polarized sheets in the screen act as a Color/Light filter. This works by electrical charge passing through 1 or both of the screens, twisting the particles to a point where light is able or unable to be seen through the 2nd polarized screen. Think of your window metal screens... When you have one metal screen you can see through that screen and passed the windows withe ease. Now if someone held up a 2nd metal window screen directly behind the screen but offset it from the 1st screen, the offset off the 2 screens would block more of the light then before. In your case i feel that your screens polarized sheets are off axis or possibly a capacitor blew to that section of the screen and you may need to replace the capacitor if possible. In either case the problem is still unresolved and should be repaired by an accredited technician who works on LCD's and other displays. Let me know how things go, and if I can further help out.

Ben
Lead AV Tech,AA Rental
post #7 of 9
Thread Starter 
But it works fine when I don't have a heater or dehumidifier plugged in. The picture is perfect
post #8 of 9
My apologies Spartkiatis! I didn't realize that you were in Canada. Were you able to get the issue you're having resolved there? And did you try visitng: http://www.sony.net/SonyInfo/SupportAll/ to see if one of our Sony colleagues in Canada can help? -Amanda M
post #9 of 9
Thread Starter 
Quote:
Originally Posted by SonyListens View Post

My apologies Spartkiatis! I didn't realize that you were in Canada. Were you able to get the issue you're having resolved there? And did you try visitng: http://www.sony.net/SonyInfo/SupportAll/ to see if one of our Sony colleagues in Canada can help? -Amanda M

Please read edited post
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: LCD Flat Panel Displays
AVS › AVS Forum › Display Devices › LCD Flat Panel Displays › Please Help Me!!! Sony BRAVIA KDL55EX620 (EDITED....found problem but need solution)