or Connect
AVS › AVS Forum › Gaming & Content Streaming › Networking, Media Servers & Content Streaming › *Official* Roku 3 Streaming Player Thread
New Posts  All Forums:Forum Nav:

*Official* Roku 3 Streaming Player Thread - Page 11

post #301 of 1724
Quote:
Originally Posted by Krutsch View Post

Well, that was my next question, so thanks for pointing that out. However, just because the Roku doesn't decode FLAC doesn't necessarily imply a loss of quality. It's possible, similar to how other streamers handle this, that the server is simply transcoding to LPCM without loss of quality and sending that over the network to the Plex client.

Everything happens internal to Plex. I downloaded the PLEX Media Server to my PC. Pointed it to my FLAC files. Once the Plex server sorted everything, downloaded cover art etc. I went to the ROKU3 and added the Plex Media Player channel, which immediately showed the albums streaming from the PC. Click on an album or artist and listen to the music. The sound quality is very good. I just checked, not gapless on live albums.

Gear mentioned in this thread:

post #302 of 1724
Sorry to say this but what is the point of Plex? If you need to leave your PC on all the time to use it then I rather just play my files on the PC then.
post #303 of 1724
The point of Plex is to allow you to view your own content on your TV. I had a few friends who wanted to see a video I had. They had to crowd around the iMac. It would have been much easier if I had Plex and Roku at the time.
post #304 of 1724
Quote:
Originally Posted by PJO1966 View Post

The point of Plex is to allow you to view your own content on your TV. I had a few friends who wanted to see a video I had. They had to crowd around the iMac. It would have been much easier if I had Plex and Roku at the time.
Even easier if you had Apple TV.
post #305 of 1724
Quote:
Originally Posted by Gary J View Post

Even easier if you had Apple TV.

Not if I wanted to see it in 1080p without jailbreaking.
post #306 of 1724
Quote:
Originally Posted by PJO1966 View Post

Not if I wanted to see it in 1080p without jailbreaking.

What can't you do without jail breaking. Apples socialist restrictions is why I did not get a Apple TV. I have a iPod Touch but even they go overboard of what they allow for example no real WiFi scanner and not these wannabe scanners that are really just useless databases.
post #307 of 1724
^^^ I agree. Plus we have a LOT of music, photos, and video's on our server (that's not in iTunes or Apple format) and we have 7 Roku's. It much easier to use PLEX and we can stream to any Roku without issues.
post #308 of 1724
Quote:
Originally Posted by cavchameleon View Post

^^^ I agree. Plus we have a LOT of music, photos, and video's on our server (that's not in iTunes or Apple format) and we have 7 Roku's. It much easier to use PLEX and we can stream to any Roku without issues.

BTW, how's the reliability and ease of setup with Plex? When I've tried using it in the past, I just ran into too many bugs. But, it's been a while (couple of years) so I am curious to take another run at it.
post #309 of 1724
Can anyone recommend the correct device to choose when setting up the Harmony remote for use with the Roku? I was told to choose a DVD player but that's not working right. When I'm in the "Home" location on the Roku the up and down arrows causes it to go through two at a time instead of one. So each time I click on the up or down arrow, it moves it up or down twice instead of once.
post #310 of 1724
Quote:
Originally Posted by lujan View Post

Can anyone recommend the correct device to choose when setting up the Harmony remote for use with the Roku? I was told to choose a DVD player but that's not working right. When I'm in the "Home" location on the Roku the up and down arrows causes it to go through two at a time instead of one. So each time I click on the up or down arrow, it moves it up or down twice instead of once.

Actually it's not under the DVD player menu. When programing your Harmony, do the following:

Add Device - Select Music Player
Then Select Digital Music Server

Under Manufacturer: Roku will be a choice.

Then specify the model - doesn't matter as all the IR codes are the same. Roku 2 is the most common.

You can later change the name of the device to Roku (it will default as a DVD player).

That should work. We have 3 Harmony One's and 1 Harmony 700, all work great on the Roku's.
post #311 of 1724
Quote:
Originally Posted by Krutsch View Post

BTW, how's the reliability and ease of setup with Plex? When I've tried using it in the past, I just ran into too many bugs. But, it's been a while (couple of years) so I am curious to take another run at it.

I installed Plex Server on our main server about a year ago. There is some setup time, but it was not that bad. Maybe you should try it again. I do not know what it was like a couple years ago.
post #312 of 1724
Quote:
Originally Posted by lujan View Post

Can anyone recommend the correct device to choose when setting up the Harmony remote for use with the Roku? I was told to choose a DVD player but that's not working right. When I'm in the "Home" location on the Roku the up and down arrows causes it to go through two at a time instead of one. So each time I click on the up or down arrow, it moves it up or down twice instead of once.

There's an adjustment in the Harmony settings for the device; probably need to select the device and troubleshoot. By default, the Harmony sends each code three times quick. I have no idea what the idea behind that is. You can set it to send it once.
post #313 of 1724
Quote:
Originally Posted by Krutsch View Post

BTW, how's the reliability and ease of setup with Plex? When I've tried using it in the past, I just ran into too many bugs. But, it's been a while (couple of years) so I am curious to take another run at it.

I would install and test Plex every 5 months and the difference between today and 6 months ago is night and day. My wife loves it and it compliments the cord cutting we did last September.
post #314 of 1724
I used to own a roku2hd which I used to stream Amazon Prime videos. They looked awesome (I believe 720P). I purchased a Roku3 last week and when I configure it for 1080P, I get a really snowy/static screen. When I change it to 720P, it looks a bit better, but I see lots of ‘white dots on a black screen’.

I had the same problem with my bluray player and switching it to 1080P/24 fixed the issue.

Things I've tried:
  1. Factory reset
  2. Reloaded s/w
  3. Different hdmi cables
  4. Different hdmi channels on my AVR
  5. Plugging in the roku directly to my Panasonic Viera plasma
  6. Reseting via the secret menu

Nothing helps, so I figured a call to India would help. I'm going to slap the next service drone that tells me to 'unplug the unit... wait 30 seconds...'. 'Is the unit plugged in?' especially after I listed the stuff I did.

Any help is appreciated, although I fear I'll have to return the unit.
post #315 of 1724
Quote:
Originally Posted by gonzlobo View Post

I used to own a roku2hd which I used to stream Amazon Prime videos. They looked awesome (I believe 720P). I purchased a Roku3 last week and when I configure it for 1080P, I get a really snowy/static screen. When I change it to 720P, it looks a bit better, but I see lots of ‘white dots on a black screen’.

I had the same problem with my bluray player and switching it to 1080P/24 fixed the issue.

If you had similar issues with both the Roku and Bluray it sounds like it might be another problem. Maybe with your TV or AVR.

My Roku 3 looks great in 1080P Super HD.
post #316 of 1724
Quote:
Originally Posted by gonzlobo View Post

I used to own a roku2hd which I used to stream Amazon Prime videos. They looked awesome (I believe 720P). I purchased a Roku3 last week and when I configure it for 1080P, I get a really snowy/static screen. When I change it to 720P, it looks a bit better, but I see lots of ‘white dots on a black screen’.

I had the same problem with my bluray player and switching it to 1080P/24 fixed the issue.

Things I've tried:
  1. Factory reset
  2. Reloaded s/w
  3. Different hdmi cables
  4. Different hdmi channels on my AVR
  5. Plugging in the roku directly to my Panasonic Viera plasma
  6. Reseting via the secret menu

Nothing helps, so I figured a call to India would help. I'm going to slap the next service drone that tells me to 'unplug the unit... wait 30 seconds...'. 'Is the unit plugged in?' especially after I listed the stuff I did.

Any help is appreciated, although I fear I'll have to return the unit.

I just hooked up a Roku 3 to a 60" Samsung LED this week (had Roku XS prior). Video looks great at 1080p. Roku is direct to TV, no AVR. Something's up with yours.
post #317 of 1724
Quote:
Originally Posted by gonzlobo View Post

I used to own a roku2hd which I used to stream Amazon Prime videos. They looked awesome (I believe 720P). I purchased a Roku3 last week and when I configure it for 1080P, I get a really snowy/static screen. When I change it to 720P, it looks a bit better, but I see lots of ‘white dots on a black screen’.

I had the same problem with my bluray player and switching it to 1080P/24 fixed the issue.

Things I've tried:
  1. Factory reset
  2. Reloaded s/w
  3. Different hdmi cables
  4. Different hdmi channels on my AVR
  5. Plugging in the roku directly to my Panasonic Viera plasma
  6. Reseting via the secret menu

Nothing helps, so I figured a call to India would help. I'm going to slap the next service drone that tells me to 'unplug the unit... wait 30 seconds...'. 'Is the unit plugged in?' especially after I listed the stuff I did.

Any help is appreciated, although I fear I'll have to return the unit.

The Roku 2 can only output P60 if set for 1080P - the Roku 3 is probably the same.

It sounds like you had problems with your Blu-Ray player at 1080P60 but it was OK at 1080P24 so maybe something in your set up isn't happy with 1080P60.

Normally my first suggestion would be to try a different HDMI cable - but you have done that....

The Roku 2's had issues with some HDMI cables that didn't fit snugly into their HDMI output
post #318 of 1724
Quote:
Originally Posted by PJO1966 View Post

Not if I wanted to see it in 1080p without jailbreaking.

I can, not sure why you can not.
post #319 of 1724
Quote:
Originally Posted by CaptainVideoJW View Post

If you had similar issues with both the Roku and Bluray it sounds like it might be another problem. Maybe with your TV or AVR.

My Roku 3 looks great in 1080P Super HD.

Yeah, it's weird. My roku2hd looked perfect, the roku3 is really, really snowy/static-y. I tried changing lots of settings in my Denon 2809 AVR, but nothing fixes it.
post #320 of 1724
Something is not right. The content playing on my Roku3 looks like the content playing from my Roku 2 boxes.
post #321 of 1724
Quote:
Originally Posted by cavchameleon View Post

Actually it's not under the DVD player menu. When programing your Harmony, do the following:

Add Device - Select Music Player
Then Select Digital Music Server

Under Manufacturer: Roku will be a choice.

Then specify the model - doesn't matter as all the IR codes are the same. Roku 2 is the most common.

You can later change the name of the device to Roku (it will default as a DVD player).

That should work. We have 3 Harmony One's and 1 Harmony 700, all work great on the Roku's.
Quote:
Originally Posted by michaeltscott View Post

There's an adjustment in the Harmony settings for the device; probably need to select the device and troubleshoot. By default, the Harmony sends each code three times quick. I have no idea what the idea behind that is. You can set it to send it once.

Thanks for the reponses, I changed the device from DVD Player to Digital Music Server but it was responding the same as with the DVD Player selected. I managed to find the right settings to change the code from three times to one time. The only thing that I can't get to work correctly is the "Instant Replay" on the Roku. This doesn't seem to be on the Harmony database for the Roku? Maybe it is under a different device. It didn't work by trying to "Learn" the command. Maybe it's because the Roku remote isn't IR? Has anyone found out how to "Learn" the "Instant Replay" on the Harmony or found another device that has "Instant Replay" on the database?
post #322 of 1724
Quote:
Originally Posted by lujan View Post


Thanks for the reponses, I changed the device from DVD Player to Digital Music Server but it was responding the same as with the DVD Player selected. I managed to find the right settings to change the code from three times to one time. The only thing that I can't get to work correctly is the "Instant Replay" on the Roku. This doesn't seem to be on the Harmony database for the Roku? Maybe it is under a different device. It didn't work by trying to "Learn" the command. Maybe it's because the Roku remote isn't IR? Has anyone found out how to "Learn" the "Instant Replay" on the Harmony or found another device that has "Instant Replay" on the database?

Ahh, see you issue. All the basic buttons will work, but the 'instant replay' has to be learned. You cannot use the gaming remote as it's RF (blue tooth). You'll need one of their standard remotes which is IR based for learning commands. Check this page, it has the IR version (I know it's an extra cost, but may be your only option - $14.99):

http://www.roku.com/accessories
post #323 of 1724
Quote:
Originally Posted by gonzlobo View Post

I used to own a roku2hd which I used to stream Amazon Prime videos. They looked awesome (I believe 720P). I purchased a Roku3 last week and when I configure it for 1080P, I get a really snowy/static screen. When I change it to 720P, it looks a bit better, but I see lots of ‘white dots on a black screen’.

I had the same problem with my bluray player and switching it to 1080P/24 fixed the issue.

Things I've tried:
  1. Factory reset
  2. Reloaded s/w
  3. Different hdmi cables
  4. Different hdmi channels on my AVR
  5. Plugging in the roku directly to my Panasonic Viera plasma
  6. Reseting via the secret menu

Nothing helps, so I figured a call to India would help. I'm going to slap the next service drone that tells me to 'unplug the unit... wait 30 seconds...'. 'Is the unit plugged in?' especially after I listed the stuff I did.

Any help is appreciated, although I fear I'll have to return the unit.

Finally got it to work. For some reason my $5 HDMI cables (all 3) were the issue. Plugged in some old $2 cables (two of them) and it works as expected.
post #324 of 1724
Quote:
Originally Posted by lujan View Post

Has anyone found out how to "Learn" the "Instant Replay" on the Harmony or found another device that has "Instant Replay" on the database?

That button is not on the IR remote which ships with the current generation Rokus; it's on the Roku 2 XS' and Roku 3's RF remotes (and as cavchameleon points out, it's also on the accessory IR remote that you can buy from their site and other places). The function is also in the Harmony device definition that I'm using ("DVD/Roku/Roku 2 XS"--I named it "Roku 2 XS" but when displaying the device options menu it displays "RokuRoku2 XS" in parenthesis next to the name I assigned). The function is called "InstReplay" and I've bound it to the SKIP BACK and PREV buttons of my Harmony One. Note that that device definition also includes the direct to Netflix, Pandora and Crackle functions not found on any of their remotes currently in production (I have Netflix bound to the RECORD button as I have for all my other devices with Netflix players except TiVo Premiere which does record and doesn't have a direct-to-Netflix function anyway).

BTW, I tried adding the device as a Digital Music Server (Roku's listed as a manufacturer of such because of their old SoundBridge products) but it still calls it a DVD so I don't think that it makes any difference whatsoever.
post #325 of 1724
Quote:
Originally Posted by michaeltscott View Post

That button is not on the IR remote which ships with the current generation Rokus; it's on the Roku 2 XS' and Roku 3's RF remotes (and as cavchameleon points out, it's also on the accessory IR remote that you can buy from their site and other places). The function is also in the Harmony device definition that I'm using ("DVD/Roku/Roku 2 XS"--I named it "Roku 2 XS" but when displaying the device options menu it displays "RokuRoku2 XS" in parenthesis next to the name I assigned). The function is called "InstReplay" and I've bound it to the SKIP BACK and PREV buttons of my Harmony One. Note that that device definition also includes the direct to Netflix, Pandora and Crackle functions not found on any of their remotes currently in production (I have Netflix bound to the RECORD button as I have for all my other devices with Netflix players except TiVo Premiere which does record and doesn't have a direct-to-Netflix function anyway).

BTW, I tried adding the device as a Digital Music Server (Roku's listed as a manufacturer of such because of their old SoundBridge products) but it still calls it a DVD so I don't think that it makes any difference whatsoever.

Ok, so it seems the trick is naming it the "Roku 2 XS" and that's what grabs the correct database information which includes "InstReplay", right? I think I have it working ok except that now I removed the old device information which corrected the commands being done 3 times again so it goes back close to 30 seconds instead of 7 seconds. I have to correct that again and all should be fine I hope?
post #326 of 1724
Quote:
Originally Posted by lujan View Post

Ok, so it seems the trick is naming it the "Roku 2 XS" and that's what grabs the correct database information which includes "InstReplay", right? I think I have it working ok except that now I removed the old device information which corrected the commands being done 3 times again so it goes back close to 30 seconds instead of 7 seconds. I have to correct that again and all should be fine I hope?

I don't think that it matters what you name it, just what you ask for: device type DVD/DVD, manufacturer Roku, model Roku 2 XS. You could name the device "Malcolm" if you want biggrin.gif. It actually seems as though device type doesn't matter as long as you choose one that you can choose Roku as the manufacturer of; if it's not the right type for the model it will find it in other types as long as it's a product that Roku makes. And yeah, you'll have to set the new device to repeat the commands only once again.
post #327 of 1724
Quote:
Originally Posted by michaeltscott View Post

I don't think that it matters what you name it, just what you ask for: device type DVD/DVD, manufacturer Roku, model Roku 2 XS. You could name the device "Malcolm" if you want biggrin.gif. It actually seems as though device type doesn't matter as long as you choose one that you can choose Roku as the manufacturer of; if it's not the right type for the model it will find it in other types as long as it's a product that Roku makes. And yeah, you'll have to set the new device to repeat the commands only once again.

I'm using an old 880 remote that doesn't work with the myharmony website. I'm using the old software that you download and it does seem to make a difference with this software because when I used DVD/Roku, it then asks me the model where I have to input the model name "Roku 2 XS" in this case. When I input "Roku 3", it did not give me the same data and "InstReplay" was not in the database. It is not a drop down where I can select it. I tried using myharmony.com and it told me that my harmony didn't work with the site.
post #328 of 1724
I double checked all my Harmony's (3 Harmony Ones and a 700). When programed as the device being Roku 2 XS, the instant replay does work as stated by Michael. But it does not work on the 700 (I'm assuming the 800 uses the same coding). So, you will need a learning function.

Lujan, PM sent.
post #329 of 1724
Quote:
Originally Posted by cavchameleon View Post

I double checked all my Harmony's (3 Harmony Ones and a 700). When programed as the device being Roku 2 XS, the instant replay does work as stated by Michael. But it does not work on the 700 (I'm assuming the 800 uses the same coding). So, you will need a learning function.

My impression was that he had it working when he chose Roku 2 XS in whatever software he uses for his 880. The InstReplay did not show up when he chose Roku 3.
post #330 of 1724
I can confirm it works with the 880 when you use Roku 2 XS for the device, no learning required. It couldn't find any device back when I programmed it using Roku 3.
New Posts  All Forums:Forum Nav:
  Return Home

Gear mentioned in this thread:

AVS › AVS Forum › Gaming & Content Streaming › Networking, Media Servers & Content Streaming › *Official* Roku 3 Streaming Player Thread