or Connect
AVS › AVS Forum › Audio › Receivers, Amps, and Processors › Pioneer VSX-822-K will no longer output audio/video through hdmi out
New Posts  All Forums:Forum Nav:

Pioneer VSX-822-K will no longer output audio/video through hdmi out

post #1 of 11
Thread Starter 
Hey Everyone,

First post here but I've been a long time reader so I was hoping someone could help me with my problem. I have a Pioneer vsx-822-k receiver powering a Energy 5.1 Take Classic Home Theater System. I have been using it for around 9 months now and haven't had any problems. The other day though, I turned on my PS3 and couldn't get any signal to my LG tv. I've tried a variety of solutions, including switching out the PS3 for another device, trying other HDMI input ports, switching out the HDMI cable and the TV but have had no success. I've also tried playing audio from the TV to the speakers which does work. I've also tried to access the MCACC menu but can't get it to come up. Anyone know what else I should try or what the problem could be?

Thanks,
Mike
post #2 of 11
I am currently having the same problem.
i think i got zapped or something.
maybe my cable box? cause my cable box is no longer working either

i am having the exact same issue as u report, any device...xbox...dvd...i hook straight to tV it works great.

receiver just sits there flashing HDMI adn the HDMI red indicator never turns on

i'm sure the board is fried or something
going to call pioneer tomrrow.
so frustrating
post #3 of 11
luckily the OP's receiver is still under warranty if he's only had it 9 months.
post #4 of 11
Thread Starter 
I did get it resolved. I took it into a pioneer repair center and they restored the system settings through the front panel controls. Works perfectly now.
post #5 of 11
ugh, i tried the factory reset and all of that stuff.

Sending to repair company who said ti's a known issue with many recievers and manufactures....with a bad capacitor or they will replace the whole HDMI board.

will update when its back
post #6 of 11
Quote:
Originally Posted by ryanderenzy View Post

ugh, i tried the factory reset and all of that stuff.

Sending to repair company who said it's a known issue with many recievers and manufactures....with a bad capacitor or they will replace the whole HDMI board.

will update when its back

I just had the EXACT SAME ISSUE with my Pioneer Elite VSX-53. On last Tuesday, the HDMI out died, no video and then no sound either. And something zapped my Uverse cable DVR, no sound. New DVR arrived last Thursday (very quick and helpful AT&T customer service). So unless I got a power surge from either the AC line or the cable (I have a Panamax M5300-MX and a UPS that is dead now of course), it's possible that the surge or whatever zapped the receiver via HDMI from my cable box. I can't think of any other possibility. My VXS-53 isn't plugged into the UPS, just directly into the Panamax. Just the DVR and the gateway were plugged into the UPS. Though the UPS would cycle briefly when I power everything up, everything seemed fine for months. And I've had it for 9 months too.

And most importantly, Geek Squad/Best Buy is fixing it now, I bought the service plan. If they can't reset the firmware or whatever to the defaults and replace the busted HDMI, hoping Pioneer's warranty service can. Though I was told that Best Buy will either fix or provide a similar spec model if they can't fix it. But wouldn't Pioneer be able to fix it, at least in theory? I'd almost rather try that than get some refurb receiver that "works" from Best Buy.
post #7 of 11
good info!

think mine was from lightning, pretty sure.

had two trees hit that day by lightning had GFI's blow out, and i had a spot on my aluminum siding that was MELTED a hole in it!

however my power strip was not tripped, something came through my COAX cable i think, hit my DVR and fried my reciever i believe.
it's in shop beign worked on now, all i know is they ordered parts for it.

i'm really worried my speakers got blown too, but i can't test it yet.

however my XBOX, TV, DVD, Blu ray player are all unafected.
post #8 of 11
good info!

think mine was from lightning, pretty sure.

had two trees hit that day by lightning had GFI's blow out, and i had a spot on my aluminum siding that was MELTED a hole in it!

however my power strip was not tripped, something came through my COAX cable i think, hit my DVR and fried my reciever i believe.
it's in shop beign worked on now, all i know is they ordered parts for it.

i'm really worried my speakers got blown too, but i can't test it yet.

however my XBOX, TV, DVD, Blu ray player are all unafected.
post #9 of 11

You guys mentioned the reset via the front panel, and I tried that with this very same issue on my VSX-822-k and it worked!

 

thought I would post the instructions for anyone else that lands here:

 

Reset the main unit if the receiver is generally not operating correctly. Switch the receiver into standby mode. Hold down the "BAND" button while pressing the "STANDYBY/ON" button for about two seconds. When "Reset?" appears in the display window, press the "AUTO SURROUND/ STREAM DIRECT" button. "OK?" appears in the display window. Press "STEREO/A.L.C." to confirm. "OK" appears in the window. The system has been reset.

 

post #10 of 11
I had to send mine in for repairs and have the HDMI daughter board replaced to fix my issue.
post #11 of 11

I joined this forum just to say thanks. This reset method worked perfectly. I was so grateful to find it when I was freaking out about a non-functional almost-new receiver. Made my day!

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Receivers, Amps, and Processors
AVS › AVS Forum › Audio › Receivers, Amps, and Processors › Pioneer VSX-822-K will no longer output audio/video through hdmi out