or Connect
AVS › AVS Forum › Audio › Receivers, Amps, and Processors › Pioneer sc-1522K setup
New Posts  All Forums:Forum Nav:

Pioneer sc-1522K setup

post #1 of 4
Thread Starter 
So it's not really setting up the receiver that's giving me problems. I have an htpc that I had hooked up to my old pioneer vsx-1021k and it worked great but when I just replaced it with my new sc-1522k today everything else is working great but the htpc. It picks up the hdmi cord when I put it on the input the computer is hooked up to but I can't seem to get the picture.. Anybody got anything for me to trouble shoot? I'm stumped and want to start enjoying my me toy!! Also it doesn't come with a book and the program for pc is having an error!
post #2 of 4
New on the SC-1522-K. I have an old Go Video that I use for playing VHS tapes. I have it input to the Pioneer via the component ports and use BDR/DVR for the remote selection. It starts up the Go Video and I get sound only but no video. I suspect I have a bad assignment somewhere but can't find anything in the manual except a reference to IN2 (Input 2?) that I can't find anything else about either. Any ideas?
post #3 of 4
The error on your PC can probably be solved by running the AVNavigator program directly from the disk menu rather than trying to run it from the screen link. This worked for me.
post #4 of 4
Thread Starter 
Turns out my hdmi to mini hdmi cord was just bad. Got it up and running and love it so far.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Receivers, Amps, and Processors
AVS › AVS Forum › Audio › Receivers, Amps, and Processors › Pioneer sc-1522K setup