or Connect
AVS › AVS Forum › Audio › Receivers, Amps, and Processors › Survey: how long does your amp take to turn on?
New Posts  All Forums:Forum Nav:

Survey: how long does your amp take to turn on?

post #1 of 13
Thread Starter 
I'm curious how long different amps take to turn on, after the switch is depressed or the 12V signal is triggered.

I have two multichannel amps on hand right now, one rated 100W/7ch/8Ω (Sherwood A965) and one rated about double (won't name for now, but it's a well-regarded amp from a blue-chip brand), both with good reputations. The A965 takes about five-Mississippi to power one. The other takes 30+ seconds, or much longer than my Anthem MRX 300 AVR's boot-up time.

What about yours? How long does it take to turn on?

I'm wondering if there's something wrong with Amp 2, or if it's supposed to take that long.
post #2 of 13
I have three Rotel amps. An RMB-1095(200x5) and two RB-1050(80x2). All three amps are triggered by my Anthem MRX300 receiver's 12v trigger and all three take about 3 seconds to power on after I hit the power button on the receiver. If your 2nd amp takes 30+seconds sounds that sounds like an unusually long time to power on.

BTW are both amps being triggered by the MRX300 at the same time by daisy chaining then together as in 12v trigger to amp1 and then 12 trigger wire from amp1 to amp2?
Edited by Legairre - 4/16/13 at 8:22pm
post #3 of 13
I have some vintage Yamaha amps and a Carver. Once the TV is triggered the amps take about 1 or 2 seconds to turn on before the avr turns on. SS amps should not take long to activate unless something is wrong somewhere in the power chain.
post #4 of 13
Thread Starter 
Quote:
Originally Posted by Legairre View Post

BTW are both amps being triggered by the MRX300 at the same time by daisy chaining then together as in 12v trigger to amp1 and then 12 trigger wire from amp1 to amp2?

I have a miniDSP and a couple amps because my system's fairly complex, so I use an Emotiva ET-3 triggering box downstream of the MRX.
post #5 of 13
With my previous receiver I could trigger the amps daisy chained from receiver to amp1, then amp1 to amp2 and amp2 to amp3.. With the MRX it was taking several minutes for my third amp in the chain to power on. Turned out that the voltage from the MRX receiver to amp1, then from amp1 to amp2 was fine to trigger them, but from amp2 to amp3 there was some kind of loss of voltage. Almost like the MRX trigger voltage wasn't enough to make it to the third amp in the chain. I ended up getting a Radio Shack mini plug splitter and plugged it into the MRX 12v trigger outlet with one side going to amp1 then amp2 and the other side going to amp3. Now everything turns on right away.
post #6 of 13
Thread Starter 
Here, it's definitely the amp.

Since I've not only heard from the mfg, but also from two people I know to own substantially similar amps, I'm comfortable saying the amp with the delay (I timed it at just under 30sec from the time I push the "remote/power" button on the Emotiva ET-3 (plugged into the way) to "go" is an ATI AT2007.

By contrast, my Sherwood Newcastle A-965 goes from "triggered" to "go" in about 6 seconds. Now, I do understand why the ATI amp woud need a longer delay to avoid overwhelming one's circuit-breaker.

Both are standard AB amps, designed for 15A circuits. But the ATI is 3dBW more powerful, and weighs almost 20lb more despite being a bit more compact in form-factor Those two transformers are bloody enormous, and I suspect it has a lot more capacitors to charge up given that it is twice as powerful.

I wonder how long similar amps from other makers, such as the McIntosh MC207/MC8207, take to start up after being triggered on.
post #7 of 13
I leave my parasound halo a23 on 24/7... So I never wait!
post #8 of 13
I also have an ATI AT 2007 power amp and it also takes around 15 to 30 second to power up. This is there soft start circuitry in action as to not blow circuit breakers on power up. It also keeps connected speakers from "thumping" on turn on. I know of other folks running 3 ATI amps on the same circuit and they can all power up without popping his circuit. I actually like this idea as my old B&K ref 2007 amp would "pop " my speakers on startup and shutdown.
post #9 of 13
Thread Starter 
Quote:
Originally Posted by smitty8451 View Post

I also have an ATI AT 2007 power amp and it also takes around 15 to 30 second to power up. This is there soft start circuitry in action as to not blow circuit breakers on power up. It also keeps connected speakers from "thumping" on turn on..

Oh, agreed completely. IMO, that kind of soft-start is one thing that differentiates better gear from less well-engineered stuff. The A965 starts soft as well though.

I suspect the difference in delay length between the Sherwood A965 and the AT2007 is simply that the AT2007 has more caps to charge.

So I'm curious about how long other conscientious amp makers in this power level (say, Mac MC207, Anthem Statement A5, etc.) take to start up. Obviously, there are a number of different brand 200W/ch rated amps that will take the same amount of time to start up as the AT 2007. wink.gif
post #10 of 13
Quote:
Originally Posted by DS-21 View Post

I suspect the difference in delay length between the Sherwood A965 and the AT2007 is simply that the AT2007 has more caps to charge.
The ATI amp has two big transformers and independent banks of caps. This is like having two amps in one chassis. It would make sense to have a longer startup time, to allow the first power supply to stabilize before the second is turned on.
post #11 of 13
My Yamaha amps have a protection light that comes on first and it is ready to go in 1 or 2 second after. These amps are rated 200 and 250 watts/channel and no speaker pops turning on or off.
post #12 of 13
The ATI amps have a Morris Kessler designed soft-start circuit that limits the in-rush current so lights don't dim and circuit breakers don't pop when the amplifiers come on. Please see the attached photo. The AC is initially routed through a bank of NTC thermistors. After about 30 seconds, the second relay closes and removes the thermistors from the AC circuit.

Jeff
Edited by Stereojeff - 4/18/13 at 12:20pm
post #13 of 13
Thread Starter 
Thanks for the additional details, Jeff.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Receivers, Amps, and Processors
AVS › AVS Forum › Audio › Receivers, Amps, and Processors › Survey: how long does your amp take to turn on?