or Connect
AVS › AVS Forum › Video Components › Video Download Services & Hardware › Finally: Netflix on Linux...It Works!
New Posts  All Forums:Forum Nav:

Finally: Netflix on Linux...It Works!

post #1 of 9
Thread Starter 
I've been waiting for this for quite a while....

http://www.iheartubuntu.com/2012/11/ppa-for-netflix-desktop-app.html

I installed it on an older Ubuntu 10.04 box, and on a new Linux-Mint 14 Cinnamon installation, both with no problems.

Enjoy!...
post #2 of 9
Thanks, I'll give it a whirl. Redbox also promised their streaming service would work with Linux but at least during the beta I tried it didn't. I had me downloading Moonlight and then it would through an error message when playing a video. Some of the networks have heavily protected streams for their shows which will still play on Linux with no special plugins.

I need to update this box now that Ubuntu 10.04 LTS support goes away this month but I tried 12.04 LTS. Unity is NOT an interface for developers at all. Even Google, which uses Ubuntu for Android development, is ambivalent about what to do. I like Mint but it's going to be tedious to cross upgrade. Canonical screwed the pooch. Unity is their Vista though I compare it to the Microsoft "Bob" flop. wink.gif
post #3 of 9
Instead of creating a new thread on this, I thought I'd tag onto this one.

Pipelight is the new answer to Netflix on Linux.

http://fds-team.de/cms/articles/2013-08/pipelight-using-silverlight-in-linux-browsers.html

It's the real deal so far.

I've loaded it onto two boxes so far, a Linux Mint and ArchLinux build.

I've gotten it working well with both Firefox, Chrome and Chromium.

I didn't like Netflix-Desktop. I had problems with choppy video, and the browser was borderline unusable for anything else.

Pipelight just tags onto the Wine-Compholio build, and adds a plugin to your native browser and while Pipelight accesses Wine, it does everything in the background. So, the solution is very seamless and invisible.

This also makes it suitable for Redbox streaming and other streaming services using Silverlight.
post #4 of 9

You will have to add PPA (Personal Packages Archives) in order to install Netflix on Linux.
http://namhuy.net/1867/how-to-install-netflix-on-ubuntu-linux-mint-and-fedora.html

 

$ sudo apt-add-repository ppa:ehoover/compholio


To install Netflix Desktop on Ubuntu and Linux Mint

$ sudo apt-get update && sudo apt-get install netflix-desktop

post #5 of 9
And yet Hulu+ works on Linux. What is Netflix missing? (Other than tech literate executives).
post #6 of 9
Thread Starter 
It must be the commercials!
smile.gif
post #7 of 9
Not everything on Hulu+ has commercials. Most of the movies are commercial free as are some of the foreign TV series.
post #8 of 9
Hulu Kids section is also commercial free. (Hulu Plus members only)
post #9 of 9
Heh, I went to watch a French cop show with Hulu+ and Chromecast. It came up saying I wasn't old enough to watch the show. I'm going to be 67 next week so I guess you have to be 95? The Android app knew the series was on my watched shows list so I was logged in. But to watch the show I had to re login. Bugs. I should probably report it and maybe they'll give me a couple free weeks credit like they did last time. wink.gif

And I seem to recall the French show had no commercials before but was subjected to bunch of insipid ones this time.
New Posts  All Forums:Forum Nav:
  Return Home
AVS › AVS Forum › Video Components › Video Download Services & Hardware › Finally: Netflix on Linux...It Works!