or Connect
AVS › AVS Forum › Audio › Audio theory, Setup and Chat › Help!!! Technics SL-1210MK2 forgot to set from 110v to 220v
New Posts  All Forums:Forum Nav:

Help!!! Technics SL-1210MK2 forgot to set from 110v to 220v

post #1 of 8
Thread Starter 
Technics SL-1210MK2 forgot to set from 110v to 220v.

I turned on with 110v and a blue light flashed once.

Suddenly I remembered wrong voltage and switched off the power at once.

Since than I can't turn it on.

What can I do?
post #2 of 8
Quote:
Originally Posted by gxxrgehk View Post

Technics SL-1210MK2 forgot to set from 110v to 220v.

I turned on with 110v and a blue light flashed once.

Suddenly I remembered wrong voltage and switched off the power at once.

Since than I can't turn it on.

What can I do?

Find a qualified service tech and pay him to do his thing.
post #3 of 8
Thread Starter 
It's there any internal fuse that blown up and need to replace?
post #4 of 8
IIRC the unit doesn't have internal fuse, the transformer may be blown.
post #5 of 8
Thread Starter 
post #6 of 8
You should be able just to unscrew the bottom of the turntable and find those fuses on the daughter board closest to the voltage switch. See which one that's blown and just pull that one and replace it with another with the same value and fast-blow variety.
post #7 of 8
post #8 of 8
Thread Starter 
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Audio theory, Setup and Chat
AVS › AVS Forum › Audio › Audio theory, Setup and Chat › Help!!! Technics SL-1210MK2 forgot to set from 110v to 220v