or Connect
AVS › AVS Forum › Video Components › DVD Recorders (Standard Def) › No TV sound from broadcast source on Toshiba RD-XS34
New Posts  All Forums:Forum Nav:

No TV sound from broadcast source on Toshiba RD-XS34

post #1 of 8
Thread Starter 
My RD-XS34 supplies sound to the TV when playing back a recorded source from the HDD or a DVD, but recently it does not play any sound while in TV Guide. It shows the tiny picture of the broadcast program in the upper left corner of the screen as always, but with no sound, AND it plays neither sound nor picture when changed from TVGuide to a selected channel.
And, here's the additional variation, there is a picture from a broadcast program if I stop playing a recorded source and it "switches" to a channel, but still NO sound.
I have checked settings, etc. with no solution.

Any suggestions would be helpful...

Thanks!
post #2 of 8
Is this your machine?





Let me ask you this... is your TVGuide still woking?
post #3 of 8
Thread Starter 
The TVGuide just shows the channels, it hasn't displayed the actual programs that are scheduled for a couple of years. This recent change is --- No sound, and sometimes no picture.
post #4 of 8
Thread Starter 
Yes, that is a photo of my model of machine.

Any suggestions on the lack of sound from broadcast material?
post #5 of 8
OK, I guess you will need to make a soft reset to your RD-XS34, let me google how to do it. If that doesn't work the issue will be located on the tuner.
post #6 of 8
Thread Starter 
OK... How do you do a "soft reset"?

Thanks
post #7 of 8
Quote:
Originally Posted by bvanloh View Post

OK... How do you do a "soft reset"?

Thanks

I was googling and nothing came on... only this answer from CitiBear:
Quote:
Originally Posted by CitiBear View Post

While there are any number of posts here from people trying all sorts of DIY fixes on Toshibas, in my opinion if the machine is of great value to you, send it in for direct Toshiba service. Toshiba DVD/HDD recorders are staggeringly twitchy and complex pieces of gear. Like any super-high-performance item, if you want the performance you have to be prepared for maintenance issues. Only Toshiba has the slightest clue how to restore these units correctly- call the service hotline and see if they'll match Panasonic's flat-fee $130 repair program for out-of-warranty recorders. Send it to an actual Toshiba depot if possible, not to a local "authorized" shop.

But please check these threads, they talk over a consistent firmware fault:

http://www.avsforum.com/t/1327587/weird-tv-guide-issue-rd-xs34
http://www.avsforum.com/t/1104814/toshiba-rd-xs52-problems-fix-myself

In the worst scenario, you could get a working unit from ebay or craiglist, and swap your old HDD without losing the content:

http://www.avsforum.com/t/840132/toshiba-xs32-xs54-xs35-all-xs-models-hdd-swap-info
post #8 of 8
Thread Starter 
Thanks, I'll read the other threads and look for ideas.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: DVD Recorders (Standard Def)
AVS › AVS Forum › Video Components › DVD Recorders (Standard Def) › No TV sound from broadcast source on Toshiba RD-XS34