or Connect
AVS › AVS Forum › Video Components › Home Theater Computers › MadVR uses the wrong GPU
New Posts  All Forums:Forum Nav:

MadVR uses the wrong GPU

post #1 of 15
Thread Starter 
Hi all.

My problem is this: I'm trying to get MadVR to use GPU acceleration on my laptop. I have a Nvidia GT 650M on it. The problem is that for some reason it uses my integrated Intel 4000 GPU instead, which is... not good.

How do I force it to use the 650M? I imagine it'd be faster, right? Or am I missing something here?
post #2 of 15
The laptop screen will always use the integrated gpu.
To use the Nvidia gpu, you must use the HDMI output connected to a display device.
post #3 of 15
Thread Starter 
Oh, well that's what I'm doing. I'm playing some HD content on my TV through HDMI.
post #4 of 15
Then you need to setup the HDMI screen as 'Extended' not 'cloned' in the Nvidia control panel.
post #5 of 15
Thread Starter 
I don't have anything like that in the Nvidia control panel settings; it only has 3D settings. But it is set to extend under Windows' "screen resolution".
post #6 of 15
Are you using the latest drivers - 320.18 - 64bit from Nvidia?
post #7 of 15
Thread Starter 
I'm using a version that was released in March. But I'll download that now. Thanks for the link. My download speed is ridiculously slow, so I'll come back in about an hour when it's done.
post #8 of 15
A release from March should have had settings for multiple displays too where you can select Extended over Cloned. The default installation is Cloned.

EDIT: For reference, on my laptop, when playing a video with MPC on the laptop screen, it uses the iGPU. Without even closing the player, as I drag it to my Extended display, it auto switches to using the Nvidia GPU.
Edited by Shark007 - 5/25/13 at 6:58am
post #9 of 15
Thread Starter 
Maybe I've shut down a service for Nvidia that has that stuff or something? I'll uninstall my old drivers and try reloading all that stuff with the new drivers, see what happens. Still 15 minutes left on the download though. Argh.
post #10 of 15
During the driver installation, select 'Custom' and then there is a checkbox to do a Clean installation which removes all previous user settings.
post #11 of 15
Thread Starter 
Alrighty then. Just did a clean install. No change whatsoever. I still have no settings on the control panel and it doesn't change automatically to the 650M. I don't understand how you're getting those settings??
post #12 of 15
Quote:
Originally Posted by Kootio View Post

I don't understand how you're getting those settings??



In the image above, I rightclick the laptop display (1) and there is a selection to Extend rather than Clone
post #13 of 15
Thread Starter 
See the topics or tabs or whatever on the left where it says "3D settings"? That's the only thing I have there. No display, no performance, no video.
post #14 of 15
Quote:
Originally Posted by Kootio View Post

See the topics or tabs or whatever on the left where it says "3D settings"? That's the only thing I have there. No display, no performance, no video.

Seems that it may be a limitation of your hardware (laptop).
My laptop is an ASUS N76V

I cannot explain why I have these options and you do not.

As you can see in my screenshot, I have the same 650M along with the intel iGPU
post #15 of 15
Thread Starter 
I have a HP ENVY... Yeah I don't know. Guess it can be some stupid graphics controller chip somewhere, but you'd think you could just force it to use the 650M somehow... Maybe there's some other software that can do that?
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Home Theater Computers
AVS › AVS Forum › Video Components › Home Theater Computers › MadVR uses the wrong GPU