or Connect
AVS › AVS Forum › Display Devices › LCD Flat Panel Displays › Sony XBR65X900A 4K Flashing red power indicator
New Posts  All Forums:Forum Nav:

Sony XBR65X900A 4K Flashing red power indicator

post #1 of 9
Thread Starter 
I have a Sony XBR65X900A that I love but it went down on me today. The TV won't respond to remote demands or on the TV demands. It also shuts down on it's on and the power indicator light flashes red 8 times. Has anybody had this issue yet?
post #2 of 9
It's either the panel or the power supply that has gone bad.....sorry to hear it.
post #3 of 9
Quote:
Originally Posted by Rebelpirate View Post

I have a Sony XBR65X900A that I love but it went down on me today. The TV won't respond to remote demands or on the TV demands. It also shuts down on it's on and the power indicator light flashes red 8 times. Has anybody had this issue yet?

Good afternoon Rebelpirate!

This is Kevin Krause from Sony Support USA. I am very sorry to hear about the problems that you have experienced with your new TV. We will certainly help you out with any issues you are having. Please email us at Sonylistens@am.sony.com and we will be happy to help you out. Please be sure to include a brief description of the issues your TV is displaying and in the subject of the email please refer to the event ID number E57810825.

Thank you,
Kevin Krause
Sony Support USA
post #4 of 9
Pretty cool. Hopefully this (presumably sanctioned) participation will encourage more mfrs to do this type of customer engagement.
post #5 of 9
Your problem is discouraging, but good to see that a Sony rep frequents these forums.

Let us know what it turns out to be and how it was rectified.

I have one being shipped to my home and I would have loved to hear only positive user stories.

Good luck!
post #6 of 9
Thread Starter 
was taken care of for
me by Sony! Power supply was bad! Other than that TV is AWESOME!!!!
post #7 of 9
I'm glad it was repaired quickly.

Delivery company is due to bring my new set tomorrow, between 7 AM and 10 AM.
post #8 of 9
Thank you for making this post. We just got this tv yesterday and we have the exact same issue tonight. It will turn on and the video will work, and then it will cut out on its own. It repeats this process three times before finally turning off and then the red LED blinks 8 times.

I spoke with Sony customer support and their theory was that the 8 blinking lights means the tv needs a software update. The power supply issue makes much more sense as I can't fathom an engineer/programmer making a product that cuts out when a software update is needed.

Will have to make a few more phone calls tomorrow during business hours to figure out the solution. Did they repair or replace your unit?
post #9 of 9
There may be something to the software update information. My 65 was experiencing the same thing except 4 blinks instead of 8. This happened on Sat after I got the set on Thurs and applied the update available. Sun/Mon a new update came out, and my set has worked just fine since.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: LCD Flat Panel Displays
AVS › AVS Forum › Display Devices › LCD Flat Panel Displays › Sony XBR65X900A 4K Flashing red power indicator