or Connect
AVS › AVS Forum › Audio › Receivers, Amps, and Processors › Marantz NR1603 and Apple TV - no video
New Posts  All Forums:Forum Nav:

Marantz NR1603 and Apple TV - no video

post #1 of 5
Thread Starter 
We have a Marantz NR1603 av receiver, MySky HD STB, Denon DVD and JVC TV. I have everything connected via HDMI cables and it all works perfectly.
I am now trying to setup Apple TV but I can only get audio but no video. I have tested ATV on our TV in our bedroom and it works fine so I know it is not the ATV unit.
I have tried plugging it into various inputs on the receiver , game, media player , aux and on all of them I get audio but no video. I am puzzled as to why I cannot get video.
Is there something different you need to do for ATV setup?mad.gif
Thank you
post #2 of 5
Welcome to AVSForum! smile.gif

Response posted in the 1603 Owner's thread linked below ....

http://www.avsforum.com/t/1409015/marantz-nr1403-and-nr1603-slim-line-receiver-thread/400_100#post_23422464
post #3 of 5
Thread Starter 
Thank you. I have just tried resetting the microprocessor but this has not helped. Would a firmware update help? Could it be a HDPC compatibility issue or is this unlikely as the ATV will work if plugged directly into a TV but not work when plugged into the AV receiver. Thanks again, Bev
post #4 of 5
Thread Starter 
Just a thought, could the fact that we run our HDMI over Cat5 have any bearing on the problem? Thanks Bev
post #5 of 5
Responded in the Owner's thread ... please post your responses in that thread as well. Thanks.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Receivers, Amps, and Processors
AVS › AVS Forum › Audio › Receivers, Amps, and Processors › Marantz NR1603 and Apple TV - no video