or Connect
AVS › AVS Forum › Display Devices › LCD Flat Panel Displays › KDL-52XBR4 strange green problem
New Posts  All Forums:Forum Nav:

KDL-52XBR4 strange green problem

post #1 of 9
Thread Starter 
I got the tv from a friend of mine and it has a strange green haze in the top right corner. It is darker in the closer you get to the corner and kind of fans out about a foot to the left and down. If you turn up the backlight and brightness you can almost bleach them out but you can still notice it. If the screen is displaying grey its dark green in the corner and once again lighter as it fans out. Is this problem fixable or is it a problem with the actual lcd panel. Ive been reading up for 2 days straight and Im very confident with working with electronics. I did read the TCON board goes bad a lot but not sure if this is my problem. Also I did try doing the Tab Bonds and nothing seem to change when messing with those. Any ideas are appreciated thank you in advance.
post #2 of 9
Thread Starter 
post #3 of 9
Looking at the pic, it's sort of tough to tell, due to the lack of RF signal presence, hence "snow" on screen. I'd guess from the irregularity of the shape, that the backlight tubes in that area aren't fully illuminated. I say that because you can see the tcon addressing is somewhat working because the snow is present beneath the haze. But that wouldn't cause the green haze condition. Is it safe to say this condition exists on all inputs? The green is typically indicative of loss of digital signal, but, again I can still see snow beneath it. If you get right up to the display in that area can you see that all 3 sub pixels are lit? If you can find a tcon cheap on somewhere like shopjimmy.com, i'd try it. Worth a shot.

If the inverter boards are interchangable, I'd also try swapping them and see whether the problem moves to somewhere else on screen.

Hope this helps some, good luck.
post #4 of 9
Thread Starter 
Sorry for just using the snow lol. Ill quick hook up my computer and take a few pics on different colors to see if this helps. Also the inverter boards, where are they located?





Like I said before it is like a very dark green in the corner and then gets lighter as it spreads from the corner
post #5 of 9
Thread Starter 
and I forgot to mention it is on every input setting
post #6 of 9
Thread Starter 
Alright another update after a few trial and error ideas. After cranking the backlight, color, and brightness up it almost washes the spot out to where you barely notice it and the whole picture is almost still perfect. It almost looks like it is not there anymore but once again if you reset the settings its still there. Also I would like to add that after calling the previous owner this problem started small and then slowly spread. He did inform me that the tv was on many hours everyday and took quite awhile for it to get to the point that its at now.
post #7 of 9
If left unplugged for 30+ minutes, then powered back up, is the effect immediately as intense as in the above pix, or does it take some time to develop to that point?
post #8 of 9
Thread Starter 
Makes no difference
post #9 of 9
Thread Starter 
Major update... after unplugging the right side of the screen from the TCON board the problem seems to shift to the center of the screen...its not as bad but still very noticeable


as you can see its green in the corners like when the whole screen is powered but now in the center so does this mean bad tcon board
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: LCD Flat Panel Displays
AVS › AVS Forum › Display Devices › LCD Flat Panel Displays › KDL-52XBR4 strange green problem