or Connect
AVS › AVS Forum › Audio › Receivers, Amps, and Processors › AV receiver (Onkyo TX NR515) not producing output to my TV.
New Posts  All Forums:Forum Nav:

AV receiver (Onkyo TX NR515) not producing output to my TV.

post #1 of 4
Thread Starter 
I am having a problem with my AV receiver (Onkyo TX NR515) producing output to my TV.

Firstly, I have a old TV which doesn't have any HDMI in (yeah I know).

I just purchased this new AV receiver tx nr515 thinking that since it has composite out (video out) , it will direct from the source to the TV.

I connected the TV to AV receiver via :

AV Receiver OUT = Video out
TV IN = Composite IN 2



I wanted to connect the below two devices :
1) Cable set-top box
2) Western Digital Media Player



Any suggestions how can go about, and why its not producing output to the TV.
post #2 of 4
As noted on p. 50 in your Owner's manual, in order to connect the composite video out to the TV, all of your sources will also have to be connected to the AVR with composite video cables as well.
post #3 of 4
Thread Starter 
I connected my media player to pc in of composite connection.

will that work ? I dont see any output on my tv.
post #4 of 4
Thread Starter 
Jdsmoothie : yes. All my connections are on composite only.

No hdmi and no component. Still nothing on screen.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Receivers, Amps, and Processors
AVS › AVS Forum › Audio › Receivers, Amps, and Processors › AV receiver (Onkyo TX NR515) not producing output to my TV.