or Connect
AVS › AVS Forum › Industry Area › HDMI Q&A - The One Connector World › [Solved] No audio from PC over HDMI distribution system
New Posts  All Forums:Forum Nav:

[Solved] No audio from PC over HDMI distribution system

post #1 of 10
Thread Starter 
I am using an Audio Authority 2800 Series HDMI over IP video distribution system. It works perfectly when getting a feed from a TV receiver. But when I connect a PC, there is no audio. If I connect the PC directly to a TV, there is audio, so I think the PC's HDMI setup is basically OK. The 2800 system supports only 2 channel PCM, so I assume that the PC is somehow sending something that is incompatible. Basic Windows sounds also don't work, so it's not just a video encoding format on the PC. I'm surprised that the PC HDMI autoconfigure handshake doesn't sort this out somehow and send the proper 2 channel PCM audio.

1. Is anyone else using a PC over this type of system?
2. Is there any way to force the PC to send 2 channel PCM audio?

Thanks,
post #2 of 10
This really isn't a HDMI problem. It is most likely a configuration problem on your computer. Do you have HDMI configured as the default audio device?
post #3 of 10
Thread Starter 
Quote:
Originally Posted by Colm View Post

This really isn't a HDMI problem. It is most likely a configuration problem on your computer. Do you have HDMI configured as the default audio device?

Yes, the HDMI output is the default device; and it works when I plug the computer directly into the TV.
post #4 of 10
Quote:
Originally Posted by bikeoid View Post

...it works when I plug the computer directly into the TV.
Doh! How did I miss that?!

Is the device set to 2 channel PCM?
post #5 of 10
Quote:
Originally Posted by bikeoid View Post

I am using an Audio Authority 2800 Series HDMI over IP video distribution system. It works perfectly when getting a feed from a TV receiver. But when I connect a PC, there is no audio. If I connect the PC directly to a TV, there is audio, so I think the PC's HDMI setup is basically OK. The 2800 system supports only 2 channel PCM, so I assume that the PC is somehow sending something that is incompatible. Basic Windows sounds also don't work, so it's not just a video encoding format on the PC. I'm surprised that the PC HDMI autoconfigure handshake doesn't sort this out somehow and send the proper 2 channel PCM audio.

1. Is anyone else using a PC over this type of system?
2. Is there any way to force the PC to send 2 channel PCM audio?

Thanks,

Since it works when directly connected to the TV, do you know what audio format the TV is getting in that case? Usually the answer is 2-channel PCM but some TVs will accept 5.1-channel Dolby Digital, too.
post #6 of 10
Is your computer outputting 720p or 1080p video?

I have not had any experience with HDMI over IP solutions ever, so it's kind of back to basic troubleshooting options.

It sounds like you connected a cable tuner of some type and that you were able to get audio with that no problem correct?

Are you using Gb switches throughout your entire setup? I'm not sure that matters at this point as you are getting video.

About the only thing I can think of is that for some reason, the PC is having a EDID issue, perhaps getting caught as a DVI source somewhere in the setup. There are some tools out there which you could run on your PC to look at the incoming EDID information and find out what is being asked for and what is being output. EDID is a much bigger headache than HDCP is at this point as the entire structure is less than accurate quite often.

Do you have a laptop or some other PC you could test with it?
post #7 of 10
I’m guessing the PC is either receiving no EDID or garbled EDID when its plugged to the HDMI over IP Transmitter so likely defaulting to video with no audio.

An EDID manager between the PC and the HDMI over IP Transmitter will likely resolve your problem as that way the PC will ‘see’ the EDID from a ‘virtual’ Monitor which supports 2ch PCM via HDMI.

The Gefen HDMI Detective+ or HDFury DR HDMI will do the trick.

Joe

PS You’ve just given me something else to test with our New Octava HDMI over IP solution smile.gif
post #8 of 10
Thread Starter 
Thanks for the insights - one of the complications of HDMI from the PC is that not many PCs have HDMI output (corporate environment). But we did try to change to a different model of video card, with no improvement.

It sounds like the EDID got garbled, and the HDM Detective+ or DR HDMI are great suggestions.

One of the problems is poor diagnostics to know what the TV negotiated when it had a direct HDMI connection, as well as what the PC is sending.
post #9 of 10
Use this to read the Monitor EDID - http://www.entechtaiwan.com/util/moninfo.shtm


Run it direct (PC to Display) then again when you are going via the HDMI over IP Tx!

Joe
post #10 of 10
Thread Starter 
Thanks for all the tips - I've finally solved this. The problem was that Windows XP apparently cataloged the device as not sound capable, and we had to move to Windows 7. I discounted this possibility because I envisioned it as seeing the HDMI audio as the audio device rather than the specific endpoint device detection.

We upgraded to Windows 7 and it works perfectly now. It's a long story about how I got there and couldn't place my hands on a Windows 7 PC to help diagnose the problem!

I'm now an expert and have the EDID diagnostics program in my toolkit!
New Posts  All Forums:Forum Nav:
  Return Home
AVS › AVS Forum › Industry Area › HDMI Q&A - The One Connector World › [Solved] No audio from PC over HDMI distribution system