or Connect
AVS › AVS Forum › HDTV › HDTV Recorders › iView-3500STB stopped working!
New Posts  All Forums:Forum Nav:

iView-3500STB stopped working!

post #1 of 5
Thread Starter 
hi everyone. I need some help! I bought the iView 3500STB just over 3 months ago and had it up and running within minutes of unboxing it. It worked perfectly until today. When I got home from work today, I turned it on and had lost all channel reception.

I hadn't touched it at all since I turned it off last night, and the antenna is located about 5 feet from it with a very short (temporary) coax line that has worked perfectly. I swapped out the coax with another run and confirmed still no reception. The unit seems to be operating normally in every other way.

My next step was to download the firmware updates and install them and the reset back to factory defaults. Still no reception when doing either Auto or Manual channel search.

Is there anything else I can do before declaring it a defective unit?
post #2 of 5
Thread Starter 
Update: I just checked the Information section and see that I'm running firmware V2. Shouldn't it be a higher version if I just downloaded the update off the iview website and installed that? Where can I get V6?
post #3 of 5
The version numbers have nothing to do with anything and are random. Please see recent posts in this unit's dedicated thread:

http://www.avsforum.com/t/1465875/iview-3500stb-tuner-dvr-owners-thread/900
post #4 of 5
Thread Starter 
Thanks to the help from some forum members, I got it running again. Apparently I'm not the only one with this issue. The trick is to unplug the unit from the power outlet (which I thought I had done, but apparently hadn't). Once the power had been disconnected for a few minutes, I plugged it in and it booted up as it had before. But this time when I did a channel search, it found all stations right away.
post #5 of 5
Try unplugging the unit for a couple of minutes!
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: HDTV Recorders
AVS › AVS Forum › HDTV › HDTV Recorders › iView-3500STB stopped working!