or Connect
AVS › AVS Forum › Video Components › Home Theater Computers › Intel HD 2000 - HD-Audio only at 24hz
New Posts  All Forums:Forum Nav:

Intel HD 2000 - HD-Audio only at 24hz

post #1 of 6
Thread Starter 
Hey guys,

i'm very desperate about my following issue:

I've got a Intel i5 2500k with an integrated Intel HD Graphics 2000. I can't get the HD Audio formats (DTS-HD/ TrueHD) to show up and work except when i'm setting the refresh rate to 24hz. After a reboot the HD Audio formats are showing up properly and are also played back very well (with XBMC and Total Media Theatre 6). But at 24hz the menus and windows feels very choppy and laggy.

I've tried the display drivers from th AsRock Website and also the latest Intel drivers.

Here are my specs:
Intel i5 2500k ( Intel HD Graphics 2000)
8 GB RAM
AsRock H61M/U3S3 Mainboard (BIOS 2.40)
128 GB Crucial M4 SSD
Windows 8 64bit

I've also added MonInfo information (using 60hz) and my audio settings showing 24hz and 60hz.


[
post #2 of 6

I have an i3 with HD2000 and I use Intel's drivers without issue. However during the driver's installation it sets my display to 59.x and I leave it there. If I tell XBMC to adjust the display refresh rate to the video it switches to 24hz automatically and all is well... switches back once playback stops. With XBMC be sure to pick the correct audio decoding as well (WASAPI).


Edited by Charles R - 7/23/13 at 7:19am
post #3 of 6
Thread Starter 
That doesn't work either. frown.gif Because at 60hz the HD Audio formats are all gone and i've to set it manually to 24hz and reboot my machine. Only then the HD Audio formats are available.

I've connected my HTPC via HDMI to my Denon 1611 and the Denon via HDMI to my LG 60PV250.
post #4 of 6

I'd suggest uninstalling all video drivers. Reboot, Via Device Manager delete all of your video and audio devices. Reboot and install the latest Intel drivers. Reboot and give it a try...

post #5 of 6
Thread Starter 
Okay, ill give that a try smile.gif

I'll need the following drivers, right?

Intel HD Graphics 15.​28.​15.​64.​3062


Do I need anyhing else?
post #6 of 6
Thread Starter 
Reinstalling all devices and drivers didn't help.
I've also tried OpenElec and XBMCbuntu with the sames results: No HD-Audio at 60hz frown.gif
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Home Theater Computers
AVS › AVS Forum › Video Components › Home Theater Computers › Intel HD 2000 - HD-Audio only at 24hz