or Connect
AVS › AVS Forum › Video Components › Home Theater Computers › ATI Pixel Format/Best Practice Video Settings
New Posts  All Forums:Forum Nav:

ATI Pixel Format/Best Practice Video Settings

post #1 of 17
Thread Starter 
Ok, so there are many threads on similar issues. I just can't seem to find the answers I want.

My hardware is:

Sapphire Radeon HD 7770 (using madvr,LAV)
Onkyo 818
Panasonic ST50


I believe ideally I want the video card to be RGB 4:4:4 Pixel Format PC Standard (Full RGB)? When I set this the colors look richer and the blacks are much better...but there is definitely black crush.

When I try to set RGB 4:4:4 Pixel Format PC Studio (Limited RGB) The blacks aren't nearly as deep but no crushing...and the colors not as rich.

I've also played with LAV video decoder settings to try tv, pc and untouched ranges.

The Onkyo 818 is set to Direct on the video mode so it will leave the video untouched.

The Panasonic ST50 has an HDMI mode setting that is set to auto.

What is the "proper" way to set this up?
post #2 of 17
I have the exact same video card, using the latest ati beta drivers - AMD_Catalyst_13.6_Beta2.exe.

I have the pixel format set to rgb 4:4:4, under colors, advanced, 16-235, tv set to full range (samsung f6300, "normal"). With the TV set to low (16-235), there was black crush occurring.

On the tv, you'll need to readjust the brightness, otherwise your blacks won't be black but more like dark grey.

I previously had it set on 4:4:4 YCbCr, and 0-255 under colors. With this variant, the brightness on the tv had to be turned up. Also with this setting, the tv did not permit be to toggle the black level between low (16-235) and normal (0-255).

Fwiw, I think there is some goofyness with ati's driver. With it set to 16-235, I am able to see the full spectrum in a pluge pattern, with it set to 0-255, there is definite clipping going on. Strange!
post #3 of 17
Thread Starter 
Thanks for the reply.

I think I have found the best settings but my frustrations are coming between WMC live tv vs MPC with Madvr. With ATI set to RGB Full and the HDMI range on the TV settings set to non-standard the picture is perfect in MPC but blacks washed out in live tv.

If I go and set the HDMI settings on the TV to standard live tv looks perfect...but then black crush occurring with MPC.

Also when I go into Lav filters and set 0-255 vs 16-235 I see no difference.
post #4 of 17
Thread Starter 
post #5 of 17
I have the same video card as you and the same Onkyo smile.gif


I first adjust brightness/contrast with the TV settings using the AVS test patterns running on my PS3

then

I calibrate the contrast/brightness using the AVS test patterns running in MPC-HC with madvr using the contrast brightness adjustments in ATI CCC

CCC and mad-vr both set to 0-255

looks great in both MPC-HC movies AND WMC live tv
post #6 of 17
Quote:
Originally Posted by FantaXP7 View Post

http://www.hack7mc.com/2009/06/fixing-media-centers-poor-black-levels.html

Maybe that is the best solution in my case.

This is my experience & may help you. WMC7 looked normal & its black levels matched my other components. That's because they all use 16-235 color space & so does WMC7 be default.

Then I added an HD6450 video card & things didn't look right. That's because the HD6450 default was 16-235 and when added to WMC7 16-235 was doing a double conversion.

I changed the HD6450 to 0-255 and when used with WMC7 16-235 looked OK & matched my other sources. Problem was if I did not use WMC7 and for example used MPC-HC instead. Now the color space was 0-255 & did not match my other sources.

I set the HD6450 to 16-235 and did the above WMC7 "hack" that you mentioned & it solved everything for me by making WMC7 0-255. So now I have only the one 16-235 color space and it is in the HD6450. No matter what I feed the HD6450 at 0-255 (the hacked WMC, MPC-HC, etc) it all comes out at 16-235 & matches all my other sources.

I realize a lot of people want to use 0-255 color space & I'm not against that. I'm just trying to explain that you may have a 16-235 conversion taking place that you don't want & it might be affecting your calibration & black levels.
post #7 of 17
Thread Starter 
Quote:
Originally Posted by Mike99 View Post

This is my experience & may help you. WMC7 looked normal & its black levels matched my other components. That's because they all use 16-235 color space & so does WMC7 be default.

Then I added an HD6450 video card & things didn't look right. That's because the HD6450 default was 16-235 and when added to WMC7 16-235 was doing a double conversion.

I changed the HD6450 to 0-255 and when used with WMC7 16-235 looked OK & matched my other sources. Problem was if I did not use WMC7 and for example used MPC-HC instead. Now the color space was 0-255 & did not match my other sources.

I set the HD6450 to 16-235 and did the above WMC7 "hack" that you mentioned & it solved everything for me by making WMC7 0-255. So now I have only the one 16-235 color space and it is in the HD6450. No matter what I feed the HD6450 at 0-255 (the hacked WMC, MPC-HC, etc) it all comes out at 16-235 & matches all my other sources.

I realize a lot of people want to use 0-255 color space & I'm not against that. I'm just trying to explain that you may have a 16-235 conversion taking place that you don't want & it might be affecting your calibration & black levels
.

I think this is exactly where I am at now. Though I wanted the 0-255. I am not sure which is technically best to use though?

Thanks though this sort of confirms what I am doing to be "correct".
post #8 of 17
Thread Starter 
Quote:
Originally Posted by JL-F1 View Post

I have the same video card as you and the same Onkyo smile.gif


I first adjust brightness/contrast with the TV settings using the AVS test patterns running on my PS3

then

I calibrate the contrast/brightness using the AVS test patterns running in MPC-HC with madvr using the contrast brightness adjustments in ATI CCC

CCC and mad-vr both set to 0-255

looks great in both MPC-HC movies AND WMC live tv

Ya I am trying my best not to have to touch the video settings on the TV as I did a custom panel prep and calibration found on this site.

Also you using the video processing on the Onkyo? I have mine set to either through or direct, I forget which exactly but they both don't touch the picture.
post #9 of 17
Onkyo is set on 'Direct'

If your tv is calibrated you don't need to do the PS3 step I did, leave the TV settings

What I did you need to try is using the AVS calibration file or Disney WOW on the PC and adjust the pc settings, brightness and contrast in the PC display menu , Catalyst control center. that fixed all my crush and washed out issues
post #10 of 17
Quote:
Originally Posted by FantaXP7 View Post

I think this is exactly where I am at now. Though I wanted the 0-255. I am not sure which is technically best to use though?

Thanks though this sort of confirms what I am doing to be "correct".

Everything I've read indicates that consumer electronics use 16-235. And that the HDMI spec is 16-235 for YCbCr. But that you can pass 0-255 RGB through HDMI. I'll stand corrected on that, but that's my understanding.

Blu-ray discs are mastered in YCbCr which is 16-235. AFAIK OTA HD is also 16-235.

I'm not sure the reason for using 0-255 video. Maybe a PC converts 16-235 to 0-255 and therefore people want to stay with that instead of converting back to 16-235 when sending out the video. But I'm not sure if that's how it works. I guess if the HTPC uses 0-255 then it makes sense to pass this to the HDTV.

One advantage of using 16-235 is that you can display blacker-than-black video which makes it easier to adjust your HDTV, presuming the TV can display B-T-B.
post #11 of 17
Films are YCbCr 16-235 but a PC coverts YCbCr to RGB so it is better stay with RGB. The reason to pass 0-255 is that desktop, games, pictures, etc are 0-255 so if you converts film to 0-255 you will have all ok. Whit better words:
Code:
My recommendation is always to set configure your display so that it expects PC levels (full range). This has 2 important benefits: (1) Levels will be correct for everything, including games, photos, applications and video playback. (2) There should be no problem with image quality.

If your display can't do PC levels, or if you have good reasons for not using this solution, then you have 2 alternative solutions:

(a) Either set the GPU to limited range and madVR to PC levels. This means madVR will render to PC levels and the GPU will afterwards stretch the madVR output (and desktop, games, applications, photos etc) to limited range. Using this approach still has the benefit of having correct levels everywhere. But image quality might suffer because the GPU usually uses a rather bad stretching algorithm, which can introduce banding artifacts.

(b) Or set the GPU to fullrange and madVR to TV levels. This will result in good image quality (no artifacts) and correct levels for video playback. However, desktop, games, applications and photos will have wrong levels.
post #12 of 17
My HD6450 is set for YCbCr / 16-235. But I'm led to believe that is only for video. And that the desktop & pictures are still 0-255, which do look proper. I seem to recall displaying some 0-255 monitor test patterns and all shades were visible. I'll try this again later in order to verify.
post #13 of 17
In the CCC the Pixel Format is under “My Digital Flat Panels” and the Dynamic Range is under “Video”. I’m using YCbCr 4:4:4 Pixel Format and Enhance Smooth Video Playback which sets the Dynamic Range to Limited (16-235).

I viewed a black level .png test image using WMC7, Windows Photo Viewer, & IrfanView. All displayed down to black level 1.

And I can display blacker-than-black video, which helps in setting the HDTV black level.

I guess I could change the HTPC to output 0-255 and use a different input on the TV. OTOH all my sources match at 16-235 color space & I do not see any color space conversion artifacts, whatever they may look like.

I'll have to experiment later.
post #14 of 17
Thread Starter 
Quote:
Originally Posted by Mike99 View Post

In the CCC the Pixel Format is under “My Digital Flat Panels” and the Dynamic Range is under “Video”. I’m using YCbCr 4:4:4 Pixel Format and Enhance Smooth Video Playback which sets the Dynamic Range to Limited (16-235).

I viewed a black level .png test image using WMC7, Windows Photo Viewer, & IrfanView. All displayed down to black level 1.

And I can display blacker-than-black video, which helps in setting the HDTV black level.

I guess I could change the HTPC to output 0-255 and use a different input on the TV. OTOH all my sources match at 16-235 color space & I do not see any color space conversion artifacts, whatever they may look like.

I'll have to experiment later.

I'm curious what you would think of it.

I learned a bit from you all in this thread. Though I am still with 0-255 set in CCC and my HDMI setting on my tv set to non standard I see a noticeable difference in color and black level performance with out any crush in the blacks. It seems like the perfect settings for my setup. Maybe it varies tv to tv.

And another thing, do people have a setting in madvr for this or is it just Lav filters like I have only seen? The setting I try in Lav seems to do nothing.

Thanks
post #15 of 17
Thread Starter 
Quote:
Originally Posted by HDWorld View Post

Films are YCbCr 16-235 but a PC coverts YCbCr to RGB so it is better stay with RGB. The reason to pass 0-255 is that desktop, games, pictures, etc are 0-255 so if you converts film to 0-255 you will have all ok. Whit better words:
Code:
My recommendation is always to set configure your display so that it expects PC levels (full range). This has 2 important benefits: (1) Levels will be correct for everything, including games, photos, applications and video playback. (2) There should be no problem with image quality.

If your display can't do PC levels, or if you have good reasons for not using this solution, then you have 2 alternative solutions:

(a) Either set the GPU to limited range and madVR to PC levels. This means madVR will render to PC levels and the GPU will afterwards stretch the madVR output (and desktop, games, applications, photos etc) to limited range. Using this approach still has the benefit of having correct levels everywhere. But image quality might suffer because the GPU usually uses a rather bad stretching algorithm, which can introduce banding artifacts.

(b) Or set the GPU to fullrange and madVR to TV levels. This will result in good image quality (no artifacts) and correct levels for video playback. However, desktop, games, applications and photos will have wrong levels.

Interesting...now I want to go back and experiment some more with these settings even after finding a combo that seems to work wink.gif

Thanks
post #16 of 17
The only setup that works 100% correct and consistent on everything is 0-255 and YCbCr 4:4:4 Pixel Format. I have an AMD 5450. All other advanced processing is turned off as well.
post #17 of 17
"When movies are played on a PC, someone somewhen has to convert YCbCr to RGB."
With YCbCr output:
"If the graphics card first converts the YCbCr source to RGB, then converts it back to YCbCr for output."

Double conversion:
YCbCr -> RGB -> YCbCr
Code:
If your display supports 0-255, then setup is easy - set everything to 0-255 and you don't have to think about it.
If your display does not support 0-255, will have to compromise.

The first option is to have everything set to 0-255, except for the video card output, so that on the output stage it is being converted to 16-235. This means that all content is kept at the same levels (desktop & video) but the conversion to 16-235 on output may introduce banding. If you are using your PC for more than just video playback, this is the setup you have to use.

However, if you are going to be using the computer exclusively for watching videos through madVR, you have a second option. What you can do is set the video card output to 0-255, and set madVR to 16-235.

This will avoid the potential banding from having the video card compress the output levels to 16-235. But it will make anything that is not video look terrible, as anything on the desktop will still be outputting 0-255, and all values above 235 and below 16 will be clipped. (very high contrast image with no shadow/highlight detail)

I would only suggest doing this if your are only using the PC for video playback, and are seeing banding from the video card outputting 16-235.

Edited by HDWorld - 8/1/13 at 2:28am
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Home Theater Computers
AVS › AVS Forum › Video Components › Home Theater Computers › ATI Pixel Format/Best Practice Video Settings