or Connect
AVS › AVS Forum › Video Components › Home Theater Computers › Can't get blurays to play after windows 8 "up"grade
New Posts  All Forums:Forum Nav:

Can't get blurays to play after windows 8 "up"grade

post #1 of 11
Thread Starter 
Hi there!

I recently upgraded from windows 7 (where blurays were working fine on total media theatre 6) to windows 8 and suddenly I cannot play bluray at all on powerdvd, totalmedia theatre, or corel windvd pro.

I've tried all 3 software, reinstalled each one, and updated each one to their latest edition. None work.

I've also tried multiple disks (planet earth, life, and frozen planet) and none work.

Lastly, I updated my nvidia drivers (I have a gtx 240) to the latest edition.

For windvd & powerdvd, nothing happens when I press the play button. For total media, the first 5 seconds (usually the FBI warning, and then a few seconds of the intro video) will play and then it'll freeze and stop playing, returning me to TMT's opening screen.

Since 3 different software all failed, my guess here is that there's something else wrong. However, after hours of trying everything I can think of, I cannot figure this out.

If you have any ideas I'd enormously appreciate your help here.

Thank you in advance!!
post #2 of 11
Did you try asking on the support forums of the vendors respectively?
While its weird that it affects all of them, it might still be a simple bug in their software.
post #3 of 11
Did you actually upgrade from Win7 to Win8 or did you do a clean install from Win7 to Win8. If it was an upgrade then that might be your problem.
post #4 of 11
Thread Starter 
Good idea - I'll give that at try as well. Thanks for the response.
post #5 of 11
Thread Starter 
Nope - it was a clean install :/.
post #6 of 11
Try replacing your video drivers. If you use ATI, download their official cleaner tool and use it prior to reinstalling the latest drivers from them.
post #7 of 11
Thread Starter 
Quote:
Originally Posted by cybrsage View Post

Try replacing your video drivers. If you use ATI, download their official cleaner tool and use it prior to reinstalling the latest drivers from them.

Hi Cybersage,

I installed the latest nVidia drivers with no luck. Any other ideas?

Thanks,
Eric
post #8 of 11
Which version of Win8 did you install: Standard, Pro, or Pro+WMC?

If you don't have WMC, you may be missing some of the key codecs.

FWIW, I'm on Win8 Standard, and I installed MediaPortal as my DVR solution, which came bundled with the LAV filters/codecs. Works great.

But if you're already on Pro, likely worth the $10 for WMC.
post #9 of 11
Both PowerDVD and WinDVD have their own codec support built in. They don't rely on OS codec support. $10 for WMC won't buy you much (mainly MPEG2 codec support in OS).
post #10 of 11
I would not buy the WMC app if all you want is the codec. I bought it for all the goodness that WMC brings as a front end.
post #11 of 11
Thread Starter 
Quote:
Originally Posted by Foxbat121 View Post

Both PowerDVD and WinDVD have their own codec support built in. They don't rely on OS codec support. $10 for WMC won't buy you much (mainly MPEG2 codec support in OS).

Thanks FoxBat - yes this is my understanding to.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Home Theater Computers
AVS › AVS Forum › Video Components › Home Theater Computers › Can't get blurays to play after windows 8 "up"grade