or Connect
AVS › AVS Forum › Display Devices › Direct View (single tube) CRT Displays › Convergence problem with Sony WEGA KD-34XBR970
New Posts  All Forums:Forum Nav:

Convergence problem with Sony WEGA KD-34XBR970

post #1 of 2
Thread Starter 

I bought this 34" behemoth of a CRT used a few years ago and had to adjust convergence at that point as it was pretty far off.  It's been fine for years, even through two moves, but today I noticed that it's way off again (almost 1/2" horizontally).  The blue is separated to the left while the red is separated to the right, so I thought for sure YBWU and YBWL in service mode were going to do the trick.  But, when I went to adjust them, nothing happened.  I tried moving both values all the way down to 0 and all the way up to 63, but there was zero visible change.

 

Is it possible the dynamic convergence system has failed?  If so, how hard/expensive is that to repair or replace, and where would I go to find information on how to do it?  I've heard that the minimum cost of getting a technician is probably close to twice what I spent on the TV to begin with, so that's probably not an option.  But, I'm sort of a EE so I may be able to work out the fix.

 

Any suggestions?

post #2 of 2
Welcome! bjp.

There is a thread about your 970 here in the forums. Hopefully, someone has posted a remedy to your situation. If not, post the query in the ISF Calibrators thread. There are several guys who still perform treatments to the Sony 960/970 CRT sets.smile.gif
New Posts  All Forums:Forum Nav:
  Return Home
AVS › AVS Forum › Display Devices › Direct View (single tube) CRT Displays › Convergence problem with Sony WEGA KD-34XBR970