or Connect
AVS › AVS Forum › Display Devices › CRT Projectors › Toshiba 51hx93 sound but no picture problem
New Posts  All Forums:Forum Nav:

Toshiba 51hx93 sound but no picture problem

post #1 of 6
Thread Starter 

My Toshiba 51HX93 CRT rear projection TV recently quit working in an odd way. I hope the following description will allow someone knowledgeable to tell me what the likely problem is and whether or not I should pursue a repair vs. a new TV.

 

I have had the TV hooked up to an over the air antenna (antenna input) and to my PS3 (DVI input) for a long time with no problems. However, today I only can hear sound on the over the air antenna. I can't see any picture. It is dark. This happens no matter what channel I choose. Furthermore, when I switch the input to DVI for my PS3, there is likewise no picture. It is also dark.

 

Now, for the interesting part: The onscreen setup menus show perfectly well. Also, when I put in an SD card with photos, I am able to view the photos just fine. Therefore, I am sure that the basic "projection" part of the TV is working fine. What appears to be the problem is whatever circuit board takes the inputs from the antenna and DVI, processes the signal and sends it to the projection unit.

 

Does this help anyone localize my problem?

post #2 of 6
that's called your video input board. If you can locate it, remove it, and fine someone to repair it you might get it going again. Your best bet though is to find an "organ donor" set to rob parts out of
Do you have a manual that walks you through the chassis lay-out?
post #3 of 6
Thread Starter 

I found a service manual online. I am reasonably handy, but no TV or electronics repairman. Is there a "junkyard" store where one can order such parts as the video input board? I doubt I could find one locally, and if I could it would probably make more sense to junk my TV and buy the other.

post #4 of 6
Quote:
Originally Posted by cnil1 View Post

Is there a "junkyard" store where one can order such parts as the video input board? I doubt I could find one locally, and if I could it would probably make more sense to junk my TV and buy the other.
there's an entire forum on Curt Palme .com dedicated to front projection CRT's, the ones you hang from the ceiling,and parts for those are bought, sold, and traded regularly. You could post a WTB (wanted to buy) there in the for sale section. Check with McGyver on that forum by sending him a private message, he repaired a lot of these types of electronics as well.

Unfortunately,I do not know of a forum or web-site dedicated to RPTV. It seems like people were really in a hurry to get rid of these once they broke. Not saying there isn't a group of enthusiasts out there,just don't know of one. On e-bay there are occasionally sellers are willing ot take things apart and sell you pieces, like this DVI input board for your set

http://www.ebay.com/itm/TOSHIBA-DIGITAL-VIDEO-MODULE-PD1243-23599680-FROM-51H93-/121143725404?pt=US_TV_Boards_Parts_Components&hash=item1c34ba8d5c

not sure this would fix your problem since you said your antenna also isn't working and that's a coaxial cable?
post #5 of 6
post #6 of 6
Go into the tv menu and make sure closed caption is turned off and/or make sure it is not in text mode.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: CRT Projectors
AVS › AVS Forum › Display Devices › CRT Projectors › Toshiba 51hx93 sound but no picture problem