or Connect
AVS › AVS Forum › Gaming & Content Streaming › Home Theater Gaming › HTPC Gaming › I'm getting flickering and trails/ghosting, but only in *some* games. Help?
New Posts  All Forums:Forum Nav:

I'm getting flickering and trails/ghosting, but only in *some* games. Help?

post #1 of 7
Thread Starter 
My PC - 3570K / 8GB / 7970

I have my PC connected to my HDTV - a Vizio E701i-A3 - over HDMI.
Game Mode is on, and all video enhancement / smoothing is off.

In a few games - Skyrim and Bioshock Infinite so far - I'm getting significant problems with movement. In Skyrim, the screen blurs when I turn, and there are trails coming off objects in the direction that i'm turning. In Bioshock Infinite, there is ghosting and doubling, as if the TV is a frame behind.

Windows (mouse cursor / window movement) and some games (Strike Suit Zero, Dolphin emulator (Zelda Wind Waker)) display on the TV with no problems. I noticed an occasional flicker, though, in Windows.

The TV does not have these issues on any other input (including PS3 / Xbox), so it's not the TV.
Skyrim is locked at 60FPS (internal vsync).
Skyrim and Bioshock Infinite do not have these problems on my monitor (2560x1440), so it's not the games themselves.
I did not have these problems on my last TV over HDMI, so it's not my video card's HDMI port.
The TV is displaying the PC at 1:1 so it's not a scaling issue.

Based on all that, I assume it's something wrong with my settings in Windows.

I'm not sure if this matters, but Windows shows the TV as having a refresh rate of 60hz, but Catalyst Control Center says "Maximum Reported Refresh Rate 75hz"

I'm not sure what else to try. Any Ideas?
post #2 of 7
"I did not have these problems on my last TV over HDMI, so it's not my video card's HDMI port."

Based on that, I would say it's the TV's fault. Not sure why some games don't exhibit the issue though.

Have you tried turn on/off v-sync at the driver level instead of within game?
post #3 of 7
Thread Starter 
Quote:
Originally Posted by DaverJ View Post

"I did not have these problems on my last TV over HDMI, so it's not my video card's HDMI port."

Based on that, I would say it's the TV's fault. Not sure why some games don't exhibit the issue though.

Have you tried turn on/off v-sync at the driver level instead of within game?

Well, wind waker I just realized i have limited to 30fps. But its not a screen tearing issue...the trailing and stuff seems like a refresh rate thing but I'm surprised it's not happening in Strike Suit Zero.
post #4 of 7
Do Radeon cards have an option to limit Vsync to half the displays refresh rate? I know it wouldn't be smooth, but it would be interesting to see if you get get the same issues at 30fps.

Also, does the Vizio share an HDMI input with DVI? You might want to try that input, and if there's a PC mode, switch to that.
post #5 of 7
Thread Starter 
Update:

I took this short video to show what the trailing is like...watch his lips:

Also, some more testing:
I started by resetting CCC to all defaults.

Different TV HDMI input - no change.
Setting refresh rate on the PC to 59HZ - no change
Setting vsync to "Always On" - no change
Enabling triple buffering - no change

Dishonored @ max settings - same judder that i had with Bioshock, but no trails.
Strike Suit Zero @ max settings - - no problem AT ALL, even with vsync off! No trails or doubling.
Tropico 4 @ max settings - - no problem AT ALL, even when moving extremely
PS3 games - no problem AT ALL even with fast motion games.

I'm still at a loss here. The TV's refresh rate is 60hz, but it seems like frames are getting screwed up somewhere in the process, but only in some games. I'm downloading Darksiders II to try it in another game.
post #6 of 7
Thread Starter 
Quote:
Originally Posted by gui3 View Post

Update:

I took this short video to show what the trailing is like...watch his lips:

Also, some more testing:
I started by resetting CCC to all defaults.

Different TV HDMI input - no change.
Setting refresh rate on the PC to 59HZ - no change
Setting vsync to "Always On" - no change
Enabling triple buffering - no change

Darksiders 2 @ max settings - exhibited trails off the edges of objects as well.

Dishonored @ max settings - same judder that i had with Bioshock, but no trails.
Strike Suit Zero @ max settings - - no problem AT ALL, even with vsync off! No trails or doubling.
Tropico 4 @ max settings - - no problem AT ALL, even when moving extremely fast.
PS3 games - no problem AT ALL even with fast motion games.

I'm still at a loss here. The TV's refresh rate is 60hz, but it seems like frames are getting screwed up somewhere in the process, but only in some games. I'm downloading Darksiders II to try it in another game.
post #7 of 7
Thread Starter 
bump - any ideas?
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: HTPC Gaming
AVS › AVS Forum › Gaming & Content Streaming › Home Theater Gaming › HTPC Gaming › I'm getting flickering and trails/ghosting, but only in *some* games. Help?