or Connect
AVS › AVS Forum › Audio › Receivers, Amps, and Processors › PC to TV via Onkyo - HDMI Problems
New Posts  All Forums:Forum Nav:

PC to TV via Onkyo - HDMI Problems

post #1 of 4
Thread Starter 

 Hello there. First post so treat me gently!

 

Having trouble getting sound via HDMI. The set up is a Lenovo laptop running Windows 8. This feeds via HDMI an Onkyo TX-SR705 amp. Then again via HDMI I'm feeding an LG flatscreen tv.

I get perfect video but no sound.

If I connect the PS3 to the amp instead of the laptop I get sound and video. If I connect the laptop direct to the tv then again I get both sound and video. I've tried swapping the two HDMI leads over. I've tried resetting the Onkyo to factory default settings.

Any help appreciated!

post #2 of 4
On my Dell laptop, I have to switch between the source to get the sound from HDMI. I do it in the sound tab in control panel
post #3 of 4
Thread Starter 
Quote:
Originally Posted by Spetznaz24 View Post

On my Dell laptop, I have to switch between the source to get the sound from HDMI. I do it in the sound tab in control panel


Cheers for that. But.........without doing anything to the laptop settings, if I take the amp out i.e. laptop connected directly to the tv then sound comes on the tv. Almost as if the amp isn't "seeing" the HDMI audio coming out of the laptop.........which I know is there. Somebody mentioned "PCM" but not sure on that.........

post #4 of 4
Do you actually know what your pc is outputting?... just knowing that "something" is being sent out on hdmi isn't knowing much. You have to ensure that the coding sent is the coding that the receiver is expecting and / or can handle.

Look at the display on your receiver, what is it indicating for incoming audio... that will be your clue.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Receivers, Amps, and Processors
AVS › AVS Forum › Audio › Receivers, Amps, and Processors › PC to TV via Onkyo - HDMI Problems