or Connect
New Posts  All Forums:Forum Nav:

How to SSH to my freenas?

post #1 of 3
Thread Starter 

So currently I am running a freenas on my laptop for now just to mess around with it and get familiar with it before I go and buy and setup a system for myself. I currently have plex up and running with it. Now the problem is I wanted to do SSH to my freenas from my phone for now as it is the only thing with another wireless wifi (3g/lte). I have enable the service SSH/FTP and Dynamic DNS on the freenas and I also register for a DNS with no-ip.com. I have my SSH port to 22 and port forward it already on my router.

 

The problem is when I go into a SSH app on my phone and enter the DNS to it, it usually say can not connect to [DNSHostname]/@192.168.0.107. I usually get this error when I am doing it on my lte. The username on the SSH I am using is root and for the password I put my password that is for the login on freenas.

post #2 of 3
What app are you using on your phone? Do you have to append the port # (x.x.x.x:22 or hostname.no-ip.com:22) to it? Are you running FreeNAS natively on the laptop or virtual? if Virtual, what about the software firewall on the host OS? Can you ping your DDNS name from outside your home network?

After re-reading your post, you've enabled SSH/FTP, but have you enabled the root account to login remotely via SSH? and you really don't want to allow the root account SSH access...at all. Create another account and give that account SSH/Shell access.
post #3 of 3
If you have Android, JuiceSSH is a good app.

Can you SSH from inside the house? You should make sure that is working before trying from the outside.

From the outside, you'll setup your app to connect to .no-ip.com and then supply your login/pwd. (probably using "admin" for the login account?)

Make sure you have a strong password.

I'd also recommend using port translation on your router if it's supported. Port 22 will be scanned by all of the hackers out there. Changing the port to 10022 would be better. (just make sure you use that port in your SSH app then)
New Posts  All Forums:Forum Nav:
  Return Home