post #1 of 1
Thread Starter 

I posted in another thread i have a Sony vp-7040 u matic vcr i got it some time ago from a reuse shop ( last stop to the dump) ! but got it home and it played tapes fine no problems at all.

i tried it again a while back when i got some other tapes and its just loaded and none of the buttons works.

i just get a stand by light stay on.

When you power it up i can hear a relay or some thing electro mechanical switch on then the play button light comes on for a second or 2 and then the standby light is on and nothing on the button side of things work will not eject either ..counter number lights are on so i thing the power supply is fine .

Its a front loader i can see all the sensor leds seem to work and it also has a few tiny light globes not sure but i think they are just there so you can see the inside workings perhaps in case it screws a tape up ? 

But nice if any one can help ....not sure if this has belts or not i have not looked under it .Any one that has worked on these machines might know any case thanks for reading good advice always welcome .

Harry