or Connect
AVS › AVS Forum › Display Devices › Digital Hi-End Projectors - $3,000+ USD MSRP › Uggh! How bad are stuck pixels? Advice Please!
New Posts  All Forums:Forum Nav:

Uggh! How bad are stuck pixels? Advice Please!  

post #1 of 6
Thread Starter 
Well, it happened last night. After 4 hours of running my VPL-VW10HT through it's paces (I walked step by step down the 10HT FAQ, I even bought Video Essentials for the test patterns) I decided this one was a keeper and started watching the first movie in my HT with my family. At the very end I shut the DVD player off, and to my chagrin my wife pointed to a single bright blue dot on the screen that looked like a blue version of a laser pointer. Yep, a stuck pixel, stuck on none-the-less.

So here's my quandry. With 6 hours of lamp time I would now have to pay a $780 re-stocking fee to return it. Is it worth it? I've read conflicting reports on this. Some say you'll almost never notice it and some say you can't live with it. Obviously after 4 hours of looking and not finding it it's hard to spot. However, now that I know it's there and where it is will my eye always be drawn to it?

Anyone out there in a similar circumstance? Any advice?
post #2 of 6
Shouldn't it be under warrenty to fix that kind of thing I would give them a call and see what they can do.

PS on a seperate note did you know there is a web site and a Home Theater group in your area. Called Dallas Home Theater Group. The web site is http://dhtg.org/dhtgcgi-bin/Ultimate...assCookie=true Drop by some time.

------------------
FLABOY
www.hometheater71.homestead.com
post #3 of 6
Thread Starter 
Quote:
<font face="Verdana, Arial" size="2">Originally posted by FLABOY:
Shouldn't it be under warrenty to fix that kind of thing I would give them a call and see what they can do.

</font>
No, unfortunately, like laptops or any LCD device a certain amount of dead pixels are expected/allowed in the manufacturing process. I will take the advice of the 10HT FAQ and write a nice letter to Sony asking for replacement but according to the FAQ it's unlikely they will fix/replace the unit since they do not consider a few dead pixels a defect.

Also, thanks for the link, I'll look it up!
post #4 of 6
If you are working with a good dealer they should exchange it for a projector without a problem. The first 10HT I received had a stuck blue pixel. I called MVS told them I would like to replace the projector and asked them if they could pre-screen this one for defects. They agreed and gave me an option to return this one and once they received it they would ship out the replacement or they would ship me out a replacement immediately and charge me for it and once they received the defective one they would credit my account. I opted for them to send a replacement immediately and coordinated the delivery with the pickup of the defective unit. Now every thing is fantastic. IMO I think you should politely and respectively expect quality service from whoever you purchased the equipment from. BTW by the time it took coordinate pickup of the defective unit I had 25 hours of time time on the bulb.

Regards,

Brian
post #5 of 6
Thread Starter 
Quote:
<font face="Verdana, Arial" size="2">Originally posted by btmoore:
If you are working with a good dealer they should exchange it for a projector without a problem. The first 10HT I received had a stuck blue pixel. I called MVS told them I would like to replace the projector and asked them if they could pre-screen this one for defects. They agreed and gave me an option to return this one and once they received it they would ship out the replacement or they would ship me out a replacement immediately and charge me for it and once they received the defective one they would credit my account....
IMO I think you should politely and respectively expect quality service from whoever you purchased the equipment from. BTW by the time it took coordinate pickup of the defective unit I had 25 hours of time time on the bulb.
</font>

Well, my story will have a happy ending now thanks to Darren at ProjectorPeople.Com (actually I think Darren is with AVI Inc so they must be affiliated). He helped me immediately get connected to someone directly at Sony that started helping me.

That's where things got worse. The tech at Sony notified me of some things to try to do to fix it that would have voided my warranty. Fortunately for me I dropped projectorpeople an email to let them know the status. A few minutes later my phone rang and Darren was on the phone letting me know NOT to do that since I would not be able to get a replacement/repair with a voided warranty.

He then called Sony, pre-arranged a replacement unit that was sent to my house, and is having Fed-Ex come and pick the unit up for repair/replacement within 7 days. That was it, no fighting with Sony, no problems whatsoever. ProjectorPeople stood behind their product and gave some very proactive and helpful customer service!
post #6 of 6
Thread Starter 
Quote:
<font face="Verdana, Arial" size="2">Originally posted by GoBlue:

He then called Sony, pre-arranged a replacement unit that was sent to my house, and is having Fed-Ex come and pick the unit up for repair/replacement within 7 days. That was it, no fighting with Sony, no problems whatsoever. ProjectorPeople stood behind their product and gave some very proactive and helpful customer service!
</font>
Well, my story does have a happy ending, again, thanks to Darren at ProjectorPeople. I received by projector back from Sony. I hooked it all up again and started the Matrix. The same blue dot appeared immediately. So I took a few quick snapshots of the screen and sent it to Darren. No questions asked he sent me an RMA. I overnighted the projector back to them on their account and he QA'd a new projector to make sure it had no problems before shipping me a new one.

Based on this entire experience I give ProjectorPeople the highest marks for customer service!
New Posts  All Forums:Forum Nav:
  Return Home
This thread is locked  
AVS › AVS Forum › Display Devices › Digital Hi-End Projectors - $3,000+ USD MSRP › Uggh! How bad are stuck pixels? Advice Please!