or Connect
AVS › AVS Forum › Gaming & Content Streaming › ReplayTV & Showstopper PVRs › More New Replay 5000 Software Toys!
New Posts  All Forums:Forum Nav:

More New Replay 5000 Software Toys! - Page 5  

post #121 of 156
moeronn...

It IS fun! I 've already played with it even though I have no forseeable use for it.

The DVD part is also true, and I hadn't thought of that.
post #122 of 156
I've been playing with the rtvconvert tool, but have yet to have success converting a video. Today I got it to run with a couple of my videos, but keep getting this error:

D:\\Video Capture>rtvconvert test.mpg sample.mpg
Source: test.mpg
Target: sample.mpg
Lost MPEG sync at 000000000E: 01 BB 00 0C
Convert Time: 000:00.035

Why did it end like that, and what does this error mean?
post #123 of 156
Quote:
Originally posted by JohninLA
I've been playing with the rtvconvert tool, but have yet to have success converting a video. Today I got it to run with a couple of my videos, but keep getting this error:

D:\\Video Capture>rtvconvert test.mpg sample.mpg
Source: test.mpg
Target: sample.mpg
Lost MPEG sync at 000000000E: 01 BB 00 0C
Convert Time: 000:00.035

Why did it end like that, and what does this error mean?
Take a look at the documentation. Your input MPEG has to meet some very specific criteria, and chances are good that your test.mpg doesn't.
post #124 of 156
I've been trying to convert 4xxx files to 5xxx format with no success. When I use rtvconvert like this:

rtvconvert "Ken Burns American Stories - 2003-05-28.mpg" "Test.mpg"

I get a resulting mpg file that is 1k in size.

When I try to use it with an edit file I get an error:

E:\\DVArchive\\Local_Guide>rtvconvert edit1.txt
rtvconvert <source.mpg> <dest.mpg>

Source streams must be:
Resolutions: 352x480, 480x480, 720x480
Video rate: 29.97fps @ 2-8Mbps
Audio rate: 48kHz @ 112-320kbps
GOP struct: 1/5/2, 1 sequence per GOP, max 15 frames

Here's the text of my edit file:

FKen Burns American Stories - 2003-05-28.mpg
TLocal_Guide\\Test.mpg
E

The files I'm trying to convert were downloaded to my machine with DVArchive.

Any idea what I'm doing wrong? I've read through the docs, but can't find the answer... Thanks!

eddie
post #125 of 156
Thread Starter 
Try rtvedit edit1.txt.
post #126 of 156
OK, I used rtvedit instead on the text file and I got this:

RTV 4K Source - EXPERIMENTAL - STREAMS MIGHT NOT PLAY!
Source: Ken Burns American Stories - 2003-05-28.mpg
Target: Test.mpg
Time=(000:00.495, 089:57.280) SCR=000:00.495 File=(0000000830, 00AB738000)
Lost MPEG sync at 0000030114: C9 57 BA 52
New Program Time: 089:56.785
Edit Time: 000:00.063

The resulting mpg file is 190k in size and is basically a screen grab of the first frame of the video...

What am I doing wrong?

Thanks for the help!

Eddie
post #127 of 156
You're not doing anything wrong.

This message comes up when there is a problem with the stream. Try starting at a later point in the stream. For example, to skip over the first 5 seconds:

FKen Burns American Stories - 2003-05-28.mpg
TTest.mpg
A000:05.000
E

This might get you around the problem area.
post #128 of 156
Yep, that did it! Thanks for the help!

eddie
post #129 of 156
I read all of the posts to try to figure out how to get
RTVEDIT to work, and I have gotten this far....

My first "script" was as follows:

FInput.mpg
TOutput
A0:00:00.000
D0:00:13.747
A0:13:06.019
D0:17:12.498
A0:24:30.502
D0:28:06.685
A0:40:00.732
D0:43:51.796
A0:50:34.832
D0:54:01.038
A0:59:29.499
D0:59:59.496
E

No luck with this, (all 5k input files, .exe & script were in the root dir):confused:


Then, I tried this script:

FInput.mpg
TOutput
A0:00:00.000
D0:00:13.747
A0:13:06.019
D0:04:06.479
A0:24:30.502
D0:03:36.183
A0:40:00.732
D0:03:51:064
A0:50:34.832
D0:03:26:206
A0:59:29.499
D0:03:29:997
E

.......and it didn't work either:confused:


(The difference is in the "D" value. The first script has the start and stop times for the segments to be deleted, and the second script has the start time and the duration of time to be deleted.

What gives? The error message is "Invalid time" for all the values of "D".

Any help would be interesting.

can anyone figure this out?:) :)
post #130 of 156
The second one looks way off. You want times within the program, not durations. Each number should be larger than the last.

The first one looks off too, in the punctuation. I don't have anything in front of me, but I don't remember that many ':' in the script file. I think it's more like

AMMM:SS.sss

That is
A(3 digits of minutes):(2 digits seconds).(100th of second)

Not: A(hours):(minutes):(seconds).(100th of second)
post #131 of 156
here is the example included in the rtv5ktools.zip archive. It shows the expected time format:

D:\\video\\Local_Guide> evtdump "Stargate SG-1 - Revisions.evt" > evt.txt
D:\\video\\Local_Guide> type evt.txt
FStargate SG-1 - Revisions.mpg
A000:51.147
D003:28.305
A005:34.156
A006:04.587
D017:48.467
A020:47.321
A021:17.452
D027:17.890
A029:18.122
A029:48.109
A030:28.228
D036:27.278
A039:53.226
A040:23.639
D047:00.935
A049:47.267
D059:45.907
A060:43.832
A060:48.875
E
post #132 of 156
Heeding your advice, I tried the following script:

FInput.mpg
TOutput
A000:00.000
D000:13.747
A013:06.019
D017:12.498
A024:30.502
D028:06.685
A040:00.732
D043:51.796
A050:34.832
D054:01.038
A059:29.499
D059:59.496
E

And surprise, surprise.....

I got a file with only commercials. Hmmm.

Then, I tried this script and....

FInput.mpg
TOutput
A000:13.747
D013:06.019
A017:12.498
D024:30.502
A028:06.685
D040:00.732
A043:51.796
D050:34.832
A054:01.038
D059:29.499
E

and C'est Magnifique!!

It seems that I don't have the first set of RTV Tools, and the
documentation that goes with them, so you have been of
great help. (Also it wasn't helping that I had not gone to sleep
last night)

Thanks Again:)

It seems that neither the commercial skipping algorithm in RTVEDIT, nor the one in the RTV decoder hardware are perfect. There always seems to be one or two that slip by.....

So I have resorted to using VirtulalDubMod to find the 'timestamps', then inserting those into the RTVEDIT script for shows that I want to archive onto DVD's or to CD's via DivX/XviD/other encoders etc. etc.

Thanks also to the 'mystery' programmer.:) It is very generous of him/her.
post #133 of 156
I tried the conversion functionality of rtvedit with the following script:

F1061092800.mpg
TAnatomy of a Shark Bite.mpg
A00:10.344
D14:28.835
A18:26.105
D28:34.980
A32:20.472
D39:21.860
A44:38.676
D50:59.823
A54:25.195
D70:40.870
A74:57.927
D86:35.657
A90:31.793
D98:46.454
A103:28.436
D111:19.339
A113:50.857
D119:31.131
E

First I exported the 4x files, ran the script/program on the set, and got a 5x fileset.

Then I imported the 5x fileset into DVArchive and attempted to stream it to a 5x machine.


The files ran beautifully on the PC (VideoLAN player), but there were a couple of problems with the stream to the 5x machine.

The stream (DVArchive v 2.1) plays fine for about 5 or 10 min. then begins to skip, first
repeating a phrase/frames two times, then 3 times, then eventually there is an error message on the TV screen saying "video temporarily unavailable". The skipping can be stopped by using the 30 sec skip key on the remote.

Also, the "play from the beginning" (vs. the "play") on-screen button in the replay guide menu crashes the 5x machine.


Hope this helps the programmer(s)......
post #134 of 156
I have found that the commercial detection algorithm in rtvedit is not as good as the one in the RTV. In some cases, it finds almost no commericals. In other cases, it finds the breakpoints for the commercials, but does not mark them as such in the output file.

As for the RTV crashing, note that there is a known issue with the RTV streaming from DVArchive. For many people, if you try to stream 2 shows in a row from DVA to RTV, the RTV will reboot. The workaround is to watch a show stored natively on the RTV before trying to stream a second show from DVA.

These are great tools.
post #135 of 156
Thanks again bholio. They are great tools.

I'm not worrying too much about problems now with DVArchive and the 5k RTV's (I assume that that's what's being referred to in the comment about 2 shows streamed in a row crashing) --unless one only has a 5k. Although I haven't observed that problem myself as I just got my 5k, I just realized that you most likely mean that the problems are not with RTVEDIT, but with DVArchive and the new 5k's. Perhaps the DVArchive programmers and the RTVEDIT programmer(s) will have to exchange some information.

Not to worry, it's a big relief to have found something that's free that allows me to at least review the video and find the frame/timestamp (VirtualDubMod) in order to cut out the commercials before transcoding (RTVEDIT).


I have both a 4k and a 5k. DVArchive (the latest release) works very well with the 4k, (much better than the earlier releases did). I have been able to either record from broadcast or play from the 4k and download to DVArchive simultaneously, or download from the 4k while streaming from it or DVArchive simultaneously without crashing.

This is something that I could not do with the earlier releases of DVArchive though. I do have to say that the CPU/ASIC in the 4k does not have the processing power 'overhead' to handle a series of fast navigation commands from the remote while it's doing this though. Perhaps the 5k's CPU/ASIC is a little more powerful.

At any rate, if there is any enthusiasm still in the programming team at sourceforge/DVArchive, then I'm sure that they will continue to improve the interface. I think that DVArchive is so cool, that I actually want to tackle my Java programming book that's been sitting in my bookshelf for a couple of years now!!

That would be a big job (for me) though, as the only thing I can program at this time is my Texas Instruments graphing calculator.
post #136 of 156
The "play from beginning" crashes since it is streaming a second program without an intervening tune or local playback (see the "linkie-poo" in post #35 of this thread).

The skipping after 10 minutes seems to only occur on Windows systems and is an issue covered in the DVArchive FAQ. Some folks have had luck with using TCPOptimizer and changing a few settings.

//dvarchive.sourceforge.net/dvarchive_faqs/generalTroubleshooting_1.shtml#08131851

(would have been the link, but I can't post any yet)

Both issues happen on normal downloaded programs regardless of editing or converting.
post #137 of 156
Thanks for the steer agent.

I was thinking that it was something like GOP (group of pictures) and PTS (presentation time stamp) errors because I always record high quality. It seems that the RTV high Q, as opposed to the med Q coding introduces these types of errors for some reason, making the files non-mpeg2 compliant (this according to JimsTips.com, ReplayTV Tip #1).

(I can't URL here yet either, but Google Jim's Tips and you'll see the link to the info about GOP and PTS errors at the top of the home page)

Funny thing is, I have been using DVArchive since 'way back when' with my 4x machine, and never had the slightest problem with playback, although the earlier releases were not as stable or as slick as the current one.

I know there is a lot more for me to learn about all of this, so I definitely will be checking out your suggestion on the SourceForge DVArchive FAQ and this forum.

By the way, have you ever tried to control a (digital) cable box with a simple 1/8 in. mono mini jack (plugs into the same jack as the IR 'blaster), or to define the input device as a sattelite receiver (even tho it's a cable box) so the serial cable interface can be used to change channels.

I imagine that at least the serial cable would switch channels faster, and either one would be a cleaner looking way to interface the cable box than with the IR blaster.
post #138 of 156
Well, well, well.

I got the whole problem solved. Turns out you guys and the DVArchive programmers were right on the money.

I looked at the "the "linkie-poo" in post #35 of this thread", and the first thing that interested me was the slow connection remark by Jeff D. So then I looked at the
SourceForge FAQ's and went to work on a couple of the suggestions about how to optimize my network efficiency.

In the "Playback FAQ's", I found that a "Windows Person" had had some luck with pinging his PC to RTV connection to find the maximum MTU, (mine turned out to be 1470), and then did a few regedits to optimize for the value.


In the 'General Troubleshooting FAQ's', I found that someone named John Nadu had run Dr. TCP and changed the MaxDuplicateACK's to 2, and that he turned off TimeStamps as well, both of which I eventually did. It turned out that the third regedit, for TimeStamps and for WindowScaling, (Tcp1323Opts = 3) may have been superseeded by the Dr. TCP changes, which I did second, and which returned TimeStamps to off.

Then,...

I also updated my Linksys Router's firmware, and changed/enabled the MTU there to the same value (1470) as my regedit, then rebooted.

And all's well with the world.


I didn't have any luck with just the tweaks from the "Playback FAQ's", which I did first, but when I found the "General Troubleshooting FAQ's" Dr. TCP optimizations, everything started to work great.


I never noticed the fact that the tab for "Served Shows" in DVArchive shows two streams for the 5040 shows and a single stream for a 4040 show until I started working on this problem.

This may be why the program never stressed the ethernet network until I started trying to run my new 5040/rtvedited shows.


By the way, the show that I rtvedited and streamed to the 5040 was from "The Discovery Channel" "Shark Week" entitled "Anatomy of a Shark Bite".

It's really a fairly good documentary. It seemed a little gratuitously violent and gruesome at first, but after watching it a few times, some of the statements and ideas that the scientists, engineers and victims had held a few very interesting insights. Not gimmicky at all in retrospect.

This is a show about the scientist Dr. Eric Ritter, who waded with Bull Sharks even at night and where there is lots of chum, for such a long time finally got bitten.

I remember when I was a kid in Florida there was a shark fishing tournament and the paper reported that the winner was a fisherman who caught a 1000 lb. Bull Shark FROM THE BEACH, IN THE SURF, probably a 12 footer since the 8 ft. fish that attacked Dr. Ritter was estimated to be 400 lbs and almost killed him.

And I used to swim there all the time, right next to the fishing pier when I was a kid. I guess I did have enough sense, even as a kid, to keep my eyes open for fish (prey) and for sharks of course, and not to swim in cloudy water. Not because I knew that that was unwise, because I also swam in the Bayou, which had tannin in the water and was dark even in the day, but because I was a little squeamish about crabs, jellyfish, and seaweed etc.

Lucky me I guess, because back in the late 60's there were a lot more sharks and fish in the water than there are now.
post #139 of 156
Thread Starter 
The third release of the toolkit has been released:

http://www.avsforum.com/avs-vb/showt...hreadid=301591
post #140 of 156
I ran rtvedit against a 4k file using the edl4k (conversion to 5x) option.

The file is a Hi Q stream. (I know Med. Q streams are most compliant)

The third line (command line interface) after "Source:...", and "Target:...." is:

"ndx entry has invalid offset (000000362C), skipping...."

All of the edit points after that are advanced by 000:00.555.


The edit points were all key frames found by using VDubMod.

Any one know how this error arises, and/or how to fix it.



FYI:
Dr. DivX will transcode the resulting file, but crashes when selecting "Advanced Options", however it will run in "Certified mode" with no modification to the settings. The Source file is 5.5GB, the rtvedited/converted file is 4.08GB, and the Dr. DivX file is .978GB (Hi-Def certified default settings). Dr. Divx ran at about 30fps.

The same rtvedit/convert file transcoded by VDubMod and DivX Pro 5.1 plays back (on the PC) blocky/pixelated on scene changes. I can't rule out the codec settings, but I can't rule out the source mpg either as it crashes Dr. DivX (see above).

Perhaps a Med. Q file will work better.
post #141 of 156
Hi Lee...

I have been trying the rtvconvert tool to create videos to send back to my ReplayTV 5000 for the express purpose of playing MP3s on my stereo. There are problems (see: <guess I can't post a URL yet, just search this forum for rtvtools and look for a thread about MP3s> ) but I was able to get a short clip of music to my ReplayTV 5000. Currently this is a batch process - 1 MP3 at a time. What I would like to eventually do is stream MP3s to the ReplayTV 5000...

...is there a chance you could persuade your friend to create a version of rtvconvert that would accept standard in and out so as to enable development of this project?

...thanks

==================
added Sep 30, 2003

A friend of mine pointed out that "named pipes" may be used with programs which do not accept standard input / out options. Has anyone done this with "rtvconvert"?

Also, is there something somewhere to read about the 3 files rtvconvert creates. Specifically the ".evt" and the ".ndx" files.

I am interested in creating something that can be spooled to a ReplayTV 5000. My thinking is that the .evt and .ndx files are only initially needed by the machine serving the video and the only file really needed is the video it's self (i.e. the .mpg file). Can anyone comment?

...thanks
post #142 of 156
Hello again, did some more scripting. Bad news is that rtvconvert doesn't look like it allows "named pipes" (i.e. it probably creates the files it writes to). I used something along the following lines of script:

mkfifo -m 660 stream1.mpa
mkfifo -m 660 stream1.mpg
mkfifo -m 660 stream1final.mpg
mkfifo -m 660 stream1final.edx
mkfifo -m 660 stream1final.evt
mplex -f 4 -S 680 -o stream1.mpg test2.m2v stream1.mpa &
rtvconvert stream1.mpg stream1final.mpg &
cat music_clip2.mp3 | lame --mp3input --decode - - | mp2enc -v 0 -r 48000 -b 192 -s -o stream1.mpa

...which didn't work. I then did...

mkfifo -m 660 stream1.mpa
mkfifo -m 660 stream1.mpg

mplex -f 4 -S 680 -o stream1.mpg test2.m2v stream1.mpa &
rtvconvert stream1.mpg realfile1final.mpg &
cat music_clip2.mp3 | lame --mp3input --decode - - | mp2enc -v 0 -r 48000 -b 192 -s -o stream1.mpa

...which works but produced real files (not named pipes) as the output of rtvconvert. Is there a possibility of creating an rtvconvert program that either can take standard in / out or at least use named pipes?

By the way, please point out any errors I may have made w.r.t. the above scripts.

...thanks
post #143 of 156
I've skimmed this thread from beginning to end, and perhaps I'm missing something, but I can't see a concise comprehensible explanation of how & if this tool helps me get non-ReplayTV mpegs (e.g. from DV home video, or mpeg files downloaded from the internet (no NOT porn! ;-)) into DVArchive so I can stream them to my Replay 4000 box...???

Thanks

Mike
post #144 of 156
Thread Starter 
Not on the 4000 but on the 5000 yes -- and there's a newer version of the toolset. (Look for the 'version 4' version of this thread).
post #145 of 156
Thanks Lee... I've no intention of moving to 5000 any time soon, so I guess I'll have to be patient until it's back-ported, or get off my lazy butt and hack it myself! :-)

Or is there some non-trivial reason (to do with 4k vs. 5k formats?) why it hasn't already been done (i.e. too hard)?
post #146 of 156
Thread Starter 
Well the primary reason is agent-x does not have a Replay 4k.
post #147 of 156
Quote:
Originally posted by Lee Thompson
Well the primary reason is agent-x does not have a Replay 4k.
So, what if the 4xxx user community banded together and bought a 4xxx for agent-x? How much is this capability worth to 4xxx users?

Would the 4xxx unit need an active ReplayTV subscription?

Just a thought.
post #148 of 156
Thread Starter 
Well it would obviously need to be functional so it would need to be activated.
post #149 of 156
Quote:
Originally posted by Lee Thompson
Well it would obviously need to be functional so it would need to be activated.
Thanks for the info. I hadn't ever considered not subscribing, so wasn't sure if a unit could stream from DVA without activation -- enabling testing of rtvconvert'd streams. However, I totally neglected to consider that the unit would need activation in order to record shows, to produce native 4xxx show files for rtvedit development/testing.
post #150 of 156
This is my first attempt at using RTConvert, and I keep getting this error:

audio buffer overflow: len=66809

Here are the audio specs for my source file:
Audio : 10.12 MB, 224 Kbps, 48000 Hz, 2 channels, 0x51 = Mpeg-1 audio Layer 2 [0xc0], Supported

What's wrong?
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: ReplayTV & Showstopper PVRs
This thread is locked  
AVS › AVS Forum › Gaming & Content Streaming › ReplayTV & Showstopper PVRs › More New Replay 5000 Software Toys!