or Connect
AVS › AVS Forum › Video Components › Home Theater Computers › IDE controller issue. Please help.
New Posts  All Forums:Forum Nav:

IDE controller issue. Please help.  

post #1 of 12
Thread Starter 
You probably won't like my advice: stay away from Via.
PCs are hard enough...
I use only Intel chipsets. That also means I have to use Intel CPUs, but they are not bad. I guess they may be a little slower than AMD but I think it's very important to have device drivers that work and in this field (HTPC), Via and Ati have a lot of trouble getting along.

I setup a computer with a Via chipset for a friend and it gave me no end of grief.
post #2 of 12
Another basic question: any configuration change (hardware, Windows Update, Scenalyzer Live) before the problem? Or is the only manifestation a 95% full disk?

What motherboard? Are primary and secondary IDE channels on mobo? What model removable drive tray? For each IDE channel, what is the device type (disk, DVD), manufacturer, model, and speed (ATA-33, 66, or 100)?

(heh, not that answers would allow me to pull an answer out of my magic hat)

I like your idea to eliminate removable drive trays from the test environment; fewer connections will simplify the equation.

You could try upgrading the motherboard BIOS (though if this doesn't solve problem, you've now contaminated the test environment).

Cables. Not my final answer but imperfect cables have hosed me. I use Granite Digital for high quality SCSI cables; haven't tried their IDE cables. No answers but at least it's bumped to the top. http://www.avsforum.com/ubb/smile.gif

..Mike

------------------
Newbie snacks in the meta FAQ ; helpÂ*Â*Â*<FONT face="Lucida Console"><FONT COLOR="LimeGreen">fight</FONT c> leukemia </FONT f>

[This message has been edited by miksmi (edited 06-09-2001).]
post #3 of 12
Also maybe make sure it's not one of those drives that boots slower. If you have the fast boot option turned on in the bios then sometimes it tries to acces the drive before it is ready. There's usually an option to go slower or do memory tests more times on boot.

- Tom

------------------
Getting started:
HTPC FAQ , DScaler , Xcel's Links .
post #4 of 12
Ummm. I had the same problem awhile ago. Power off and get a new IDE cable and reconnect everything. Also, switch your power leads around while your at it(can't hurt and might prove a power cable problem). Then, come up in safe mode (if running Win 9X,Me) and delete all drives. Reboot and come back up, after redetection and a reboot, it should be fixed.

My problem stemmed from using a damaged and/or non-ATA spec IDE cable. It had me bogged down for days!

You could also be having an IRQ problem, but I doubt that. There would be a good case for that if you had onboard RAID or aftermarket RAID card. But without such, that's rare.
post #5 of 12
pngai: It's an Intel 450 MHz Slot 1 CPU. At the time, only VIA supported the 133 MHz FSB. I've seen many others echo your advice about Intel, though. Fool that I am, I am about to try an AMD Duron with Via chipset as a second PC. At least that's still within the Fry's return period...

miksmi:
Configuration change? Not immediately prior. Boot issue has been ongoing for several weeks. HDD performance issue appeared suddenly. Actually the system has been evolving considerably: new Aureal 1500 sound card (replaced SB AWE64); new Radeon LE card (replaced AIW128); added 1394 card. But I don't think IDE problem was coincident with any of these changes. And, noteworthy is that Scenalyzer Live had been fine on this HDD with that configuration for more than a week.

95% full only? No, I deleted stuff down to 40% full. Same issues. Also, other HDD on 2nd ctlr, WD 10G, has same problems, although it's 75% full.

Mbd: Iwill VD133 contains both IDE channels. Drive trays are Genica brand UDMA & ATA 33/66/100 ($7.50 at Computer Geeks). They've been installed for over a month.

Primary IDE ctlr has Maxtor 40G 94091U as Master, WD 60G 600AB as Slave (no problems). Secondary IDE ctlr has WD 10G 102AA as Master, WD 60G 600AB as slave. All are running as UDMA66 because that's what Mbd ctlr supports.

Motherboard BIOS was re-flashed about 2 weeks ago to try to fix no-secondary-disks-at-Reset-except-PwrOn. It had no effect, but I'll look to see if there's yet another update.

Cables is a good idea. I have a couple new ones from new 2nd CPU target Mbd.

trbarry:
Slow boot? Good idea. I'll poke around in BIOS at next reboot (Power cycle).

Well, folks, I appreciate your generous consideration of my tale of woe. Unless Tom's idea pans out though, it looks like I'll actually have to do some work.

Edit:

bdschuler: Sorry I missed your post while typing. You've got me suddenly full of renewed hope! Thanks!

Rebooting now...
End edit.

Thanks for the suggestions.

-yogaman

------------------------
Power cycling: It's not just for bikers anymore.

[This message has been edited by yogaman (edited 06-09-2001).]
post #6 of 12
That is an excellent signature.
post #7 of 12
Miksmi: Thanks for the sig compliment. I guess I should thank the gods for this hassle that provoked it.

Disk Issue Update:

Cable change had no effect.

Disabling Quick POST (or reverting again to AUTO drive type recognition by BIOS) caused BIOS to recognize drives on secondary Ctlr after Ctl-Alt-Delete, Reset Switch, and Windows Reboot and Power cycle. Only observable slowdown happens after power cycle, and that was finding the drives before, but BIOS is finding them now, so I'm not complaining. (Except after removing the Caviar 60G; see below.)

Checked Iwill website and found that they've only posted v4.30 of VIA drivers, so I installed them. No effect.

Found that ATAPI drivers weren't installing from Setup.exe supplied by VIA drivers v4.30 or v4.31, so I manually installed each a few times. When VIAVSD.INF file was changed, I was able to get the secondary controller to be recognized and remove it's "?" Error Indicator from Device Manager device display (until reboot). BUT...
1. HDDs that now appeared under Disk Drives were Type 2 (Caviar 10G) and Type 95 (Caviar 60G). Once upon a time when things were working, these were Type 47. They're configured as AUTO in BIOS.
2. DMA is disabled on all drives after new driver installation. Enabling only takes effect after reboot.
3. An Unknown Device Found message appeared. Windows hung while searching for a driver for it. (Suggests soon step should be to remove cards from PCI bus.) No driver found, so it got the familiar yellow "?" Error Indicator.
4. Rebooting with or without enabling DMA for any HDDs causes "?" Error Indicator in Device Manager to come back for Secondary Bus Master IDE Controller. Back to Square 1.

Physically removing the Caviar 60G from IDE1 (secondary controller) causes BIOS not to recognize the remaining Caviar 10G on IDE1. (Suggests soon step should be to try some other drive by itself on IDE1.) Windows still shows "?" for 2ndary IDE Ctlr, but Win Explorer still finds drive, although drive letter now is moved from before IDE0 Master's 2nd partition to after. Caviar 10G attached to IDE1 still doesn't appear under Device Manager Disk Drives.

I'm now backing up the contents of the 10G. Will try any suggestions after that.

Thanks for your interest.
-yogaman
post #8 of 12
Well, the backup didn't complete because the target drive didn't have enough space. (I selected the wrong drive when I set up the copy. Oops.)

But the good news is I finally traced it down to a particular HDD that would cause the secondary IDE controller Windows driver to get a Device Manager "?" Error no matter where it was plugged in (except I didn't test Primary IDE Controller Master). Yes, even when it was plugged into the Primary Controller cable, the WinMe Secondary IDE driver reported a problem. (7 drives in 3 positions could have been 210 combinations. I got it in 12, so I should feel lucky, I guess.)

The solution was to repartition and reformat the drive.

(It's been that kind of day. During this process, PacBell's San Francisco DNS server went down. Arghh! AVSForum withdrawal! Plus now I get to restore my IP Address and Gateway because they made me take the router out of the loop to troubleshoot. Sigh.)

Edit: I see I neglected to report one of the remaining confusing points. The problematic drive was formatted with Western Digital's Diagnostic diskette. Apparently, the default installation causes the Active Partition flag to be set on the disk. When I used MS fdisk to repartition the disk, the Active flag was cleared, of course, because fdisk enforces the rule that only IDE0 Master drive can set an active partition.

The confusing aspect is that I have another WD600AB drive bought one day earlier, also formatted with WD's diagnostic diskette, also with the active partition bit set. This drive does not interfere with the rest of the system in any way I can detect, regardless of its position on either IDE controller (IDE0 Master not tested, of course).

The only difference I can find between these two WD600AB's is that one is MDL: 32BVA0; other is MDL: 60BVA0. Two other tested WD600AB's were both MDL: 00BVA0.

But unless I have future problems, I'm willing to let it go.

I'll plan to delete this thread in a couple days, assuming I remember. I think it's unlikely to be of interest to very many people (VIA chipset, WD Caviar partitioned and formatted with WD tools, WinMe: how common can that be?)

-yogaman

[This message has been edited by yogaman (edited 06-10-2001).]
post #9 of 12
First off let me apologize to Western Digital for casting doubt; the WD600AB HDD that I ScanDisk'd ( Better ScanDisk? ) is fine; ScanDisk eventually reported zero errors.

However, the problem has not gone away. I've now discovered that Windows Me Device Manager reports that the Secondary IDE controller (dual fifo) is either not present, not working properly, or does not have all the drivers installed. (Code 10.) When I try to Update Driver, it told me I had the best driver already insalled.

So, I downloaded the latest 4in1 (v431) from Via, and installed it. The only effect that had was to turn off DMA for the drives on the primary controller.

Neither of the drives on the Secondary IDE controller currently appears in the Device Manager Disk Drives list. However, both appear in Windows Explorer listings.

One more puzzling feature is that when I reboot via Windows, or via Ctl-Alt-Delete, or via front panel Reset switch, BIOS doesn't find drives on the secondary IDE controller. When I power off momentarily, the drives are found by BIOS. I've tried letting BIOS auto-detect, and I've tried User-defining the BIOS drive types.

I'm using drive trays. I will try to remove them. I can try booting without any drives on the secondary channel, then putting the drives back one at a time. I can try stripping out all other I/O cards from the PCI bus. But I haven't seen this type of problem before. Could the IDE controller really have failed suddenly?

I am confounded. Any advice is appreciated.

-yogaman

[This message has been edited by yogaman (edited 06-09-2001).]
post #10 of 12
yogaman, glad it's working. FWIW I think this is a good diagnostic thread but I hear you about keeping the archives clean. I've saved it offline.

The solution was to repartition and reformat the drive.

Did the errant drive end up where it started (same channel, master/slave, and cable)? Also, were you using CSEL (cable select) or were you setting the master/slave jumpers? Just curious as I've read CSEL misbehaves sometimes.

..Mike
post #11 of 12
Yogaman,
You may not be completely out of the woods yet. Never use Maxtors EZ-Install to format a drive. It is a proprietary program that doesn't like Microsoft. Trying to get rid of it can be fun...but there is a tech doc on their site for removing it. But once used, it can make life easy or difficult for you depending on what you plan to use the drive for. In multiple drive systems, it causes problems. I personally ran into problems with it many times in the past.
post #12 of 12
Miksmi:

Good point about putting it back where it started. The answer is, "Yes."

Briefly, I had one of the uninvolved Maxtor test drives using CSEL, but then I accidentally plugged it into the IDE0 Master slot, when there was already a jumper-selected Master on IDE0, so neither HDD was recognized. I recognized this fairly quickly, and moved the Maxtor jumper to Slave. All other testing was done with explicit jumper selects. (As a result of the back and forth jumper selecting, none of my drive carriers have screws securing the drives in the cases anymore.)

Bdschuler:

So, why does WD ship the utility, I wonder? Weird that it's OK on one HDD (so far anyway), but was a problem with the other. Both drives are presently installed, and both have been tested in all IDE0 Slave, IDE1 Master and IDE1 Slave positions, with various other drives. Just weird.

Thinking about it, maybe I won't delete this thread. How about a poll?

-yogaman
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Home Theater Computers
This thread is locked  
AVS › AVS Forum › Video Components › Home Theater Computers › IDE controller issue. Please help.