or Connect
AVS › AVS Forum › Gaming & Content Streaming › ReplayTV & Showstopper PVRs › Upgrade failed - Stuck on "Please wait..."
New Posts  All Forums:Forum Nav:

Upgrade failed - Stuck on "Please wait..."  

post #1 of 30
Thread Starter 
Everything went smoothly with RTVPatch (off a Win98 box), using a Maxtor 40 GB.

Until I put it back into the Replay! Then it just sits on "Please wait a few moments..."

I tried jumper settings: Master, slave, cable select... No dice.

Tried patching it again. Well, FYI, RTVPatch said the 40 GB was a "Replay Drive" but I mirrored it again anyway from the original. Same problem.

I found a few other threads about this problem, and not a single solution.

I suppose I may try another hard drive... this was one I bought a few months back for a PC but never ended up using (figured, what the heck http://www.avsforum.com/ubb/smile.gif)... Oh well, nothing LOST... except 2 hours of my life.
post #2 of 30
I had a similar problem. Very important always make sure ac power cord is unplugged before connecting hard drive into the replay. Removing the disk with power on does not corrupt data it's the reinstallation into the replay unit. Does original hard disk boot if so try the rtv patch again. If your original disk will not boot as well I would suspect you may have plugged it into the replay with ac power plugged in and corrupted the data. It is a good idea to zero out the new disk before using in the replay. Maxtor disk will boot from master jumper setting. Because you say your maxtor shows up as a replay disk under rtvpatch suggests you did the copy and patch correctly. I assume you hooked up the power connecter correct and red stripe on the ide ribbon goes towards the power connector.
post #3 of 30
When you tried to patch it again, did you first restore the original drive from the backup then try the process over again?

Were you adding a 2nd drive or replacing the original?

------------------
:)
post #4 of 30
Thread Starter 
The AC plug was nowhere near the unit when touching the drive, ever.

Replacing the single drive.

I didn't go back to the 'backed up' image because the original drive still worked fine.

------------------
Si hoc legere scis numium eruditionis habes
post #5 of 30
Thread Starter 
Any other help?
post #6 of 30
Randy,

Do you get one blue "Please wait a few minutes" screen, followed by another please wait screen with the Replay / Panasonic logo on it, or do you just sit at the first blue screen? Does it eventually turn off or reboot after a while? How many times have you hard booted it before determining that the upgrade failed? When I hacked my 2020 to a 2060 (with an 80 Gig drive before the 80 gig images were determined), I think I had to reboot it 5-6 times before it finally came up.

I also remember that, when trying to figure out the right checksums for the 80 gig patch, I put in a drive several times that had the wrong checksum (so it wouldn't boot). However, when examining the drive after taking it back out, the contents of the drive had been changed in numerous places (which supports the theory that the patch does not necessarily do everything required to put the Replay into the right state, but that it does enough that the Replay will usually repair the rest on its own.)

There's still some magic about the hack that we don't necessarily understand, which is why sometimes it doesn't work. If many reboots don't help, maybe the partition size calculated by the RTVPatch program is one that the Replay doesn't like for some reason. If you feel like going high-touch, you could try to dig up one of toot's initial revisions of the Win2k RTVPatch, before she added the capability to auto-detect the size of the drive. It allowed you to enter the size you wanted your data partition to be. You could try lowering the size by a meg or a gig and see if that gets you anywhere.

And if you're really feeling generous, you could save the image that doesn't work, so when you're able to get a working image you can compare them and see if you can determine why it didn't work for you. And then someone could improve the patch program to fix that problem.

Or, if you're feeling low touch, you could buy one of the 60 or 80 gig drives that everyone else has been using. (And if it still doesn't work, then we'll wonder about your original Replay drive...)

Good luck,
--Joe
post #7 of 30
Thread Starter 
It sat at the "Please wait" for 20 minutes each time...

Are you suggesting I should reboot it to this screen a bunch of times? If so, I'll try that tonight.

------------------
Si hoc legere scis numium eruditionis habes
post #8 of 30
You may want to check/swap the ide cable.

Does the unit still work in the original configuration?

Ben.
post #9 of 30
Thread Starter 
Yep, the original drive went back in last night and everything's fine there.

Do you mean the cable config when I'm doing the patch on my Win98 machine? I can do that...

------------------
Si hoc legere scis numium eruditionis habes
post #10 of 30
Quote:
Originally posted by RandyL712:
It sat at the "Please wait" for 20 minutes each time...

Are you suggesting I should reboot it to this screen a bunch of times? If so, I'll try that tonight.

I think it should go from blue "please wait" to Replay "please wait", and then shut itself off. Then when you turn it back on, it should be working correctly. I think I had to reboot mine manually several times before this happened.

The sourceforge log says that the (f)orce option has been added back into the Win2k version of RTVPatch, so if you can get access to a Win2k machine, you could force the drive to a smaller size and see if that shakes it loose.

Diagnosing this type of problem will be hard unless you want to get your hands dirty. You could use dd to pull off the relevant sectors and see if they contain the expected values. You can calculate the expected values with a calculator and a look through the original "60 hour hack for the brave" thread from when patch files and dd were the only way to do it. And although I'm sure you've already looked at it, you could also re-read the summary of what is known about the filesystem: http://rtvpatch.sourceforge.net/omfs.html

Good luck,
--Joe
post #11 of 30
Anatomy of a failed upgrade:

2020 20 GB Quantum Hard Drive Master
New 80 GB Maxtor Slave

RTVPatch (GUI) takes about 5 minutes to display menu
After each setting choice RTVPatch takes 5 minutes to refresh drive listing
Made backup of Quantum
Tried to copy partition from Quantum to Maxtor (get read error)
Tried again (after reboot), read error
Restored backup to Maxtor, works
Put in Replay, works

Two days later, with 80+ hours, try first high quality 1 hour program, drive goes nuts, clicking stuttering, pretty much dies.

Try new Maxtor in another machine, RTVPatch appears to work much better in this machine, no 5 minute wait for drive listing to come up. Restore previous backup to target drive. Put new drive in Replay, stuck on "Please Wait"

Repeat whole procedure in second machine, put in replay, drive has worked great so far (only two days so far)

Conclusion. RTVPatch wasn't compatible with first machines configuration for some reason (Windows 2000 SP 2, Dell 1 Mhz P III)

Second machine (Windows 2000 SP 2, Dell 1.7 Ghz P 4)

Don't know if any of this helps, but my suggestion is to try a different W2K machine if you can.
post #12 of 30
This is important - The bootup drive must be recognised as master by replay. Put your new drive in your computer. Go into BIOS and see if it show up as master or slave. The reason I ask is I screwed up an IBM hard drive using replay (because I plugged it in with replay powered up). The IBM showed up in bios as slave even though it was jumpered as master and was the only hard drive connected to the primary IDE. I was able to repair the disk with IBM software available at their web sight.
post #13 of 30
Thread Starter 
Still no luck, did it again, this time copying the 2nd partition (shows) as well.

WEIRD: Even though I had deleted EVERY show off the Replay drive, it still had 12 GB to copy from partition two! Explains why the damn thing is so slow lately! Empty the trash bin and defrag, Replay http://www.avsforum.com/ubb/smile.gif

Anyway, still no luck. Rebooted the Replay (with the 40 GB) endless times... Always the same sound. Put the replay drive in, it immedaitely works.


I guess I'll try it from a Win2K computer, but my hopes are already dashed on this.

------------------
Si hoc legere scis numium eruditionis habes
post #14 of 30
Its the drive jumpers or the ide cable. email me if you still need help.

------------------
- CosmoK
"I want my RTV"
post #15 of 30
Thread Starter 
Which IDE cable - the one on my PC or the one in the Replay?

------------------
Si hoc legere scis numium eruditionis habes
post #16 of 30
Thread Starter 
I am suspicious of the jumper setting also, but as Maxtor tells me to, this is the setting I've used:

http://www.dvrcade.com/masterjumper.jpg

It's a Maxtor 40.9 GB Hard Drive, Model 34098H4.

Again, everything seems to be perfect until I put it in the Replay. And the original drive still works fine. I've tried resetting the partition, etc., no dice.

I'd love to find a solution!

[This message has been edited by RandyL712 (edited 07-29-2001).]
post #17 of 30
Randy that's the correct jumper setting for master. That's what I used on my 60 gig conversion which works just fine.

It was slave while in the PC for the brain transplant though...

No I don't remember a 12 gig xfer for the partition that you noted.

EZ Bake still on....

------------------

Come on in, the Radiation's fine!
post #18 of 30
Thread Starter 
Anyone else with a possible solution? This stinks http://www.avsforum.com/ubb/frown.gif
post #19 of 30
Did you select the option in RTVPatch to "wipe the MPEG partition?" That might help.

Also, using the command line version of RTVPatch, you could try specifying a different drive size (make it smaller than what's detected automatically) and see if that helps.


------------------
Daniel M. Zimmerman
Caltech Computer Science
post #20 of 30
I ran into this problem yesterday on my first attempt to upgrade using the new Maxtor 100gig drive. On my second attempt, I was successful. I changed a few things on my second attempt so, I cannot pinpoint the exact problem. In both attempts I used the W9x bootable floppy upgrade method. I will detail the steps I did on each attempt:

ATTEMPT #1
I connected the replay drive and the new 100gig drive to my PC and discovered that my Award BIOS would not recognize the 100gig drive. So, I installed it with EZ-BIOS. This was a mistake as I later learned. However, I was able to get the upgrade program to recognize the drive by configuring the drive definition in the BIOS to NONE. I proceeded to do the upgrade in the following sequence: 1) mirror partition 1, 2) mirror partition 2, 3) apply the patch without reinitializing either partition table. Everything went fine and the upgrade program recognized my 100gig drive as a REPLAY drive. I transferred it to the REPLAY box and when I powered it up, it constantly hung at the "Please Wait A Few Moments...". I tried some of the suggestions in this thread. I rebooted 10 times. Nothing. I redid the patch, no help. I decided to start over completely from scratch.

ATTEMPT 2
Since I originally installed the drive with EZ-BIOS and later read that was a big no-no, I decided to wipe the drive clean first. I ran the low-level formatter POWERMAX first. Then I redid the upgrade in the following sequence: 1) mirror partition 1, 2) apply the patch and reinitialize the MPEG partition table. I popped that sucker into the REPLY box and, bingo, it came up!

SUMMARY
Here's the differences. I made sure EZ-BIOS was not a factor by reformatting the drive. I said the hell with trying to save any existing shows (it took four hours to copy the MPEG partition in the first attempt and there was no way I was going to do that again). I reinitialize the MPEG partition. Was one it one of these, a combination of two, or all three? I will never know. But, it works and I am happy. I know your pain although I only experienced it for a few hours and hopefully, this helps.
post #21 of 30
FWIW. Try the following: A. See if your Maxtor 40GB can work as bootable PC drive. B. If A works, delete all DOS and non-DOS partitions from Maxtor and repeat your upgrade process.

Instructions for above A:
1. Make a Win98 DOS boot disk. Make sure you copy FDISK, SYS, and FORMAT files to the floppy also.
2. Disconnect all hard drives but the Maxtor from your PC.
3. Boot your PC with the floppy.
4. FDISK and delete all partitions from Maxtor.
5. Create Primary partition using all available disk space and make partition active (option 1 I think)
6. Exit FDISK and reboot with floppy.
7. FORMAT the Maxtor. C should be the only drive.
8. Do a SYS C: to make the Maxtor a system drive.
9. Remove floppy and reboot with the Maxtor drive.

Instructions for above B:
1. Boot your PC with the floppy.
2. FDISK and delete all partitions from Maxtor. DO NOT create new one.
3. Exit FDISK and shut off PC.
4. Connect the appropriate hard drives to your PC and repeat the upgrade process.
post #22 of 30
I upgraded mine on Saturday morning -- using a Western Digital 60 gig drive (5400 rpm). And I was pleased that everything worked exactly as the direction said that it would. My only suggestions would be to make sure that after you mirror both partitions, you then apply the patch.

Copying took quite a bit of time -- but it went well. I'm very grateful to those that contributed to the Win2K RTV Patch project.

I basically went for the upgrade to go with a higher quality, not for more recording time. I'd be happy to offer any help that I might be able to.
post #23 of 30
Tip with the utilities that help older machines deal with big drives... That's written in the Master Boot Record of the drive. Best bet would be to hook it into a machine that's running Win98 or DOS ... and run FDISK with the /mbr command line option to ensure that all traces of it are removed. (Ensuring, of course, that the machine that you attach it to isn't running any such program.. booting from the Win 98 Setup disk or a DOS floppy is a good bet here)

Then go at another low-level format. That should restore the drive to like-new state. Those programs can be as tough as a virus to get rid of.

Hope this helps.
post #24 of 30
Thread Starter 
I can't imagine the problem... I've now done this upgrade like 10 times without luck.

The drive always works fine in my PC, but put it in the Replay and it's like the jumper settings aren't right! I've tried everything listed in this thread without luck.

How odd!
post #25 of 30
This is a bit of a shot in the dark, but have you tried jumpering it for cable select and trying it? If all else fails... you never know. I've seen weirder. Another thought is could you try a different IDE cable. Maybe swap the cable from your PC into the Replay temporarily to see if that makes a difference.

------------------
Technology Rules!
post #26 of 30
Thread Starter 
Has anyone else had this happen?? I've tried every possible jumper setting, done RTVPatch so many times I can't count... the unit just sits there pretending it doesn't have a hard drive attached!

It's a normal 40.9 GB Maxtor 34098H4 5400 RPM hard drive... I bought them in bulk for business use and had one left over that I never used until this... I'm just out of ideas. I set it up as a regular PC HD and it worked fine. I wish I had another drive sitting around to try.
post #27 of 30
Thread Starter 
I'm going through a bit of labor to swap the drive with an identical model from a server I have. We'll see if the new drive has the same problem (it better not! I'm tired of this crap http://www.avsforum.com/ubb/smile.gif)

------------------
Si hoc legere scis numium eruditionis habes
post #28 of 30
Thread Starter 
And so the saga ends... I tried it on an indentical HD and it worked! Everything was done exactly the same way... I guess some drives just don't like Replay.

------------------
Si hoc legere scis numium eruditionis habes
post #29 of 30
Randy, I'm glad you got the upgrade to take. I can't help but ask. Many moons ago I suggested to you your failed upgrade was due to the drive being recognised as a secondary despite being jumpered as master. This is proven by checking the bios of your computer with that drive connected. If it is identified as master then I'm off base. If I'm right and that drive shows up as secondary then running the particular brand disk repair program would repair it. Just curiuos.
post #30 of 30
Randy,

Sticking on the "Please wait a few moments" generally means either the drive is not recognized, the partition table is screwed up, or one of the two partitions on the drive is screwed up. The most likely cause is a screwed up MPEG partition.

What you can try is run RTVPatch, and copy your working drive to the new drive (the "s", "t", then "m" commands), and say "Yes" when it asks if you want to reset the MPEG partition. Do not do the patch operation, just the copy (mirror 1st partition) operation. In the terms of http://rtvpatch.sourceforge.net/linu...e_upgrade.html , do everything except step #19.

This will make a duplicate of your current drive on the new drive, with the only change being the reset of the MPEG partition. Then try out the new drive in your ReplayTV. If this works, the free space remaining should match the size of the original drive. If you can get this to work, then put the drive back in your PC and do just the patch operation ("t" and "p" commands) which will adjust the sizes to match the drive size.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: ReplayTV & Showstopper PVRs
This thread is locked  
AVS › AVS Forum › Gaming & Content Streaming › ReplayTV & Showstopper PVRs › Upgrade failed - Stuck on "Please wait..."