or Connect
AVS › AVS Forum › Video Components › DVD Players (Standard Def) › Denon 3910 Owners Thread
New Posts  All Forums:Forum Nav:

Denon 3910 Owners Thread - Page 242

post #7231 of 7503
Quote:
Originally Posted by rvanya View Post

I The denon website mentions that their latest firmware on the site allows for denon link 3. I have that on my player menu so does that mean I have the latest firmware?

I think so...
post #7232 of 7503
Quote:
Originally Posted by rvanya View Post

So what should the settings be?

Try changing the "player mode" from video to audio.
post #7233 of 7503
Quote:
Originally Posted by mvaarani View Post

I must say I've never had so much trouble with any audio device that I've had with my 3910. The quality of Denon products seems to be just pure crap.

Thank you for your one person survey.

My 14 year old Denon DCM-444 CD Changer is still going strong along with my 3910 and 4806.
post #7234 of 7503
I checked that yesterday and it was on audio. I will check again to make sure. I easily could have changed it. The only reason I was looking though was because it stopped playing. We'll see though.

So does anyone know if there is a different laser assembly for different discs. Or does the laser focus on a different area depending on the disc?
post #7235 of 7503
Quote:
Originally Posted by JohnGZ28 View Post

Thank you for your one person survey.

My 14 year old Denon DCM-444 CD Changer is still going strong along with my 3910 and 4806.

I have had a 3910 since they first came out over here...... never had even a minor issue with it. It still looks and sounds magnificent and has had heaps of use too
post #7236 of 7503
After I re-initialized my player for reasons described in an earlier post, I noticed some very odd behavior. First, there was almost no sound from the surround channels coming from the analog outputs. Second, I could not get any sound at all from my digital output (coax). Third, many of the menu options in the Denon setup screens were grayed out, such as the ability to change rating levels (a feature I've never used) what color the "wallpaper" was to be, and others.

I could not figure out what happened... I then turned on DenonLink 3 on my Denon AVR to see if I could get digital sound, then turned on Denon Link 3 on my 3910. The digital sound then worked fine, and the menu items were all selectable. I reverted back to my original digital connection (coax). Now the coaxial output was working, surround sound was also fine using the analog outputs, and the 3910's setup menus were as normal.

So can anyone explain what might have happened here, and why turning on DLink and then turning it off again fixed this odd state of affairs???
post #7237 of 7503
Quote:
Originally Posted by btiltman View Post

I have had a 3910 since they first came out over here...... never had even a minor issue with it. It still looks and sounds magnificent and has had heaps of use too

Well, good for you. Mine was repaired three times during the 12 month period after purchasing the player - and every time for different reasons... So, when I compare the quality of the player to any other audio device I've owned during last 20 years this has been absolutelly the worst. For me that tells a lot of the quality..
post #7238 of 7503
Quote:
Originally Posted by mvaarani View Post

Well, good for you. Mine was repaired three times during the 12 month period after purchasing the player - and every time for different reasons... So, when I compare the quality of the player to any other audio device I've owned during last 20 years this has been absolutelly the worst. For me that tells a lot of the quality..

...and I saw a Roll's Royce broken down the other day too. *hit happens and its always possible to get a 'bad' one of anything. Sorry you had your problems! In my case its been the most reliable 'player' of any that I have owned.
post #7239 of 7503
Quote:
Originally Posted by mvaarani View Post

Well, good for you. Mine was repaired three times during the 12 month period after purchasing the player - and every time for different reasons... So, when I compare the quality of the player to any other audio device I've owned during last 20 years this has been absolutelly the worst. For me that tells a lot of the quality..

Then perhaps you should have stated that the quality of "MY" Denon product is crap rather than your blanket statement.
post #7240 of 7503
Quote:
Originally Posted by JohnGZ28 View Post

Then perhaps you should have stated that the quality of "MY" Denon product is crap rather than your blanket statement.

Agreed. The blanket statement was based on only a single data point. The only prediction you can make from that data point is that the person who made the statement won't be buying Denon equipment any more. I'm not seeing any general outcry concerning the reliability of Denon products here or anywhere else.
Now, when I had a Fiat (briefly) and everyone told me that FIAT was an acronym for "fix it again, Tony," that was a different story...
post #7241 of 7503
Everybody chill. He has had a bad experience and thinks that denon makes crap. Okay. He can have his opinion if he wants and there is no sense in arguing with anyone about it.

I came home today and tried to play the cd layer of one of my SACDs and it worked just fine. Double checked all of my settings on the player and then tried a redbood cd and it worked! Yay for me but I definitely have no idea why it didn't work the other day.

Any ideas left?
post #7242 of 7503
For what it's worth (single data point!) I bought mine new when they first came out and have never had any problems. Also own two Denon receivers and again, no problems.
post #7243 of 7503
Quote:
Originally Posted by pbarach View Post

It's definitely not normal to get a shock from any audio equipment at any time, on or off. If you are asking this question, my guess is that you don't have the knowledge to diagnose and repair it (I don't either). For the sake of your own safety, stop using the 3910 and take it for repair.

Found it! Wrong polarity at the power point connection for some of the equipment due to house shifting...All solved...
post #7244 of 7503
Denon 3910 had a number of problems after a couple of yrs. First, DVI-out stopped working, then transport. Because we are not yet excited about quality of Blu Ray players, we decided to send from CA to the Denon NJ facility - for real molasses service. They charge to look and either dispose or apply toward service. Took over a month for them to contact me that they had looked at it - and that only after struggling to get in touch with them by phone. Took another week or so to get them to confirm that they would fix both problems with their quote, and could only get an email about that. Another few weeks to get it shipped back, after they mis-noted my cc info and needed to verify again. Fortunately, my laptop is doing the job in the mean time, albeit without remote control or optimum sound. Should be here today. Will post if not working well.
post #7245 of 7503
Quote:
Originally Posted by lydiac View Post

Denon 3910 had a number of problems after a couple of yrs. First, DVI-out stopped working, then transport. Because we are not yet excited about quality of Blu Ray players, we decided to send from CA to the Denon NJ facility - for real molasses service. They charge to look and either dispose or apply toward service. Took over a month for them to contact me that they had looked at it - and that only after struggling to get in touch with them by phone. Took another week or so to get them to confirm that they would fix both problems with their quote, and could only get an email about that. Another few weeks to get it shipped back, after they mis-noted my cc info and needed to verify again. Fortunately, my laptop is doing the job in the mean time, albeit without remote control or optimum sound. Should be here today. Will post if not working well.

Sorry to hear that. I would PM DenonJeff about my experience.
post #7246 of 7503
I recently watched the DVD of "Persepolis," which I thought was excellent. My question is a technical one: Why would this DVD's menus (PLAY, CHAPTERS, SPECIAL FEATURES) display in Spanish rather than English? I have an American-purchased (region 1) DVD player, bought new from an authorized dealer. The player's SETUP screens show English as the language for menus.

This is the only DVD where this has ever happened, and I've owned the machine for nearly two years. When I put this disc in my PC's DVD drive, the menus were in English. There is no option on the disc itself for selecting the language. Any idea why this might have happened?
post #7247 of 7503
So far, so good... DVI and (obviously), transport working. Firmware updated. $300 and a TWO MONTH turn around.
post #7248 of 7503
I have 3910 hooked to a Denon 3805 over component. As I understand 3910 doesnt upscale in this case. I tried connecting my projector directly to 3910 via HDMI and set it to upscale. I cant notice any difference in picture quality which was surprising.

May be I am doing something wrong. Any ideas?
post #7249 of 7503
What kind of projector?

The non-crt projectors, like flat pannel tv's, all have a fixed native resolution, be it 720 or 1080. (Always p on a non-crt), They convert whatever signal you send them to their native resolution.

When you send 480 from the Denon or 1080 or 720 from the Denon, it always displays in the native resolution of the projector. It is just a question where it is upscaled.

Allen
post #7250 of 7503
Quote:
Originally Posted by Allen View Post

What kind of projector?

The non-crt projectors, like flat pannel tv's, all have a fixed native resolution, be it 720 or 1080. (Always p on a non-crt), They convert whatever signal you send them to their native resolution.

When you send 480 from the Denon or 1080 or 720 from the Denon, it always displays in the native resolution of the projector. It is just a question where it is upscaled.

Allen

I'm using a Sim2 HT300 projector. It is a DLP projector.
So I guess the upscaling abilities are about the same in my projector and DVD player.

Thanks for the explanation.
post #7251 of 7503
Quote:
Originally Posted by Kayess View Post

I'm using a Sim2 HT300 projector. It is a DLP projector.
So I guess the upscaling abilities are about the same in my projector and DVD player.

Thanks for the explanation.


That is one certainly one possibility. At any rate, the differences are not large enough for you to see on your screen.

How big is your screen?

Allen
post #7252 of 7503
Quote:
Originally Posted by Allen View Post

That is one certainly one possibility. At any rate, the differences are not large enough for you to see on your screen.

How big is your screen?

Allen

Believe 110 inches.
post #7253 of 7503
Hello,
Out of curiosity, would anyone with a black 3910 want to trade for a silver one? My player is mint with the latest firmware. Due to a change of processor and amplifier, my 3910 stands out in a sea of black.
Cheers,
AD
post #7254 of 7503
Is there a way to get the Denon 3910 to playback DVD-video chapters in the order that you want them to be played back (i.e. programmed playback)? I know you can do this with audio playback but it does not seem to work for video. Also, I know that you can set markers in the video so that you can jump to that spot/scene but if you set 5 markers is there a way to make the 3910 play those 5 clips or scenes automatically without you having to select each marked scene manually? Again, I want programmed play.

Thanks.
post #7255 of 7503
I have owned my 3910 for a little over 3 years now. Best dvd player I ever had.

I am finally going to hook it up with HDMI, will be getting a new 58" Panasonic 850U hopefully this week.
I have pulled out the manual and see that I need to turn on the hdmi output. Then the manual says I need to choose wheter the output is component output or rgb. Which one do I want?
Resolution wise, I figure on trying 720p and 1080i, see which one looks better.

Next dumb question. My receiver does not have hdmi inputs. I feed the digital signal from the dvd player via coax and the video goes to the tv alone. In this kind of setup, I DO NOT WANT sound from my tv when watching dvds. I get the surround from the A/V receiver. Is there a way to setup the hdmi connection so I will get NO SOUND from the tv when dvds are played?

Thanks for the help.
post #7256 of 7503
Steve,
I have a Panny plasma, too. (and a 3910)(and a 2500)
Re HDMI: on the 3910, choose HDMI Y Cb Cr and 1080i (top left 2 buttons on 3910 remote). No need to muck around with 720p.

Re Sound: Your plasma will have a menu item to turn yours speakers on or off. Choose OFF . Or press the "Mute" button on the remote when you turn on the TV.

--Ernie
post #7257 of 7503
Thanks, Ernie.

I'm dying to get the Panny in the house and get it going. I had a Pioneer Elite 610 (rptv) that quit a week ago. I got a pretty good deal on the 850, but the bad news is they are waiting on stock.

Appreciate the help.
post #7258 of 7503
Some time ago, I downloaded the firmware update from the Denon site, but never did anything with it. I read the instructions that came in the file and found that the Roxio version 7 that I have did not have the EXACT options that were called out in the instructions (Level 1 ROM disc). It does have the ISO format called out. Not wanting to risk damage to the machine, I never updated.

Now that I will finally be using the hdmi, I figured time to get it done. I sent email to Denon explaining as I just did here and asked if they could send me discs. To my surprise (and disappointment) the reply came "if you can burn a data disc, no problem". If this is the case, what was up with the detailed instructions? Beyond that, Denon can't afford to send a couple bucks worth of disc out to a customer?

In any case, does it sound safe to do what they now say is okay?

Thanks.
post #7259 of 7503
I originally had some issues burning the CD correctly, but finally made it.
The issue you might be facing has to do with how you do the upgrade
It is required to press some keys prior to inserting the CD or at the time you insert it, I really don't remember.
Also, the key sequence for european models was different than US models.
Denon, should have a document describing the process and that was important to follow to the letter.
I found my relevant document as one of the files that I had to download along with the firmware update
post #7260 of 7503
Steve5520, check this post
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: DVD Players (Standard Def)
AVS › AVS Forum › Video Components › DVD Players (Standard Def) › Denon 3910 Owners Thread